Recover a Bricked Wyze Cam V2 - Tried ALL Variables (demo.bin, sd card size, various firmware, longer wait times, etc)

I read through many posts on how to recovery a Bricked Wyze Cam. Specifically V2.

I have tried the following:

  1. Different firmware builds

  2. Different size SD cards (8 and 32)

  3. Different formats (exFAT vs FAT32)
    [Wyze Cam SD Card Format Guide] Need to Format SD Card for Wyze Cam? - EaseUS.

  • SD Cards 32GB and smaller - Choose FAT32.
  • SD Cards larger than 32GB - Choose exFAT.
  1. Changing name to “demo.bin” (I have tried various combos of leaving the original name alone and having multiple copies with different names too)

  2. Waiting 3-7 minutes instead of just the 10 seconds
    How to fix unresponsive Wyze Cam that won't pass solid yellow light. - YouTube
    He had V2 but was using PAN firmware? I tried that too

  3. I tried swapping back and forth between different firmware including OpenMiko and webcam:
    Reddit - Dive into anything
    GitHub - openmiko/openmiko: Open source firmware for Ingenic T20 based devices such as WyzeCam V2, Xiaomi Xiaofang 1S, iSmartAlarm's Spot+ and others.

  4. Not sdxc type SD cards
    Can v2 clicks and not coming on - #10 by tparr01

Nothing happens at all after plugging in SD card with new firmware, then holding the setup button while plugging in. I waited passed seven minutes a few times too.

Am I missing something or are some cameras just bricked and have no recovery?

So just to reiterate the steps…

Download the appropriate file for your camera (each has a unique set of firmware files).
Unzip the file you downloaded.
Copy the file to a FAT32 formatted sd card and rename as appropriate for the camera. No larger than 32gb card.
Depending on which firmware was on before, do a factory reset on the camera.
Unplug the camera or at least remove power in someway.
Insert the card.
Hold the reset button (make sure it is really pressed. Can be difficult with some cameras.)
Apply power and watch for appropriate lights.

Also be sure that if you are using windows that the file isn’t named filename.bin.bin

I have even tried openip and reverting back to FIRMWARE_660R_F.BIN

Tried this other name as well: recovery_wcpv2.bin

I’ve tried other power adapters as well.

Yes, These are the steps I have been following specifically from tparr01:

During a firmware update, my WyzeCam V2 got stuck in a boot loop and would no longer connect.
Below is how to recover a WyzeCam V2, white or black using only a MicroSD card and a computer.
Start by removing the MicroSD card (or getting a new one temporarily if you don’t use continuous recording).
Insert it into the computer using an adapter and then download the firmware from Wyze.
Scroll down to the WyzeCam V2 section and click the blue version number for a firmware file to flash.
Once downloaded, rename the file to demo.bin and then copy it to the root of the SD card.
Remove the SD card and unplug the camera.
Hold the “Setup” button on the back and then plug the camera back in while continuing to hold the setup button.
After about 10 seconds, the light will change from yellow to solid yellow and blue at the same time (it may appear as just solid blue).
Both LEDs are lit here showing that it is in the process of flashing the firmware.
If your camera is not changing from yellow, make sure you are using an sd card with less than 32GB of storage (not sdxc).
After a while (5 minutes or so) the camera should begin functioning again.
Despite manually trying to reset my camera several times, it showed up perfectly functional in my list of devices again without me having to re-add the wifi credentials to it.

You have to extract the file from the downloaded zip…it isn’t the bin file.

1 Like

Also, by default, Windows hides filename extensions (one of the dumbest things they could have done IMHO). So if that is the case and you rename the file to demo.bin, it will really be demo.bin.bin - which will not work.

1 Like

This is not happening for me. I always show file extensions.

Yes. I download the zip file. Then Extract. I have extracted to my PC as well as to the SD card directly.
Then I have mostly renamed the file to demo.bin
I use windows. not Mac.

I don’t think this has been the problem for me.

So do I. One of the first things I change. Lots of people don’t know that however - hence the reason I mentioned it.

Make sure you don’t leave a folder called demo.bin there either.
Frankly you are best off with the only thing on that SD card is the one file and nothing else.

Just a comment, the V3 uses a different file name for reloading firmware.

1 Like

I have mostly tried with only the “demo.bin” file being the only item on the SD card. I have also tried various alternatives that include a copy of the original firmware with the original name and a copy of that with the name changed to demo.bin.
I have also tried using capital letters too.