Realy regreat getting Wyze cam

I have two dropcams and I wanted to add some more. I’m traveling through Africa for 2 months and want to be able to keep an eye on the house. Instead of adding another 2 dropcams I added 5 Wyze cams. I like disruptive tech and wanted to support the company. Additionally, I bought 5 more Wyze cams that should be there when I get home.

I tested the system for 2 weeks before I left and it worked great.

Now, for the last 10 days - well, I might as well not even have cameras. Sometimes they connect, sometimes they don’t. The one interior one just won’t connect at all now. The others will… sometimes… When they connect you can’t view past history (just freezes on last image).

I had someone go over to the house and manually restart all cameras, and my router auto restarts once daily.

Knew I was buying inexpensive hardware and no problem if one camera just fails - but to have all 5 not working… I now have no idea what is going on in my house - I’m half a world a way and all my property is at risk, simply because I jumped on the Wyze Cam hype.

Really blows.

Funny enough - my two Dropcams are still pinging me with alerts regularly. I dislike dropcam but sometimes I guess you get what you pay for. meh.

Are you having troubles connecting to the app itself?

No, the app works - just the cameras are horribly intermittent. Error 0, 90 and a couple of others. Two work fairly consistently (even though they’re 50’ from the extender). The three within 15’ of the router just don’t work much at all. One is essentially dead - won’t connect.

When they do connect they will often show the last image the recorded and show it as ‘live’ - lol… When they do connect there’s no history to show - even though there should be as they have SD cards.

Anyway, they all worked fine when I was home for two weeks - I’m assuming things are screwed up on Wyze’s side / their network or whatever in the last 2 weeks. I updated 4 of the 5 to the new firmware - nothing has changed. I’ve restarted them etc etc.

The basic idea of buying cameras, is that you’d like to see what’s happening - this is what they’re selling, but not delivering.

There is a topic at the link I have posted below. Can you take a quick read to see if some of these errors are what you are getting?

Can you submit a support request to Wyze with the app logs attached?

I don’t know - I’m 5,454 miles away from my cameras for the next 7 weeks. I don’t think I can do anything. Except vent. :wink:

Have you tried using a VPN service with US servers to see if you can connect to the cameras that way? It is possible you are being blocked in the country you’re in. Some users in Panama have similar problems.

1 Like

Thanks. It’s not on my end. It’s totally on Wyze’s side. I’m not blocked 100% - the cameras just intermittently are not/available and throw errors.

I had no trouble from South Africa using Vodafone 4G.
My cameras are in Canada.
What country are you in?

@Cyrusblue, we are super sorry to hear about this issue. We appreciate you venting and we apologize for the trouble. You may want to try adding shortcuts to reboot your Wyze Cams through the app. It sounds like they’re often maintaining a partial connection (IoT though sometimes not the live stream) and that may help.

Please let us know how it goes if you try it!


Done that multiple times. Thanks.

1 Like

I know this may not be optimal, but I will reiterate what I said about trying a VPN on your phone and connecting to US servers. I hope you are willing to try that, because I believe it may work for you. Sometimes workarounds are necessary, even if they aren’t the preferred solution.

@Cyrusblue There have been ongoing remote connectivity issues in the last several days that are affecting many users right now. So there’s a very good chance that you’re experiencing issues that just coincidentally relate to the timing of your trip. Before you give up on these excellent cameras, I would suggest trying again after those issues are resolved. You can check on Service Status & Known Issues on the page below. Good luck!


Thanks for letting me know, @Cyrusblue!

We hope that your Wyze Cams will start connecting properly soon. If it is the service issue that @YeahThatCee mentioned, it should be resolved when we find and fix the root cause.

1 Like

Just wanted to mention that the issue in Panama starts all the way from just trying to open the app, it won’t open at all and either throw a “Network timed out”, “Could not connect to the server” or sometimes “The internet connection appears to be offline”.

It is not intermittent, it’s all the time, no way to use the app on most c&w connections.

Is this the same issue you are having @Cyrusblue ?

Video of said issue: Error al tratar de abrir la aplicacion Wyze con el ISP c&w Panama - YouTube

You can’t even create an account from zero on a c&w wifi connection because it throws a “failed to get verification code” :face_with_head_bandage: :