Playback not working!

I have a Wyze Cam Pan and since the last update, I haven’t been able to play back any videos captured by the camera. Each time I try, I am prevented by a pop up offer which I do NOT want, nor am I interested in it. All I wanna do is play back my video.

Is the card being recognized ?

Settings> advanced settings > manage sd card

Welcome to the community @stylemanmd , sorry to hear you are having an issue.

Can you post a picture of the popup so we can see what is being presented?

Are you trying to watch events from the event tab or playback from the camera home screen?


from the events tab…where I’ve always watched them.

The events tab is and always has been cloud based. That changed quite a while ago to just a still image unless you have Cam Plus (paid) or Cam Plus Lite (which can be free).
If you are trying to watch videos that are recorded on a local uSD card, that is and always has been from the View Playback button on the camera page. Obviously that requires having a uSD card in each camera.
And before someone calls me on my statement, if you watch an event on the events tab, you CAN get to the uSD card recording by clicking on the icon that sort of looks like a uSD card.


I tried and it got sent back to me telling me that…something about being a new user and only being allowed one

something or other didn’t allow for it to go through.



@Mods , is it possible to increase @stylemanmd permissions so they can post the image of what they are seeing

@stylemanmd , By reviewing the forums and reading post your permissions will also be elevated


You should be able to post images now.

Thanks for the flag.


Thank you,

Please see the images attached.

2 Events.jpg

Your cams are not capturing videos. They are capturing still images as indicated by the image icon:

As K6CCC correctly replied, you need some flavor of subscription in order to record cloud-based video events:

If a recurring subscription fee is an issue, just subscribe to Cam Plus Lite for free. That will get you back to the exact same functionality you had before.

I know what the still image is all about and in the past, if I clicked on it, it would play for me. I’ve had these 2 cameras for 3 years now and that’s how they’ve ALWAYS worked. Now that I updated it, they don’t work.

If you look at one of the other images, you can see that the playback button at the bottom is grayed out, and it was never grayed out before.

We never had still images captured in lieu of videos until recently… when at the same time, you were required to have a subscription in order to capture and view cloud-based video events.

The grayed out Playback button for SD card playback is a bug. The fix is undergoing testing.

I have NEVER used the cloud for my videos. I always got a 12 second clip and it ALWAYS played for me and then I could save it to my photo gallery or leave it stored on the SD card.

I appreciate that you recognized that the “playback” button for the SD cards is a bug.
I will wait for the fix.
Thank you

When you click on this, you are requesting an image or video from the cloud:

When you are subsequently presented with this view, it’s from the cloud:

When you now click on the Playback icon, you are requesting the same footage from your cam’s SD card.

You are incorrect. The 12 second videos have ALWAYS been cloud based. Accessed via the Events tab,