Phone not fluidly changing wifi hosts in network (Wyze Mesh Router)

Disclaimer: I’m not very technical and don’t know all the lingo.

I have my AT&T Gateway modem/router in my office and Wyze mesh router in my living room. The 2.4 networks share the same name a password, because I want all my smart home devices to stay on a 2.4 network. My TV and A/V receiver live in my living room but, the receiver is connecting to the wyze mesh and the tv is connecting to the gateway., both on 2.4. This shouldn’t matter, but here’s the problem:

My phone is treating these as two separate networks with the same name and password.

When in my office, near the ATT Gateway, my phone can control the TV in the living room but not the receiver; the Onkyo app that controls it will not connect to my phone from there because it thinks my phone is on the wrong network. When moving to my living room, I expect my phone to seamlessly transition to the Wyze mesh, but it doesn’t, I assume because the signal from my office is still plenty strong. Regardless, I can disconnect my phone from wifi, reconnect to what looks like the same network but actually move to the wyze mesh, and now control my receiver but not the tv.

So, it looks like my AT&T Gateway and Wyze Mesh Router are providing different 2.4 networks, until…

I use voice control on the Echo Dot in my office to control my receiver via Alexa, and it works. This Echo is getting its signal from the gateway. The receiver is getting its signal from the wyze mesh. These devices can still communicate across modems. Across networks, if that is indeed what’s happening. This part is not surprising, I guess, since Alexa can control my home’s smart devices with a voice command to my phone from anywhere in the world, right? Just adding this fact in case it matters in a way I don’t understand.

I have performed a factory reset on both routers and set them up from scratch twice, but nothing changed. The IP address and other identity numbers shows on my phone’s network settings are different depending on which router is providing it service.

What’s wrong here? Shouldn’t everything communicate here? It’d be nice if my phone changed from gateway to mesh router as I move through the house but, even if it did, I still wouldn’t be able to control both the receiver and tv from one location given this current problem.

This is a very common issue/mistake.

Even if the name and password are the same, devices will tend to stick to one of them until they have almost no signal. With a mesh system, the routers communicate so the device knows it can safely disconnect and switch to the other node.

This however only works within the mesh. If you have a diffrent access point (your ATT gateway) it will mess the switching up.

If your using a mesh system all other extenders or APs should be disabled. sounds like your ATT unit is a model/router/AP combo unit. If you can enable bypass mode on it everything should be smoother, as it allows the Wyze router to take full control.

Your issues with apps not being able to control other devices is due to both Wyze and ATT units routing. This is known as a double NAT, and causes the 2 networks to not be connected and your not able to communicate to devices on the other network.


Thank you so much for that. Very easy to understand, even for a novice like me. Can I just change the 2.4 network name on my ATT Gateway, instead of enabling bypass mode, and achieve the same result?

I don’t think that would solve all the issues. There would still be double NAT which causes problems with other things in some cases, but may be good enough as long as you don’t connect any devices to the WiFi the ATT box has.

Also another WiFi = more interference.

Bypass mode would be much better.

Alternatively you can try Bridge mode on the Wyze router. In theory it then passes your regular network through without NAT and basically turns your Wyze routers into access points for the ATT provided network. However, be forewarned that it doesn’t seem to work completely. Fortunately, you can switch back and forth between Bridged and non-Bridged easily…just a switch in the settings. You can test it to see if it works and turn it off again if it doesn’t.

I’ve read the thread a couple of times but am not seeing either of two critical words - wire or cable. So what, exactly, is your Wyze mesh router connecting to for Internet? Assuming you only have a single ISP, I will further assume you’ve wired the Wyze to the AT&T gateway. In which case the recommendation would be to disable ALL wireless on the AT&T, and let the mesh router handle everything WiFi.

If the Wyze router is not hard wired to the Internet (nothing in the WAN port, just using it as a bridge) then I would probably have it advertise SSIDs distinct from those advertised by the AT&T, and then use only the new SSIDs…

My assumption is the root Wyze router connected to the AT&T gateway since you have to have at least one router connected via cable/wire/ethernet. It sort of works this way in router mode giving exactly the problem posted since the Wyze mesh is behind a NAT which is a different network/subnet. That’s why @ModernMaster can’t go between the Wyze subnet and the AT&T subnet since there aren’t any firewall rules allowing access.

1 Like


So there are only a couple of options here. If you have hard wired devices along with wifi devices, you need to pick one of the systems to be the router: AT&T or Wyze, but not both. Either way, one or the other will probably need to be set to bridge mode so that you have only one subnet, unless the AT&T system allows you access to firewall rules that would let you provide access from the Wyze system to those behind the AT&T system, which is probably not the case.

I have a wired router with 3 subnets. I setup rules to allow me to access devices on my IOT and Guest networks while I’m connected to the main subnet but not the other way around. That way I can control devices on Guest and IOT without having to actually connect to the wifi on those subnets.

Probably the easiest solution is to use the Wyze mesh as your entire network. Plug one cable into the AT&T modem to gain access to the internet and plug another cable into a switch if you have wired devices. Disable wifi on the AT&T modem and have everything connect via the Wyze mesh. Then you’ll have access to everything and roaming should work.

What do you mean by “it doesn’t seem to work completely”? And, will work if I have just one Wyze mesh router, since it is the root designation necessarily?

I think we need to understand what your trying to accomplish so we can better help you.

Did you purchase a single Wyze mesh router? Was this to extend range, or to replace your ATT one?

Sounds like you want to use the ATT one for WiFi in part of your house, and the Wyze one for the rest of the house?

Is that all correct?

1 Like

You should read this article on bridge mode for Wyze Mesh:

When I tested I only had two routers. The satellite router routinely had a red light indicating loss of internet connectivity. The light only came on when I turned on bridge mode. I have a total of four routers now, scattered around my house in non-bridge mode and no red light. Plan to do some more testing with bridge mode, but trying to migrate devices to the mesh right now. (I have an apostrophe in the password on my old wifi and can’t use the same name/password…another issue with the Wyze mesh routers.)


Just found this on the support site, which is contrary to what @IEatBeans posted earlier, but @IEatBeans is actually correct: (@IEatBeans , you might want to let support know that this article isn’t really correct, without switching to bridge mode.or disabling wifi on the old router.)

1 Like

I bought just one, because I expected to be able to use it in cooperation with my ATT Gateway. It is probably not necessary that I continue to use the ATT for wifi, since the Wyze supports 50 devices and I currently have only 30, but I thought it would help the divide the load.

The reason I bought any mesh router is because my TV (LG G2 OLED) always loses connection to the internet while powered off, so I cannot then turn it on by voice. I hoped that by placing the mesh router closer to the TV than is my ATT, I could solve this, but it has not worked.

I talked to ATT about bypass mode today, and I think I know how to set it up, but I haven’t done it yet. Simply changing my ATT Gateway’s network name to get it out of the way let 30 devices all swarm to the wyze mesh, and it’s working well. Still, I’ll play with bypass tomorrow.

Thank you.


Thank you, I will bring that up to Wyze.