Pan v2 cam no firmware for manual install

I just installed my pan v2 cam and updated firmware, it got into a boot loop saying ready for setup. I am trying to flash it manually but there is no firmware to download. Anyone have a valid link, or maybe a solution for the boot loop? I’ve tried factory resetting and no luck.

Did you try here:!Screenshot 2021-10-03 at 09-33-21 Release Notes Firmware|690x254

Yeah that isn’t a clickable link.

My apology. I didn’t notice that it wasn’t a live link.

Thank you for pointing this out. Wyze has been made aware of this issue. :+1:

1 Like

My pan c2 is on solid red, reset doesn’t work. No firmware downloads or work arounds so it’s just a paperweight until wyze decides to release the firmware and flash instructions.
Great start to a “new” product.

Mine is in the same state. I’ve been back and forth with Wyze support. I’ll post any updates if they find a solution.

Good luck
But considering the “new” pan v2 is basically the v3 in the pan v1 housing I don’t think they are in any rush to fix it.

Wyze Cam Pan v2 firmware (September 10, 2021) is now available from the Release Notes & Firmware page:

Yes but where’s the instructions. Every firmware file so far has required a name change. What do we change the name to?

I’ve already tried the old pan name: demo.bin, the v3 name: demo_wcpv2.bin, and just leaving it as recovery_wcpv2.bin

None seem to work

I’ve tried; demo.bin, demo_wcpv2.bin, demo_wcv3.bin, recovery_wcpv2.bin, FIRMWARE_449_F.bin, FIRMWARE.bin, FIRMWARE_449.bin, FIRMWARE_449121_F.bin, FIRMWARE_recovery_wcpv2.bin, recovery_wcpv2_4.49.1.21_F.bin

I’ve basically tried every combination of old names from the v1 on.
How do you release the recovery file but not how to recover at the same time?
What name haven’t I thought of?

To check, did you follow this process? Part of why the firmware file was delayed was us finding some issues in the flashing process we needed to iron out. It’s possible you did everything right and I need to report an issue.

  • Wyze Cam Pan v2 files can be found on the Release Notes page.

  • Download a specific version of firmware, For Windows 10: Right-click on the folder and select extract all. For Mac: Just drag and drop the folder, put it on the root directory of your microSD card. The file name should be recovery_wcpv2.bin.

  • Power off your camera and insert your microSD card.

  • Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds until the light is solid purple, then release the button.

Note: For “Solid Purple” both the blue and red LEDs will be on at once, making it appear to be a solid purple.

  • Wait for 3-4 minutes. The camera will reboot and change light status during this time.

  • Once this is done, your camera should be functioning with the original setup. No need to re-setup your camera!


I checked and tried again and again. I contacted support this afternoon and we tried a few more things but nothing worked. Support is replacing the camera because they felt like this one is defective.

1 Like

They sent me a replacement camera and it has worked just fine now. I was having the same problems, but no issues with the new camera.


I’ll report this to the team! Thank you for the confirmation.


Hello @C.M.B.H and @otiz421,
We can only reproduce this issue on earlier beta devices.
Could you help send me a private message with the Pan v2 MAC address? Thank you.

1 Like

it’s 2022 12 08, and my V1 Pan Cam shut off (Solid orange light status) when it was prematurely unplugged before 1574 firmware was flashed. It took a very long time…
I don’t think manual flash is enabled on this device as it is pretty old.

I’ve downloaded the latest bin manually and changed the name etc etc… Doesn’t work. All I got was a 20$ coupon from Wyze Support to buy a newer V2. I think this is all a sales gimmick.

I assume you extracted the bin file from the zip file you downloaded. Also, you didn’t mention it, but if you are using windows be sure the extracted file wasn’t named demo.bin.bin.