Outdoor plug firmware won't update from

Bought two outdoor plugs last year after Christmas because I wanted scheduling of the outdoor Christmas lights.

Just set them up for this year’s christmas season and all went well. Went to upgrade firmware because it’s on and noticed latest is Wyze app on iOS is saying “Everything’ good, you’re upgraded”.

I’ve unplugged the plugs for 15 seconds and replugged them in. Didn’t work. Deleted them from the app and reconnected. Didn’t work.

I really want to use the “Time of Day” setting but it says I need to upgrade the firmware.

How can I force an updated?

1 Like

There appears to be an issue with normal firmware updates to the Outdoor Plug ATM. Here is info on how to get around that if you need to, but know the Time of Day feature is only to keep schedules running without an Internet connection. Just use a Rule with a start and stop time to set a schedule without the new firmware:

Are you doing the update from the individual plug or from the Update Firmware under Account. I have found that sometimes one will work while another does not. So try both methods.
Also what App version do you have?
I’m showing on mine, but I’m a beta tester.

Well try to log out of your app then back in

I seem to be having the same issue trying to get the update on 1 of the 2 outdoor plugs I bought last week.
When I had upgrade now it says everything is good to go, but still cannot set up the time of day feature on 1 unit.

I had exactly this issue.

On phone with very nice technical support person this past Monday - but still not able to resolve.

Wyze sending replacement plugs and I returned non-upgradable/non-schedulable plugs to them for post mortem.

This seems just a little insane.

Well welcome to the world of electronics, need to remember that wyze has no quility control…im guessing due to mass production,we have had a few items that were defective and once they get the device back they will be able to look at the lot number/production date and see what the issues are

I am pretty sure there is quality control, but items will always slip through

Jason,it’s very bad. We are a Motorola elite dealership for over 45 years and Wyze is the worse customer service that our service manager has dealt with

Customer service and quality control are two separate things. I do agree there are customer support issues, that is why you will see me trying to get attention from Wyze on issues that seem to fall through and end up on the forum.


Sorry, folks! I spoke with the team and we’re expecting this to be resolved with the 2.27 app release coming in the near future.


Have the exact same problem, but using Android. Bought two of them last year and only setup one once I got them. That one updated just fine. The one I tried setting up last week is on and won’t update. Trying to use scheduling as well for Christmas lighting… :frowning:

You can still schedule. Just create a scheduled rule with a start and stop time. :slight_smile:

1 Like

I found that work around. Still kind of silly glitch

It’s not a work around – it’s the way they have been scheduled since they were born. :slight_smile:

The new Time of Day feature only brings the scheduling out of the cloud and into the Plug hardware.

Got 4 new plugs and I’m having same issue with fmware upgrade, Currently stuck on ver1.2.0.86 that they came with. Opened a ticket w/Wyse support. Doug was very helpful but couldn’t resolve. Tried using Rules but my setup randomly fails to turn on or off a few of the plugs. I’m using 5 of the 8 available sockets. Even tried 2 rule setup, 1 to turn on, 1 to turn off.

I have the same issue. Stuck on

I think this problem has been fixed for all versions of the app. Try updating your Outdoor Plug to again. :slight_smile: