OG camera: Download failed, please try again. When saving video with OG camera


I have the new OG camera. Updated to current firmware, newest ver of Wyze iOS app. When I try to save a video event I get the following. I’ve tried all the unplug camera, kill the Wyze app, etc etc… I can save video events from all my other Wyze cameras. Except the new OG. I cannot save any video events from the OG camera.

Any ideas? Thanks!

I was able to download a 13-second clip from my OG just now. I didn’t try a longer one, but my guess is that would work too. I’m on an Android phone, if that helps.


Might be an iOS app issue. I just tested 5 videos on my OG Standard both download and share, all downloaded and shared appropriately. Only had one video upload fail from an hour ago that still shows as Live. Also tested 5 different events on the OG Telephoto and they also downloaded and shared. Android 11 - Production app.

Ugh, iOS again it seems. I can save video clips from all my other Wyze cameras. Different models. Just not the OG. I did create a post on this so as not to hijack this thread.

1 Like

Looks like the Mods cleaned it up so it’s all in one new thread so others who may be experiencing this can comment here.

For other iOS users who may post in, it is important to identify the app version. Are you running the Production or Beta App? What version?

1 Like

Well if you’re running Beta…

I’m running the current via the Apple App Store: 2.38.4 (3).

I just tried again to save a video event, any of them it fails to save. But all the other cameras I can save.

I’m able to save events from my OG on IOS

Just got the inside word, this is resolved in upcoming 2.39 ver. :-)))