Wyze Cam Outdoor NOT saving video to the Phone?

My first time with Wyze with the Cam Outdoor and it has been frustrating to say the least.

So I got a WCO. In about the 2nd week it recorded an attempted B&E.

I wanted to download the video to my iPhone to save the evidence. But no matter how I tried I always get the Download failed, please try again error message.

I posted this issue to my FB page and I got a PM from another WCO user and she told me that she also has the same problem and offered a workaround.

Are there anyone else having the same issue?

That said - I don’t need workarounds. This should be working (no issues with the V2, though) - I raised a ticket to Support, but it has been outstanding for a week now.

Oh, yes, I have a Cam Plus subscription… Firmware and iOS apps are all updated but I still get the download failed problem.

Thanks in advanced!

I had the same issue for a month. After numerous emails with support and one phone call they shipped me another base station to try. Before I got the new base I pulled the power on my original base which I had already done 5 other times. This time I left it off for about an hour, plugged pack in and I was again able to share/download the event videos. Is the base connected via ethernet or WI-FI ? You could do a reset on the base by using a paper clip in the small hole on the left side of the base, that is the reset.If it still doesn’t work call support at 1-844-999-3226 M-F 5 am to 6PM pacific time.Have your ticket number.

Hi Antonius. Thank you for your response.

The base is connected via WiFi. I already did the reset in my troubleshooting call. I might try leaving it without power for at least an hour.

As for support - I tried calling them, but I wouldn’t want to waste my time on-hold if there is a wait time of more than 10~20-minutes. Hence, have just been emailing them…

Which I quote,

I would appreciate it if we don’t go around in circles here. I already had a troubleshooting call a week back and we had gone through these steps and more and as well mentioning that I have the iOS app and firmware updated.

> Here are some troubleshooting steps we can try to help us isolate what's causing the issue.
> 1. Please check to ensure that your app is updated. To check and update your app please click here.
> 2. Please check to ensure that your camera's firmware is updated. For details please click here.
> 3. If both app and firmware are updated but the issue is still the same, please log out from the app then log back in.
> 4. If still no go, please force close the Wyze app and restart the device. 
> 5. Try changing your internet source from WiFi to mobile data. 
> 6. Also, to isolate this, please try using a different mobile device (Android)  and observe if the issue will still be the same.

That said, I don’t think I would need to buy an Android phone just to test this out if I already have an iOS?

I would respectfully suggest that this be escalated to the next level of support to replicate the issue rather than going through Knowledge Base and Support articles. Again, I had gone over all these with John a week back.

If Wyze is unable to provide a timely solution, all I ask then is a complete refund of my purchase price for the WCO, Base Station and Wyze SD card because it becomes unusable for me…

Looking forward to their next response…


I am using an iPhone and iPAD. My base is connected via ethernet and I have a good 3 bar signal to my 4 cams.

This is my tale

Whoa! Exactly same as mine…

That said - I give up with their Support. I already have THREE open tickets. Never has been a response on the first ticket, second ticket was what I was working with, and another ticket because the support representative in the second ticket asked me to raise ANOTHER ticket.

I just filed a return with my credit card. Too much time wasted already.

That said - thanks for the link. I will also post there to share my experience.