Nova Electronics (Shang hai) in Router

I have been trying to re- add my V2 to my account.
My router indicated a device named Nova Electronic is attached by WIRE. not wireless even V2 is not wired to router.

the MAC id shown in router is different than the actual mac printed on V2.

Funny part is Wyze app no longer ask for MAC id to add.

I bet Wyze has a mac idcross reference list in their server.

I kept having connection time out.

Wyze is purging V2 out?

That is weird. I do know that in their early days Wyze MAC’s were pre-registered to another company before Wyze reserved their own registered MAC addresses, but that was years ago. It’s possible some of the early orders of V2’s could’ve had this though.

I have to ask…if the MAC address is completely different and the company name is totally different, and it says wired instead of wireless…are you absolutely sure that the device you’re looking at in the router is actually the V2 camera in question?

I could possibly accept that the MAC is tied to another company, that is not abnormal at all for ODM products anyway, or really any IOT product of any kind…but for your router to think it’s wired instead of wireless, that indicates a bug with the router since that information is solely the job of the router to determine.

Altogether I’d recommend at least rebooting the router, maybe consider resetting it to factory settings if it is bugging out on how a device is connecting to it.

Anyway, to answer your question about V2s, it is my understanding that they stopped manufacturing new V2’s since the V3’s became the new flagship product, but V2’s are not discontinued, nor have they lost their support. They are even still available for purchase on the Wyze website despite V3’s being available for more than a year. They also have the potential for some AI features that haven’t been available with some other cams (such as Sound AI detections that the V3’s haven’t even been able to test yet). So definitely not being purged. They just barely did an official EOL (end of life) for the V1 cams this year, and if they were planning to get rid of the V2’s soon I would’ve expected them to announce EOL for them at the same time, but they didn’t, so it probably won’t happen for a while. But regardless, I can’t see them intentionally start using someone else’s MAC range while they phase it out when they already have so many registered for themselves.

That is an interesting thing you found. I wouldn’t worry too much about the router assuming the MAC is for another company since that is something that happens fairly frequently with network cards in my experience, but I would still go check an independent MAC registration site such as one of the following:

And go enter in at least first few character of your MAC address to see who that range is registered to.
Does the MAC in the Router Match what is showing in the Wyze App for the Cam? And that is different from the MAC on the sticker for the Cam?
How long have you had the cam for?

If it were me I’d even consider seeing if deleting the device from the app and flashing the firmware fixed it or not. Maybe testing it on another router and see if it’s the same on that router too.

The main thing that leads me to wonder if it is the Router glitching is that it thinks the cam is wired to it…that shouldn’t be the cam causing that issue…and if the router is glitching with that, it seems reasonable to wonder if the rest of the inconsistencies aren’t related to the router.


I had flashed the V2 with 860. a version before 1002. btw, both firmware wonzt work.

Router has been power cycled many times, 5ghz off when I try to re-add V2.
I had QOS, firewall turned off fairness during setup. I have other Non Eufy Cam running on the same router. None has such problem.

Yes, MAC id on V2 bottom is different from the router report.
on V2 firsts 2 digits are “2C”. but in pic it showthe mac differently.

The wired entry exhibited during setup. I imagine the firmware got the QR code and try to connect to the router. router got info displayed.

why the router interpret the V2 is wired, that I do not know. It all come down to V2 handshake with router. May be V2 firmware is feeding router bogus info.? or the Wyze server is feeding wrong info return after making contact. Wyze will know better.

so far my V2 is a dud.

That is interesting. We’ll have to keep an eye out to see if others also experience this. Thank you for sharing so we can keep an eye out to see if any kind of pattern emerges.

I am curious, what do you mean the Cam Is a dud? If it’s connecting to the router, that indicates that setup should’ve been successful or it wouldn’t have gotten the info to connect to the router in the first place. So it setup correctly but you can’t see the Livestream for some reason or something? That would also weird since the video recording process would have to be working in order to process the QR code during setup.

Definitely something weird here. I would try flashing with a different firmware this time. Maybe talk to support… They have done some interesting tests with me in the past including using a special networking app to give them a report to check out what’s going on between my router and a device. Maybe they can figure out something for you there to get it working properly again.

Cam cannot do anything. It failed to connect.
I had tried the 860,1002 firmwarr and an old firmware
both 1002 and 860 just cannot connect at setup

Firmware 111 manage to add v2 back and reconnect.after 7 tries of setup.
once update to 1002 through wyze app. it has code 90. no connection.
if power off try to move, unit won,t connect again.

the only thing get back from support is come get CampPlus email …

I don’t believe that a Mac ID of a Nova Electronics that is wired has anything to do with a Wyze Cam.

The Wyze Cam is not a wired device

The Wyze Cam is obviously not connected to your WiFi

Leave the Wyze Cam unplugged and check your router again for the suspicious MAC ID, if still there then power off/on router and re-check once router is back up.

If the MAC ID is still there while Wyze Cam is unplugged you have your answer…

Now start unplugging your Ethernet cables and repeat process until you find the suspicious MAC ID.

Good Luck, hope you isolate the MAC ID

Thisbweird mac device only shown up when I try to add V2.
I had my router admin page up to turn off 5ghz etc.

BTW, my router has

“DNS over TLS enabled with DNS rebind protection”.

not sure if this has an impact. setup csn fail if Wyze try to manipulate DNS.

This setting had been there for ages without problem.

What device (smartphone or tablet) are you using for setup?

Model and Manufacturer of the device your using to setup Wyze Cam?

Tried both

  1. zte axon 7 mini with Android 7
  2. Fire HD8 2021 with Android 9

both are having same results

I do not think my V2 is the odd one.
Seems few others experiencingbsimilar issues.

Today, mysteriously my cam is back after 4 days of trying to re-add QR code.

The riuter register it as Wyze… not Nova and it is not wired.

I’m guessing it also has a different MAC address than the one you were looking at before too.

It is hard to imagine that the camera could connect to the router without actually completing setup or using the QR code where it gets the info from. If it could use the QR code, then the video is working, if it couldn’t, then it wouldn’t be able to connect. So it was just a little odd of a situation.

1 Like

Correct, the MAC address is same as on V2.

I had been reflash my V2 around 10 times to different version of firmwares.
I had reset my routers and modem so many times.

but why all absudden it registered ad I was almost giving up to save V2 and go with competitor unit

My suspicion.
It seems Wyze server may be too busy to register camera.
I have no idea The actual mechanics .

I don’t think it had to do with the Wyze server because I just reset one of my V2’s to factory settings a couple of days ago (I have a lot) and didn’t have the same problems.

I guess it’s hard to know what the problem was, but regardless of what was involved the good news is that you got it working again. :slight_smile: