Notification rules not working

Not sure what I’m doing wrong. Getting notifications every few minutes, even though I set up a schedule to turn off notifications.

Am I missing something obvious here?

The trigger only attempts to run once at 10:30PM. If it is currently 10:40pm where you live and you set up the rule to shut off notifications at 10:30PM, then the schedule won’t run today because it’s already past 10:30, so the trigger is never activated…but it should start working tomorrow if that is what happened as I suspect is the case.

Nope, set it up earlier and it just keeps going

1 Like

Will you go to Account → rules → history and see if it tells you what happens at that time at night when it’s supposed to trigger? Does it give an error or say succeeded? Are you comfortable paying a screenshot of it?

Also, can you go to Account → Wyze Support → Submit a Log → Wyze App and Services → rules --and submit a log on this. Maybe we can get someone from the rules engine team to check it out.

As I was digging around - I think I found out why. The location in the app wasn’t set properly (though as my outdoor switches turn on and off at the right times - I never suspected it). I adjusted the location settings and then right at 7 am this morning the ‘turn notifications back on’ successfully ran in history!


That’s great! That makes sense that another rule or something could’ve been interfering. I’m glad you were able to figure it out and resolve it. :slight_smile: If you do continue to have issues with it, post again.

1 Like

Thanks for your help - what you said absolutely makes sense so I’ll be sure to check for that if I set another up in the future.

I’m glad I stumbled across this. I’ve been trying to set my rules so I only get notifications at night when im in bed. I don’t need to get notifications during the day when it’s just us here walking around. I didn’t have any location set, so I fixed that. Hopefully everything starts working the way I want it to tomorrow.

The app thinks we are one day incorrect. At least for me. I had same issue, it appears it has been solved just moving 1 day back.

At the time app appears to be at day 7th of July. I’m on day 8. That’s why it would not work for me