Not getting any power to thermostat at all

I’m not sure if this is something I’m doing wrong, or if the compatibility checker lied to me.

I have a C wire… I hooked all the wires up, minus the S1 & S2 (cause there’s no terminals on the thermo for those). I get no power at all. I tried moving Rh to Rc, no deal. Tried the S1 & S2 on the * terminal, no deal. The unit is a heat pump/AC all-in-one. Is there something I’m missing?

This is the original thermo:

Can you provide pictures of how you had the Wyze Thermostat setup and a picture of HVAC Circuit board Wires / Connections


You will lose your outdoor sensing capability with the wyze, it doesn’t have terminals for the S1 and S2 external temperature sensor.

W: white
Rc: red
G: green
Y: Yellow

Show a picture of the other side of these wires (in your air handler) and I can troubleshoot further. Often, when a thermostat has batteries, people will connect the C wire at the thermostat, but the installer hasn’t actually connected it at the air handler.


Sorry for the delay… this is at our vacation house, so there’s a lot more stuff we’re working on. I did take the cover off the heat/AC unit this morning, and I’ll snap a pic or two and post them in a little bit. I appreciate the responses and help. Hopefully we can figure this out :slight_smile:


Alright, here are a couple pics of the control board and wiring.


That’s the outdoor unit. There should be an air handler somewhere indoors. Maybe in a crawl space under the house, a closet, or in an attic/ crawl space above the house. Your air filter should be near it.

1 Like

Ah, there is a filter box on the wall above the pantry, and the pantry has a drop ceiling… I’m back home at work now, but I’m heading back up there Thursday afternoon. I’ll climb up there and take a look when I get back. Thanks again for the help with this.

1 Like

Hey @speadie, thanks for the help with this. Things got busy with finishing painting, garage cleanup and other misc stuff to get the place ready for renting. But I wanted to get back to you to let you know that your tips helped me find the other control board and it had a blown fuse. I replaced that and got things all set. Thanks for pointing me in the right direction.