No SD card playback of events

I’ve had many Wyze V3 cams with SD cards in them. Always been simple, go to events, click on events and it goes to that place in the video on the SD card. You can just simply scroll through the day if you want from there.

Upgrading to the V3 Pro, was a mistake. I found that this “issue” has been going on for a VERY LONG time unresolved.
Seeing all these posts telling people it’s their SD card, format the SD card in a computer is actually hilarious, why is that?
It’s very simple Wyze doesn’t have it in the firmware to function that way. That seems strange right? why would they not just want it to function the same way all the past cameras have when you put a memory card in. It’s just a V3 with a slightly better camera.
The answer is, they DON’T want to fix it because it’s intentional.
People using SD cards and not paying doesn’t make them money.
So you get your V3 Pro and everyone gets the same issue with events and the only way to get them to work is to pay for a cloud service or RETURN the device like they really should.
It’s even more insulting that they popup “MicroSD card not found” making people THINK it’s the memory card when it 100% isn’t, less teksavvy people I’m sure will go on to buy an SD card from their convent “Shop” button only to be left with the same results.
One of the most heinous anti-consumer moves I’ve seen.
It’s not “tinfoil hat” talk, the Firmware is that way. Gaslighting everyone on the forums as if there is a Wyze v3 Pro cam out there on the current Firmware that does function that way.

If Wyze doesn’t bother to update the firmware soon, I’ll post all the data and prove it.

Thanks much for reading.

2 Likes

Mine is greyed out too

1 Like

Yesterday I unpacked two brand new V3 Cameras, updated the firmware to the latest one, inserted SD cards in both, formatted and… experiencing exactly the issue you guys reported.

In both two V3 cameras (no cam plus plan, only SD recording):
1.the SD cards are visible and formatted properly, size is reported correctly.
2.The recording timeline is available (live stream → view playback) and reports recordings correctly, replays the recordings etc.
3. However, when you try to access the specific recording from the specific EVENT (events → [video preview] → PLAYBACK) the app says “MicroSD Card Not Found”

This is a serious bug which affect the overall app usability, needs to be fixed ASAP.

6 Likes

I’m having the exact same problem on a V3 that I installed yesterday set to Continuous Record. I can view playback from livestream but clicking on events returns “MicroSD card not found”.
I didn’t format it. It started recording without doing that on any any of my cameras.

All of my older cameras are set up the same way and functioning for a few years now with no problem.

This is definitely a Wyze problem. Not user error.

2 Likes

People have been sending in logs and complaining about this for months, perhaps years.
They know about it.but simply refuse to fix it.

I just threw all my Wyze cams in the garbage and went with a chinese brand which is cheaper and works much better. I really don’t need customer support because everything just works.

Wyze is way beyond the curve with technology and can no longer compete. I expect them to go bankrupt soon

2 Likes

I recently acquired 12 refurbished Cam V3 cameras and encountered a consistent error when attempting to access the Playback feature from the Events screen. Each time, I receive a “MicroSD Card Not Found” message. Interestingly, I also encountered this exact issue with a Cam V2 model I had in storage and reactivated. This suggests the problem lies not with the individual cameras but in the software. Has anyone found a resolution?"

1 Like

Yes, the solution is quit Wyze and buy the Tapo C120

SOLVED: I got all my cameras to work. The fix is a bit unusual.

  1. Go to Cam Plus Lite and uncheck the camera that has this issue so the camera doesn’t have Cam Plus Lite anymore.

  2. Then, make the camera record any Event.

  3. Attempt to playback an Event and try the “Playback” feature. The issue will still be there.

  4. Reboot the camera.

  5. Attempt to playback an Event again and hit “Playback.” This time, it should access the memory card.

  6. Finally, reactivate Cam Plus Lite. The issue should now be resolved.

4 Likes

Your solution fixed my v3 “SD card not found” error from the Events screen. Thanks for sharing!

3 Likes

@WyzeJasonJ , can you let the engineering team know stanlam’s solution (two posts above) fixed my “SD Card Not Found” error from the Events screen? This should help the engineering team track down the bug in the code.

3 Likes

Update 7/2/24 Started getting the “SD card not found” on my Wyze Cam Pan (OG), my first Wyze cam purchase a few years ago. Went through this process again & it resolved the issue. I just ordered a TP-Link to compare it to Wyze…

I had Cam Lite on my V3 and had switched it to Cam Plus at someone’s suggestion and it still didn’t solve the “SD card not found” error from the Events screen.
Your solution fixed it! So, whether you have Cam Lite or Cam Plus, this solution works. Thank you so much, stanlam! @Wyze should offer you $ or one of their products for your work.

3 Likes

This gave me an idea. I have 2 pan cam V3s and both have the dreaded “no SD card bug”. I have Cam Plus but since Wyze disabled removing cameras from Cam Plus, I have no way to test this method. But thinking “Reset Services” is almost similar, I tried it instead. It immediately worked for one of the 2 pan cam V3. The second didn’t work at first.

I then looked the SD card. It was full and reformatted it. Then I waited a little and tried to “Reset Services” for that camera. And it worked!

So yes, I don’t have that bug now.

3 Likes

Wow! Interesting discovery.

Remember that under normal conditions, the µSD card will always be almost full. When the card runs our of space, it deletes the oldest hour or recording to make space for new recordings.

2 Likes

I knew that, but just making sure, Wyze has always been wonky about these things.

1 Like

It’s supposed to be included according to what I read when I bought my first camera, but they have so screwed up this service it is time to find another service that honors what they say when they sell something, and don’t change it when they feel they aren’t making enough money, like since January 2024.

My V2 now has the problem


Mine did the same thing. You’re going to have to delete the version 2 cam. Then add it back as if it’s a new camera. (I thought my V2 was the only one that did this.) Here is what i did.

  1. Delete camera through the app, and add it back as a new camera.
  2. Do NOT activate Cam Plus Lite yet.
  3. Get the camera to record an Event.
  4. Press the Event icon so you can see the list of Events.
  5. Click on one of the Event and hit Playback. (It should play SD Card now.)
  6. Activiate Cam Plus Lite now and it should work.

However, now I notice sometimes when I hit the Playback button from the Event screen, it will give “The Camera info is null!” error. If that is the case, then exit out of Event screen and press “View Playback” button, and let it play for 1 second. Then go back to the Event screen and you should be able to use the Playback button.