Night vision not switching on

I have 2 Cams both v1 that are set to auto for night vision but never seem to switch to night vision when it gets dark. I see all black at night in my recording but if I manually switch night vision on, i can see my rooms pretty well.

You need to leave that switch turned ON for the lights to ever come on. (It’s a setting, not a real time on/off switch.) Turning it off means the lights are deactivated. The feature exists to prevent window reflections.

1 Like

@Customer is correct. The “Night Vision IR Lights” will automatically go off when the “Night Vision Mode” is set to Auto. If you switch the Night Vision Mode on/off while you’re next to the camera then you’ll hear the IR filter switch in/out from in front of the lens. Night vision also gives you the Black & White picture.

BTW: @mmistry1968 Welcome to the Community forum! :slightly_smiling_face:

1 Like

I do have the Night Vision set to AUTO and Night Vision IR lights set to ON for one camera and still it does not seem to switch to Night Vision mode ON at night. The other camera is in from of glass and so I keep the IR lights off because it is recommended in the App to do so and also with the lights on, there is reflection from the glass. So this camera also doesn’t switch to Night Vision ON when it gets dark.

1 Like

Any more thoughts? Tried restarting and toggling night vision settings but still not coming on automatically.

Is it bright enought in the area the cameras are looking at that they dont need night vision to see? Able to post a picture if the camera view and or your advanced settings page? See if anyone here can see something amiss?

As you can see below, the setting for both cameras is the same. Also, there is no light in either camera at night but the night vision is not turning on as it should. I have tried turning it on manually at night and then it seems to stay on for the night, turns off in the morning but does not turn back on automatically at night again.

Any help would be greatly appreciated.

Well that’s not right. :frowning:

Maybe there’s an issue with the V1s? Most people who post here seem to have V2s.

You could try changing firmware versions I guess.

Thanks, I just checked both my cams and realized they are both V2s and both on the latest firmware,

Okay, then it really doesn’t make any sense to me. Basically impossible that all the LEDs failed in both units. Why won’t they turn on in the dark? Dusty / failed light sensors?

Hi @mmistry1968 Try placing the camera in a light tight box or refrigerator and close the door. The Night Vision should turn “on” with the B&W picture. This is independent of the IR Lamps. Often I set the IR Lamps to off due to the number of bugs it attracts.
If the Night Vision doesn’t switch on automatically when you enclose it in a pitch dark place then create a log file, call Support and give them the log file number.

Live support is available: +1-206.339.9646
Monday - Friday 5 am - 6 pm PT | Saturday 8 am - 4 pm PT

1 Like

Ok, v2. Yes they should still work, like @Customer stated, it’s super interesting that both units are behaving the same way here. What Wyze app version are you using? A super old one perhaps? Is this a new issue or how long have they been doing this? The latest firmware is under a month old. My next suggestion is to manually firmware flash one of the cams back to the previous November firmware, or farther back depending on when this started for you.

Edit in later because I realized my thought just stopped. Lol..: To see if the auto switching returns to normal. Just trying to weed out the link or similarity that’s causing this.


I have tried everything. All the settings are correct and the app and firmware are the latest. When I put a box over the cameras, they switch to night vision mode automatically but they don’t seem to switch at night when it gets dark. Maybe it has to do with the speed of the transition from light to dark and if the transition is gradual, as in real life, it doesn’t trigger the night vision.

Is there a setting to manually turn on/off the night vision at set times throughout the day?

If you looking for a way to automatically switch nv modes, no there isn’t at this time. If you looking for a way to manually change it, then yes, you can click the auto/on/off button in the app just above the live stream on the right.

1 Like

Yes, I was looking for an automation for switching NV on/off.

Your night vision, when set to “Auto” should switch when it gets dark. There should be a little click as the camera moves an IR filter in front of the lens creating a black and white picture. Sometimes it takes 5 or 10 seconds to switch in and out.

When the camera is outside, you will get the color picture until it is hard to define objects, then should automatically switch to night vision. I see you have “Night Vision IR Lights” set to ON’; so you should not have the black picture shown on your screenshot.

Sometimes LED lights will fool the camera light sensor into thinking it’s lighter then actual. Seems like you have a poorly performing light sensor. Recommend to open a Support Ticket and see if they will exchange. :slightly_smiling_face:

1 Like