New pan and tilt will not take firmware upgrade

So i got a new pan/tilt camera and plugged it in. Went through the setup just fine. Told me i have a new firmware to update and so i followed the process.
have done this many times before on my other Wyze cameras.
This time after 3 tries it keeps failing.

going from

Any thoughts on this/help is appreciated.

Thank you in advance.

OK so quick update. tried 5 times and finally it took the update. Strange.
Usually goes on the first try

Also odd the wifi signal says 86% and it is sitting right next to the router.
Should be 100%

1 Like

I think there is varying quality in their antennas.

1 Like

I had a similar problem earlier this year and learned the following. Before starting the Wyze App on the phone, turn off the mobile data antenna, connect the phone with the Wyze App to the same 2.4GHz network which the cameras will be using, start the Wyze App, then power cycle one camera and perform the setup (e.g., “scan QR code”, etc). That worked for me and I hope it will for you.

Edit: I meant to add that I needed to delete the camera and THEN re-install it (QR code, etc) before the firmware would update.

Thank you both for the information.
Next time I will try that. I have several other devices on order and hope they connect easily.