New monitor base fails to upgrade firmware

My monitoring system base arrived today.

Aside from refusing to pair to either of the opening sensors I tried, install was straightforward.

Until the point where it wanted to update its firmware.

It has now completely failed five or six times, with no message other than the “oops! try again?”

I’ve tried having it do it from both my iPhone and iPad, and even leaving each a foot away, with no luck on either.

I could use any ideas here.

Unsure what your issue is – after I saw this post I finally updated my Hub, and it took right away.

Anyway, I just wanted to clarify that there is no transmission from the iPhone or iPad to the Hub. On updates where it doesn’t tell you that you have to stay on the update page, the firmware update transmission is from Wyze thru your router to your Hub. So the distance between the Hub and your router is what is important. I suspect that is good since you are still setting up and have the Hub plugged in with an Ethernet cable?

So your Hub may be broken, especially since you can’t add sensors either. You may need to call Wyze Support to see about a replacement.

Customer Support

There are many ways to contact Wyze. Their phone number is (206) 339-9646, or you can chat with an agent or create a ticket on the support site.

They’re open for support between 4 am-8 pm PT Monday through Friday, and 8 am-4 pm PT Saturday.


the distance from the hub to the router is about 4" .

I also can’t do anything with monitoring now, as that button in the app goes straight to installation, and there is a modal dialog to start the update.

There is no way-out of the screen, either, nor that which eventually comes up to try again, other than force-quitting the app.

I’ve found another path to updating, under accounts-> update firmware. It shows a message in brown test (really? bizarre . . .) to make sure it’s plugged in to power (uhm, really? how else would the app think it’s talking back to it, or keeping a blue light on).

[a couple of hours later]

After trying various combinations of ethernet/not and resetting, I got it paired for a while until it went off network

I also got low battery warnings. I hadn’t even known it had a battery.

I guess I need to give it a few hours to try to charge?

I’m scratching my head over this tomorrow, I’ll see what the few hours do for it.

And is there a list somewhere about what the three lights mean in their various patterns? (and are they always blue?)


1 Like

thanks, but I’d found that one, and it doesn’t describe how a hub actually behaves!

I’ve seen

  • all three lights blue, solid
  • the three rotating blue left to right, one at a time
  • just the left blue, solid
  • just the right blue, solid
  • left blue solid, middle and right alternating blue

I’m assuming that at least one of these means “low battery”, and the rotation of one at a time was during the flash update (which finally worked on about the third actual entire hub installation), and I think just after reset as well.

I suddenly recall a tale from the late 70s, in which a reliable mainframe suddenly started crashing.

When the dust settled, it turned out to because someone (a grad student?) had the bright idea to reprogram the main panel’s idle sequence from the sequence of single lights to a Cylon-style back and forth–which left the same incandescent light on again too quickly and cause that part to overheat, bringing th rest down with it!

The 70’s mistakes were the 80’s successes :wink:

Don’t remember KITT overheating, Hello Michael


Interesting I have never seen these patterns on mine, it been in service for 10 months now. As Newshound suggested you may need to contact support with a faulty hub.

now I know how I’ll be spending tomorrow . . .

From what the video shows, your Hub is trying to connect or is downloading firmware updates. So, basically not good if it keeps it up, which it is apparently doing.

Best thing to do under that situation is leave it plugged in with an Ethernet cable, and a port on the router that you haven’t used before. That should eliminate bad WiFi info, bad cable, bad router port.

But you may end up calling Support over this one.

1 Like

even during the brief periods it was working and responsive, they were always blue when I looked.

At the moment (in the video), it’s probably looking to connect again.

I called tech support yesterday and we diet the hard reset, and stepped through. With a couple of quirks and setbacks we got it online.

A couple of ours later, it was gone, and couldn’t come back again.

In the afternoon, I called again.

This time the gal had me download another phone app to test my connection.

She concluded that I lacked sufficient bandwidth (it’s an Wifi 6 router/ 5g transceiver combo). uhm, it consistently tests out at 200-300mbs down, and 30-40mbs up . . .

We got to the end, and it seems to stay up so far.

Before those and some other failures, it apparently sent a messages either that the battery was low, or that it was running on the backup battery. Yet it had been plugged in around the clock for a week, and still was . . .

It’s possible that the glitch was on the Tmobile router–I noted at one point yesterday that we had no wifi for anything else, either, even though it showed the usual bars of signal strength.

So we shall see . . .