New firmware (Oct 5 2020) update failed on Cam V2

Help! I don’t post regularly.
I have had a Cam V2 since summer 2019 which I bought to install outdoors by the house front door. I posted pics last year.
My issue is that I tried to upgrade the latest firmware today and it failed 3 attempts! I was especially eager as my camera stopped notifications which I discovered was tied to no recordings being stored locally. I was trying to eliminate the possibility of my failed recordings being due to installing new 256GB cards (from Samsung, bought at low prices on Amazon). My camera didn’t complain but maybe I was pushing it too far. :smile:
I tried calling the service phone earlier but I was on hold for over 5 minutes and lost patience.
BTW I am a techie and am sure I didn’t make any obvious mistakes.

Welcome back! The camera still works though? Its just that the firmware upgrade didn’t take? If you remove the SD card from the cam and restart the camera, does that help the notifications start again?

If you want to try a manual firmware flash you can try that with the camera, and can always manual firmware flash back to a previous firmware when you want. You’ll need a 32 gig card for the flash process though.

1 Like

TY Omgitstony. Sure, I lost time this evening trying to do the firmware upgrade; it was getting dark and the camera is outdoors. I still have the previous 32GB card but was thinking of trying a new 64GB card. If I don’t succeed with either I will do a manual flash. So, IOW, using the larger size card is causing this update error?

Your 64g card is probably not formatted to FAT32, It is not damaged. it is probably formatted to exFat. if you are on windows 10 it probably won’t have the FA32 option for formatting to FAT32 when it sees a 64g card. You will need to download a third party software to do that. You can try this SD Card Formatter FAT32 Free Download (Windows 11,10, 8, 7) and format your 64g card to FAT32. I use continuous recording on all 5 of my Pan Cams and I use 64g cards in all of them and I format them to FAT32, They are preformatted to exFat by the manufacturer. The reason Wyze tell you to use 32g card it because by default any card 32g or smaller are formatted to FAT32. If you format your 64g card using FAT32, the Wyze cams still see usable 58/59g space, Yes you lose a couple of gigabytes to file system. Same for 32g, usable space is around 28g after formatting. Windows 10 can read any format FAT/FAT16, FAT32, NTFS and exFat but Wyze cams O/S and firmware have limitation of the type of filesystem format it can read.

TY wyzzz. BTW, I was currently attempting to use a 256GB card; my 64GB is an alternate I was going to try as the 256GB seemed unusable. Anyway, I thought I had checked the formatting before I used it in the Cam V2. Maybe I misinterpreted what I saw. I will remove the card and reformat as per your suggestion . TY once again.

Hi! I just tried and I get the blue/yellow light at first and 20secs after it turns to solid yellow and nothing happens!!! Please help.

This update completely bricked my camera. As soon as I ran it it went off line. I have tried reflashing the firmware and also tried the version before this one, but no matter what the connection times out and the camera no longer finds my wifi.

yes mine too , it is really frustrating
I had just brought 2 new cameras and a 12 month subscription
I feel like I’ve been robbed :frowning:

Update (yes, a bit delayed).

So, as Omitstony suggested, I used the old 32GB card and was able to successfully upgrade the firmware. However, when I then tried to format a 64GB card per wyzzz’s suggestion, I had a strange hiccup of the camera continually reporting that “no card was detected”! It got so bad that it no longer even recognized the 32GB card which I had used successfully to upgrade the firmware! I was so disappointed … that the camera which was working for over a year suddenly basically “cra…ed out”. After retrying to format the cards on my Windows laptop, using the 3rd party software per wyzzz’s suggestion, the camera’s card reader seemed broke/fried. In frustration, I set it aside for a day. Then a couple of days ago, when I tried to verify the 32GB card using my laptop, it said it found errors! Anyway, out of alternate options, I repaired the 32GB card and this time my cam 2 read it! Gaining confidence, I reformatted the 64GB card to FAT32 and this time the cam 2 didn’t complain! I mounted the camera outdoors and it has been working fine for 2 days now. TY everyone.

1 Like