Firmware update bricked my Pan?

Today I (again) got that pop-up to update FW, so I went to account menu to update all of them. 9 of the cameras needed update (I think I have 14 total). So I click “update all”.

After waiting couple minutes, 6 of them updated, 3 of them failed. I click again “update all” to try again on those 3.

This time 2 of them updated, one failed. Didn’t pay too much attention, I had to leave to take my bunny to vet who’s the main subject for the cameras anyway.

Now back home, I checked that one last that failed again. App said it was offline, and the LED light was solid yellow. I tried all known items:
-remove power cable
-press reset button 10-20 seconds
-insert new FW on SD card, press reset 3-6 seconds while apply power

Nothing I do seems to do anything, the yellow led just stays solid.

I just chatted with the csr, and they basically said to try all those things I already tried, and then asked for purchase date. It was already out of warranty, so they won’t replace.

I understand electronic devices die for various reasons, especially when you have lot of them, you have higher likelihood of them dying occasionally. One of my earlier cam lost nightvision, so I can only use it at spots where I don’t need to see in the dark. But this time it died due to the FW update, because it was working 5 minute earlier and now it’s unresponsive. It’s been working happily some 2+ years without me needing to touch, so kinda unfortunate it died on the update. Makes me question if I should take any updates in the future either.

Does anyone have any other tricks on their sleeve that I could try to bring the device back to life? I’m couple miles from their office too, I wonder if they want the unit back for FAE to understand why it’s bricked.

1 Like

I had a V2 camera once that was hinky until I powered it off and removed the SD card and turned it back on. I think the possibility exists that if an SD card starts to go bad the camera may not always know how to deal with the corruption of the SD card.

The only thing I can think of you haven’t tried is what @oldgeek said, try booting it with the SD card removed and see if it boots. The only other thing is I never use the update all function, I will update all my cameras one at a time, just my personal preference.

1 Like

I didn’t have card in until later when I tried to get it back alive.

I removed it now, and no change. Still only yellow light. Sounds like dead.

Same here. Did it give an error code. Mine gave 20009. No listing for 20009. No sd card in mine either

I ran into the same problems as everyone else on this thread. I got my Wyze Cam Pan to work by going back to the November Firmware update ( and putting that on the SD Card. I followed these directions to flash the firmware:

  1. Download a specific version of firmware, unzip it, put it on root directory of your SD card and rename it to ‘demo.bin’
  2. Power off your camera, insert your SD card
  3. Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds
  4. Once the light is solid blue, release the button and wait for 3-4 minutes. The camera will reboot and change light status during this time.
  5. After it is done, your camera should be functioning with original setup. No need to re-setup your camera!

The only caveat is I had to hold the setup button for almost a minute before the light turned blue.

Just wanted to give this update in case folks have not tried rolling back to a previous firmware revision.


1 Like

Thanks for the tip. Unfortunately didn’t work for me. Tried several times, up to 2 minutes too but no luck.

I am sorry to hear this.

Same with me. one of my V2’s was bricked after this last update. I had several cameras that I upgraded at the same time. One never came back online. Same solid yellow light that everyone is taking about. Tried all of the same things to fix and still a no go. Pretty sure it’s out of warranty but still not happy that a firmware upgrade caused it. Wyze should replace it from a customer point if view. There should be some accountability.

Same issue with this new update.

I will update mine oneeeee at a time from now on thanks for letting me know :scream: I’m sorry about your Pan ! Did you try restarting it with the app ?

I have the same issue and none of the fixes are helping. I was expecting more from Wyze than just a “sorry we bricked your device but your warranty has expired”. I guess they aren’t so different than the other guys. This was not planned obsolescence but more like scheduled obsolescence.


I seem to remember a similar post by @Customer (I think). One solution was to load the Dafang firmware which allowed the camera to run RTSP. Never was able to get the Wyze firmware to load.

1 Like

My PANCAM is bricked too. I’ve tried a lot of things to no avail.

New firmware also ruined the WyzeHacks script to record to NFS shares. Now none of my cameras can record to my remote share. Any chance of the wonderful software team at Wyze actually adding NFS or FTP or some kind of remote recording other than its own Cloud service or am I wasting my time asking?

Same issue… I removed the Wyze Cam Pan from power for a couple of days and when I plugged-in it can’t connect no more and just yellow solid light, tried reset 3-5-10-20 seconds, removed plug in-out… nothing… I don’t know what’s happening… I just need to reset everything, but it looks like not working… I had this camera for almost 2-years…

I have 2 pans I bought early this year that bricked on firmware update. Business as usual.

I want to add my Pan v2 as well to the list of so far bricked devices. I’ve had it for a few years and I decided to open the application because I got the security system and I found a Pan camera I bought years ago! The second pan updated well and the original I was using bricked. The only difference was that I signed up for a beta firmware when the google home assistant testing was happening. The new camera didn’t have that. If anyone else who got bricked wants to chime in.

I couldn’t reset it or update the firmware manually. It said error 90.

Well…time to add my “bricked” v2 camera to this thread. (4) of my (5) v2 series cameras took a recent firmware upgrade with no problems. However, the 5th camera did not. I’ve done all the steps provided WYZE’s “Flash Firmware for Wyze Cam v2 & Wyze Cam Pan” webpage (same as "“bruwuser” provided above, and making sure the file name was renamed to demo.bin. But it’s been a no-go process. I get the blue light led as indicated on step 4, however light status never changes nor reboots camera. Repowering the camera without SD card in only brings camera to orange light status, but with no ability to go into setup mode. Anybody else out there have/had this condition and found a corrective procedure around it?

Same here. Even got the blue light but no light changes nor camera reboot afterwards (last part of step 4). Assuming v2 Cam is totally “bricked” and now just a one-eyed paperweight.