My thermostat is stuck to Wize logo

I changed my internet box going to Fiber. Network parameters have therefore changed.
In my thermostat, I have selected ‘restore factory settings’ with the hope that it will give me the option to reassign the new network. Now it is stuck on the logo Wyze forever and it seems I dont have access to any other option on the thermostat itself.
What can I do to link it to the new network?
Thanks for the help

Hey, try power cycling the thermostat. You should be able to remove it from the wall to remove power, or you could just flip the breaker. See if it comes back. In the future, if you set your ssid and password on your new router to match the old one, everything in the house will automatically connect again


the power off did not do anything. i can try the ssid/pswd change…Wyze tells me it is over, send it back!! this is crazy that a new thermostat does not handle a network change…

Remove the device from the app and remove the t-stat from the wall and insert it back in . See if that helps

the t-stay?


what is the T-stat exactly?

T-stat is short for thermostat

@Rulwiz is suggesting a complete deletion from the app and factory reinstall, which seems to be the next logical step. Treat it as a brand new install.

After you have removed it from the app, go thru the setup wizard in the app as though you are installing a new thermostat. Be certain your phone is logged into the WiFi, your Bluetooth is On, and your GPS location is On. If the thermostat head still locks up after you plug it back into the wallplate, try pressing in on the center of the knob for at least 10 seconds to reboot it,

1 Like

ok thanks!!
I did these tests nothing worked. I went to exchange it at home depot. new one is installed and works fine.I feel that these devices do not handle well the change of network credentials.
The idea to change the SSID and pswd of my new network to the ones of my old network might have worked but I find that if this is the source of the issue, these devices have a serious flaw.

1 Like

I’m glad that you were able to get a replacement , glad it all went well

This is not a widespread problem, your device could have been defective. Glad you got it working now!

Please mark your above message as solved so others can find the solution if they experience a similar issue.