Thermostat stuck on 'Wyze' screen after reset

I tried searching but either this hasn’t been listed before or I’m simply not using the correct search terms…

I noticed Wyze thermostat wasn’t connected to the internet and then decided to stop blowing heat after working fine for a couple weeks. Did a reset from the thermostat by holding the knob until the reset screen came up.

Now it is stuck on the wyze screen and has been for going on 40+ min. We’ve reset a couple times, I’ve removed it from the app, I’ve turned the hvac unit off and back on a couple times.

Any other suggestions or things that have worked for you?

I think you have to add the device back like it’s brand-new.

I tried that and it keeps saying connection failed. I may try restarting our modem in a bit. My husband works from home so I haven’t been able to do that yet.

How long does the reset take? I keep trying and even after almost an hour it’s still stuck on Wyze screen

Long press the button on the thermostat… it should give you the option to factory reset. Make sure it is deleted out of your app. Clear the Wyze app cache in your phone and close the Wyze app.

Reopen and try to add it again. That should do it.

If you have integrated WiFi (2.4/5 Ghz) share the same name… you may need to break out the 2.4 Ghz band for this. If it was working before, then ignore this.