My phone only connects to my cameras the first try. The 2nd, 3rd, etc. attempt won't connect

I have 33 Wyze products all together on the Wyze app. I have all variety of products: cameras (all versions), watches, vacuums, outdoor switches, door locks etc. I depend on the Wyze app and all these products. It usually works fine…but only the first time. By that I mean if I view several of my cameras and then close the app and come back to it later, it won’t re-connect. It only works the first time! This has been a problem now for a few years. I am connecting to devices at 3 different locations on 3 different networks across the country. The app will open fine on the second try and I see all my devices but when I try to connect to a camera, any camera, it tries and tries and then says the connection is unstable and to switch to a lower resolution stream, but ultimately fails to connect. The only solution I’ve found is to reboot my phone (a Samsung Galaxy S1 ultra on T-Mobile) and when it comes back fresh, I can connect to everything with no issues. But, only on the first try! If I then do something else on my phone and then come back, reopen the Wyze app I again, cannot connect to any of my cameras. Again, I have to do a phone reboot. This is most frustrating. Can anyone help?

It sounds like something within your phone or app isn’t letting go of the first P2P stream session on the cam when you close it and is preventing a second P2P stream session to connect.

What App version are you running?

Have you tried uninstalling and reinstalling the app?

Do you have Running in the Background and Hardware Decoder toggled on in the App Settings?

Is this happening while on any specific internet connection - Home WiFi, LTE\5G Mobile Data, other WiFi?

Are you running any type of VPN Security App that would police URL address connections?

Thank you SlabSlayer for your help…much appreciated.

I’m using v2.43.5 (313).

I have not tried reinstalling the app…I’m quite reluctant as, as I said, I have devices all over the country and to re-add them, I’d have to travel to each of those locations and be without the monitoring until I could get there for each. It would take a year to get things back to where they are now…so, very hesitant to do that.

Yes, I have “Running in the Background” and “Hardware Decoder” toggled on.

I have this problem where ever I am, everywhere… Various WiFi networks or mobile networks anywhere in the country.

No VPN Security app…nothing that should stop connections that I know of. And, why would it connect fine the first time?

Another clue maybe…sometimes (less than 10% of the time) it WILL connect again without rebooting the phone. But still, it’s very rare and very frustrating.


Deleting and reinstalling the app will not remove any devices from your account. Those are stored on the server, not the app. They will all appear back in your device list once you log in.

Before you do that though, try clearing the cache in the app, signing out, force closing the app, reopening it, signing in, and testing it.

It might also be useful to isolate it to your phone \ app combo by installing the app on a different device to see if you get different results.


Like @SlabSlayer stated, deleting the app is fine because the device settings are tied to the cloud. You can test this by taking another phone or tablet and loading the wyze app, and logging into your account on that phone or tablet. All your devices will populate because your devices, cameras etc are tied to your account not your phone.

1 Like

Are you using 2FA for protecting your account? You might try first to disable that. See if it makes a difference.

And in the meantime, while you have it disabled. You might also try logging out of the app, not simply closing it on the phone. Remember this is a test, to help figure out the issue. Logging out and then back in, might shine light on the issue. And when I say, log out, I mean “Sign Out” at the bottom of the page under Account.

Thanks for your help Sam Bam.
I try to use 2fa anywhere I can but can’t see that it’s available for Wyze…so I’d say no I’m not using it here.
But your “signing out” and back in is something I hadn’t tried. I just now gave that a try and actually was successful in getting to my cameras through two separate sessions! There is potential here. But I will have to continue to monitor to see if this actually solves the issue. But does this mean that I have to log out every time? Is that what everyone else does? It is a bit inconvenient.
I’ll test this further and report back.


Account Tab → Account → Two Factor Authentication. You have a choice of Authenticator App, Email, or SMS Text.

1 Like

Thanks SlabSlayer.

Indeed, I now see and have set up 2fa using an authenticator app…much better. Thanks.

I then tried to access my cameras (hadn’t seen your note at the end of your comment yet) and found I couldn’t get to my cameras (same old problem). But I then saw your note and:

I cleared the cache, logged out and logged back in (with 2fa), but was still unable to access the cameras. I rebooted my phone and then everything worked fine. I will try more troubleshooting tomorrow…still looking for suggestions…keep em coming, Thanks

1 Like

It looks like deleting the app and re-installing is the next step (and hoping everything comes back the same). I’ll attempt that tomorrow and let you guys know.

I can’t thank you guys enough for working with me on this!!!


1 Like

OK, I haven’t yet deleted and re-installed the app. As I said, I was reluctant because I was concerned about losing all my 33 devices and not being able to re-add them. I’ve been assured however that that wouldn’t be a problem as all my cameras etc. are stored in my account…not the app itself. Great. But here’s another issue: To be sure this works, I attempted to add the app to an iPad and log into my account. It took about 8 tries. I have two logins for Wyze,… and The former is to the devices and the latter is more administrative. Unfortunately the account was established years ago when Wyze first came on the scene. I was an early adopter but was a little unsure of them at first and used kind of a throwaway email account to get it started. I no longer have access to that email so it can’t be used for “recovery” purposes. So I’m reluctant to make any further changes or delete the app until I can set up my account with a current viable email address. Reading on their site, it looks like I will need to talk to them directly to make that change. I feel I must do that before I move forward. Any clues on how to reach them to make that change? Thanks much.


Good. Glad you can’t access that old account. If I were you, here’s what I would do.

  1. Create a new account, - I guess you could say a 3rd. Then I would select one of my devices and add it back to the network - that same WiFi network but using the new account. Doing this will (should) show you if the app is the problem. Because - who knows? Could be something wrong with your old account. And if the issues don’t disappear, you know know that between two account, and one newly added devices to the new account - if the problem persists, it must be the app. The only loss is having to add back that lone device to your old account after you remove and add the app back.

Make sense? (It do to me.) lol

Best of luck on getting the email changed without creating a new account and reinstalling everything from scratch.

Customer Support

(206) 339-9646 or 1 (581) 500-1166 (Canada)

I tried that and they won’t change the email and none of my devices will add to my new account so I basically have three devices that are now doorstops!!! Wyze has been zero help!

I’m not really sure what is going on with the app not reconnecting to cams after the first try. It would really need to be something that someone testing it could reproduce and log while changing possible variables. I’m not going to be much help with what is causing that since I can’t reproduce it and I have seen no other threads or posts in the forum except this topic.

As for changing the email on your account, I haven’t read of anyone being successful there since Wyze uses that email as the unique identifier for the account.

There shouldn’t be any issues with adding devices to a new account unless they are Wyze Outdoor Cams that are still on the previous account. There is a special way those need to be removed from the old account first before they can be installed on the new account to prevent bricking them.