My Outdoor Plug(s) turning on / off at random times (Hacked?)

My Outdoor Plugs are turning on / off at random times! Is somebody accessing my outdoor plug or is this a glitch? For the past several months, my outdoor plug(s) are turning on / off at random times, mostly in the evening. I tried rebooting and resetting my outdoor plugs, nothing helps.

Did you check for rules? Schedules? Vacation mode?

1 Like

I have owned this for over a year and Do Not Use Rules, Schedules, and/or Vacation modes!

This is an important outdoor duel switch that is controlled manually. Having this turn on / off randomly has forced me to take it offline until someone give me a solution. My other outdoor plug has been doing the same thing.

Specifically, it turns on from off, then turns off within a second of so.

It acts like some a server is cycling communications with my outdoor plug(s).

I cannot have the outdoor plugs cycling by itself and if I’ve been hacked, NONE of my other wyze devices (single power plugs, cams, PTZ cam, etc.) are acting in the same way. Only my two outdoor plugs have this cycling problem. BTW, my outdoor plugs were purchased many months apart!

If you think someone has gained access to your Wyze account you should immediately change your password and, if you haven’t already done so, turn on two factor authentication. Not likely to be the issue, but just in case.

I don’t think my wyze account has been hack because none of my many other power devices are doing this. I would put money on a software bug with the outdoor plug(s) or the wyze server is responsible some how. I hope someone can figure this out soon. Thank you

1 Like

Are you sure you aren’t accidentally in Vacation Mode? This sounds a lot like that. The only real indication is a color change from white on the vacation mode icon (see below).

Beyond that, what app version and Plug firmware version are you using?

1 Like

Thank you. No vacation mode used here. This is all manual operation using the app.

The firmware for app and outdoor power plugs are up to date.

When I say my outdoor plugs are turning on/off, please note that the cycle time is about a second or so. It’s like having the wyze server or some type of web crawler sweep my device for a handshake. It becoming unnerving like someone is controlling my devices and maybe even watching using the cameras?

I wonder if there is a way for our Wyze app/devices to block/restrict the public IP access and only allow local IP access? This might help keep our government or some sicko from spying on us using our wyze devices connected to the internet?

I have had the issue where the plug (indoor) will randomly turn on and back off very quickly. I’m not sure what causes it, but it’s not often and I don’t think much of it.

Probably the same case for you.

If your worried about people watching your cameras, then changing your password and enabling 2fa is the first step towards preventing that.

The plugs must be connected to the internet as they are controlled from the Wyze server.

1 Like

I’ve had no issues with my outdoor plug v1 (is there a v2?).
check line voltage at the outlet you’ve got that plugged into?
Take the outdoor plug and bring it inside to a different outlet?
Try it without an extension cord if you’re using one?
Do a bench test - just plug it in the kitchen, wait a few minutes, and see if makes the clicking sounds?
Try buying a new one, add it to your app, plug stuff into it, see if that one also does it in the same location?
If you don’t have MFA turned on - mutli-factor authentication - you are asking for trouble.
This unit you have is connected to your internal network wirelessly.
If this keeps happening, change your network SSID, make it hidden, change the key, update all devices in the house to use new SSID/password, and change your Wyze password. Yes will be a lot of work. Try the other things first.

1 Like

“The plugs must be connected to the internet as they are controlled from the Wyze server.”

Bingo! What exactly is the wyze server doing to my outdoor plug and why does it need public IP access when I am controlling my out door plug using my iPhone connected to my local network to control the outdoor plug?

I’ve decided to block wyze having public IP access to my network to see if the outdoor plug continues to have this issue. This should help identify where the unidentified commands are coming from; outside my network or inside the my network within my local IP.

I may be wrong but I don’t believe any local control is supported with the plug. Even if your on the same network in think commands must still go out to the server and back. Again, I could be wrong about this. Wyze may support local connections when possible.

Rules and non-local schedules all require internet access though.

Also, if the app doesn’t have access to Wyze server it will lock up and prevent you from doing almost anything.

The plugs need to call home when the boot up, so blocking Wyze will pretty much break everything.

1 Like

Your plugs are going through NAT - network access translation - most likely within your internal WIFI network to access the WYZE servers in the cloud.

I also believe that when you click a button in the app to turn on a light it goes from your device to the wyze servers back through your LAN that is NAT’d by default then back to your device to tell it to turn on or off.

I don’t believe that commands sent to a device - even if your phone was on the inside LAN and not on the cell only connection - ever go directly to the device within the LAN.

2 Likes

Thank you. Exactly my point! The idea is to break communication with the wyze server as a troubleshoot step to identify where the problem is coming from (inside or outside the Local Area Network. I don’t use Rules or Schedules for this outdoor plug.

Unless you are using port forwarding or have turned off NAT or turned on bridge mode on your router there is no public IP for your plugs and no access to them from the internet. The plugs initiate a connection to the Wyze servers so that you can control them via the App. The app also connects to the Wyze servers to establish a connection to the plugs and other Wyze devices associated with your account.

1 Like

Thank you.

Exactly! When I say Public IP, I’m really talking about internet/extranet (global network access); i.e. external communications protocol used to connect and/or talk/control my outdoor plug from outside the local area network.

Lucky for me, to prevent external communications to my outdoor plug, all I have to do is disconnect the modem cable to my wifi router!

I will do this in the everyday at different times to see if my outdoor plug remains steady. Yes, I can still manually control the outdoor plug switching states.

Remember, I trying to isolate the “unauthorized access” to my outdoor plug occurring from external or internal communications.

Remember, my app and devices are all up to date! I have two outdoor plugs and they are acting the same. I am also going to check to see if my regular indoor plugs are doing the same thing. I may have missed it as they are not connected to an audio alert feedback system like the outdoor pugs. Wish me luck!

But I’m fairly sure no one has external direct access to any devices – you think someone has told your outdoor plug to join their wireless network, they’ve gotten past MFA, and they are controlling the device?

1 Like

Thank you. No. It more of a quick On then Off. Happens routinely! Think of if like a wyze server sending it a quick on → off command or if already on, the wyze server sends a quick off-> on command. It flips the on/off state of the outdoor plug quickly.

Another way to think about it; lets say the outdoor plug is triggering an automatic water valve to water your lawn. This bug would quickly turn on the water valve and then shut off. Not good, because its waste’s water in a drought State like California where you can be fined $75 dollars for watering your grass on the wrong day of the week.

I’m understanding this very well now, thank you.

I think you should try a few things

  • Try disconnecting your WAN port from your router. This will kill the internet access to everything on the LAN, especially our wyze outdoor plug. Everything will be disconnected from the internet. Report back. Plug everything back in after the test.
  • Try unplugging your internet modem from the wall. Your router should still broadcast the wireless throughout the house. Everything will be disconnected from the internet. Report back. Plug everything back in after the test.
  • While still outside, remove any extension cords you have going in or out of the wyze cam outdoor. See if the flashing happens. Report back.
  • Plug in a normal incandescent light, bypassing the wyze outdoor plug, directly to the outside outlet and see if the light flashes.Report back.
  • Move the wyze outdoor plug indoors and connect it directly to an outlet near your wifi antennas. Plug in two incandescent lamps. See if the light flashes.
  • Repeat the last test, only this time attach your outside extension cord between the outlet inside and the wyze outdoor plug. See if the light flashes.
  • Buy another wyze outdoor plug. Try with that new one. If problem goes away, return the old one in the new box. Buy from a place that does refunds, like home depot or wyze.com USA online store or Amazon seller that allows refunds.

Please try all of these things, one at a time, and report back any findings over the next few days. I know time is money. Just trying to help you eliminate things.

WorldwideDave,

Please see my responses below to your questions.

| WorldwideDave
March 16 |

  • | - |

I’m understanding this very well now, thank you.

I think you should try a few things

  • Try disconnecting your WAN port from your router. This will kill the internet access to everything on the LAN, especially our wyze outdoor plug. Everything will be disconnected from the internet. Report back. Plug everything back in after the test.
    Answer: When disconnected from the internet, the problem goes away!

  • Try unplugging your internet modem from the wall. Your router should still broadcast the wireless throughout the house. Everything will be disconnected from the internet. Report back. Plug everything back in after the test.
    Answer: When modem is disconnected, the problem goes away!

  • While still outside, remove any extension cords you have going in or out of the wyze cam outdoor. See if the flashing happens. Report back.
    Answer: No extension cords used. This outdoor plug is used indoors and within 5 feet to wifi router.

  • Plug in a normal incandescent light, bypassing the wyze outdoor plug, directly to the outside outlet and see if the light flashes.Report back.
    Answer: No light was used. Instead, a 120 VAC latch relay was used. Problem still occurs randomly, mostly in the evening. Heavy Traffic hours? Network analysis shows wyze servers have litttle to no bandwidth. Ping latency runs from less than 10 ms to over a 2400 ms with an average of 467 ms. I suspect that the servers are the problem.

  • Move the wyze outdoor plug indoors and connect it directly to an outlet near your wifi antennas. Plug in two incandescent lamps. See if the light flashes.

Answer: No extension cords used. This outdoor plug is used indoors and within 5 feet to wifi router.

  • Repeat the last test, only this time attach your outside extension cord between the outlet inside and the wyze outdoor plug. See if the light flashes.
    Answer: This test was not performed as it would prove nothing since the outdoor plug has always been indoor and withing 5 feet of the wifi router.

  • Buy another wyze outdoor plug. Try with that new one. If problem goes away, return the old one in the new box. Buy from a place that does refunds, like home depot or wyze.com USA online store or Amazon seller that allows refunds.
    Answer: Both old and new outdoor plug has the problem.

Please try all of these things, one at a time, and report back any findings over the next few days. I know time is money. Just trying to help you eliminate things.

More observations: Network analysis for between wifi router and a TX/RX device indicates less than < ms and zero packet loss after 12 hours of testing. I can only conclude that the problem is faulty communications somewhere outside my network, bad design, and/or high latency causing a quick disconnect/reconnect and/or connect/disconnect with the outdoor plug.

I also preformed a device reset on the outdoor plug several times and the problem still exists.

Hi klevonius,
I’m Cisco Certified Network Engineer & Network Admin. All WYZE Wi-Fi radios utilize 802.11g standard that was approved June 2003. 802.11g operates in the 2.4 GHz ISM band. It provides a maximum raw data throughput of 54 Mbps and the widest compatibility for low-cost wireless networking. Older routers use modulation schemes that were mandatory for 2.4GHz but not compatible on 5GHz even when the router supported both bands. The antenna schemes on older routers allowed for a higher degree of multipath interference and were (IMO) a compromise in the aesthetics over functionality in affordable home networking. WYSE also advises using wireless security method: WPA-Personal [TKIP] + WPA2-Personal [AES] as preferred encryption method. This is probably due to using older, cheaper Wi-Fi chips that don’t fully support standalone WPA2 or WPA3. IMO WPA+WPA2 generates unnecessary network overhead and compounds connectivity problems in environments where there is interference from other RF sources. Don’t forget, 2.4GHz is assigned to those old wireless telephone handsets that you been using for almost 40 years, now… The biggest culprit is the ubiquitous microwave oven! If you live in a large apartment complex or a cozy condo, these gremlins will cause mischief on your 2.4GHz Wi-Fi and 3G, 4G, 5G cellular networks.

Outside of RF interference, there are gremlins living in other devices or machines that are plugged into the electrical circuits that supply the 120v to the WYZE Plug. Try putting the Plug on a different branch circuit than where it lives now. Avoid circuits that have large intermittent loads like laser printers, refrigerators, personal space heaters, etc. Turn off any device that is an ion generator (air sanitizers, static charged filters) or that might inject unusual noise into the electric supply. Ceiling fans can do 2 things that interfere with Wi-Fi networks: (1) rotating blades can deflect signals (2) motor speed controls can inject noise into electrical supply. I found that the new generation of car battery charger / pulse repair devices, will crash even the best most robust POWERLINE networks attached to a shared 240v drop transformer. Thankfully, it doesn’t affect Wi-Fi networks…

The devil you need to consider when chasing down the demons that live in both realms of our homes,

the SMART METER…

Happy hunting!