Multiple attempts required to delete recordings

Suddenly, it takes at least two tries to delete recordings… even when there are only two of them. I “select all,” hit delete, and nothing happens, forcing me to do it again. It was already bad enough that “select all” deleted only the videos whose thumbnails were visible on the screen, rather than all of them. The new malfunction makes the app a true obstacle to productivity.

What’s the fix?


This might be an iOS only issue. I just tried to replicate it on Android and it’s working for me as expected. I opened an individual event from 14 days ago, selected the trashcan icon and it deleted it on the first try. I tried a few more times. All deleted on the first attempt.

I then loaded all events from the 3 cameras I had selected and clicked the edit icon and told it to select all. It selected all 20 events loaded into the memory and I told it to delete them, and it deleted them. Then I tried again, same thing. Then I decided to try scrolling all the way to midnight to load ALL events into the phone memory and see if I could select more than 20 at a time. After I reached midnight, I clicked edit and select all and it selected around 150 events. I told it to delete and it deleted every single video for that entire day from all 3 cameras.

I think we need someone who uses iOS to see if they can replicate this instead because it’s working for me as expected.

One thing you can try doing is deleting the cache from the app. Go to account tab then app settings and delete the cache. Then restart your phone. See if that fixes it.

This behavior began on both my iPhone and iPad at the same time, so it’s not device-specific.

Carver said iOS specific - not device specific. However with that said, I just tried it on my @#$%^& iPhone and both individual events and groups of events deleted just fine.

Part two to this is why bother deleting events? They Auto-Delete after 14 days anyway.

I think the user was indicating that since it was happening on 2 devices, they don’t think that clearing the cache and restarting the phone like I suggested at the end would do anything since those are usually good resolutions when it is a single device acting up, but they have it on more than one.

Thanks for checking your iPhone. I think this means it’s not likely a widespread issue at least. On the downside it makes it harder to replicate and figure out what the cause is or how to fix it.

Agreed. I did have one person explain that they like doing this because then they still get the AI detection benefits, but they delete them so that the videos can’t ever be subpoenaed or taken with a warrant without their knowledge. The only way to get video from him directly, not in secret behind his back. That actually makes some sense if you’re concerned about that sort of thing, though, personally I’d just switch to a local PoE camera that supports RTSP so you could do your own detections and store video on an encrypted drive.

Wyze constantly reminds everyone about the cost of storing and processing videos. I delete all of mine regularly to reduce the amount of storage used, even though from a Wyze perspective it is probably meaningless.


Clearing the cache is great… if you’re accessing the video information through Safari. There’s no way to clear the cache of the Wyze app individually.

However, suggesting that it’s an iOS glitch – when it hasn’t exhibited this performance for years in the past – also suggests that it’s Wyze’s responsibility to fix it.

I’m going to try removing and reinstalling the app to see whether that makes any difference, since removing an app will, according to several sites, clear its cache.

This is my battle, too. This occurred immediately after the last updates. Aggravating, and if no benefit that I see. And cache is empty. And, again I delete also because of Wyze’s repeated concern of storing so much data. Iphone user.

It does seem like it would be in Wyze’s financial interests to allow people an easy way to delete all videos for a whole day or large groups of them, etc. One user won’t make any impact, but if lots of people did this, it might keep their costs down a tiny bit.

1 Like

I’ve been experiencing the same problem on my iPhone since the last update,

Taking a close look at the app EVENTS screen, there are two images displayed, one behind the other and slightly offset, like a shadow, as if two instances of the page are running at the same time.

It’s possibly the reason it takes two attempts to delete multiple events.

That’s exactly how it was until this latest update.

1 Like

Same but I’m also having other issues. Are you?

Most times I cannot download an event.
When I delete an event it doesn’t disappear until I refresh.
If it does delete it takes me back to the newest video and I have to scroll down to where I left off.

It driving me crazy :frowning:

Yup. It’s super frustrating. Each morning I go through the night before. Between the 4 cameras I can have upper-100s of events. I’ll view, then go to select all and delete, I’ll get the question asking if I want to delete all…say, 182? Yes. And then maybe a third are gone. Then select all, ask if I want to delete, say, 62? Yes. Then again, down to 20. So annoying. Most assuredly this started with the last updates.

Wyze is not wise about at least three things: letting customers know that they’ve over-promised, are incapable of addressing existing problems (while focusing on introducing new products), and don’t have a Plan B for, well… anything.

It’s AI is embarrassingly poor. It can’t tell the shadow of a swaying tree from a vehicle, thinks a lighting change is “motion,” and doesn’t offer a category for animals – like crows or squirrels – that aren’t pets. Of course, it thinks that those are vehicles, too, so…

The inability to delete everything in one attempt is just another example of ineptitude. Yet that action is essential when cameras record 100+ videos of moving leaf shadows on any given windy day (and, yes, those show up as Vehicle, as well).

After the most recent update, the deletion function got worse. Sadly, Wyze didn’t seem to (or doesn’t want to) notice and hasn’t implemented a fix.

The lesson is a timeless one: nothing ruins a good price like bad service.

1 Like

@Whyz @blueroadrider @3qf74b99 @kathlene2 Thanks for noticing this issue. Could I get some applogs right after this issue happens again on your end? Also, is there any specific camera model that doing this or basically happened on each camera you have.

1 Like

I can only tell you that it occurred on IOS and latest WYZE app update. If, in IOS, you swipe down to refresh the UI, it resolves the fact they were truly deleted on the first delete.
If you check my posts, you’ll see I posted an observation I had about this back a while ago. It still experiences the deletion problem/UI refresh as of today. No changes and I’m on latest IOS 17.3.1.
Update: I now believe it’s related to a combination of IOS and maybe a recent WYZE software update. So, In this thread it’s suggested it’s a WYZE issue and can be fixed in their next release.

You could probably get applogs… if you explained how to create them.

The behavior occurs on all four of my Wyze Cam v3s running firmware version on both and iPhone and iPad running iOS 17.3.1. The version of the Wyze app is (I think) 2.49.2 (2).

If the problem is related to the latest version of iOS, it’s Wyze’s obligation to work with Apple to sort out the issue. Apple’s not going to change its operating system, affecting millions and millions of users, to accommodate the fraction of those users who use Wyze devices.

Yes. How do I get you logs? This occurs on a V2 and three V3s.

1 Like