More broken Wyze stuff

Wyze switch stopped working according to rules. Pretty simple, turn off the switch after it’s been on for 2 hours. Worked for 6 months, now it doesn’t.

Anyone have a good guess as to why it stopped working? NOTHING has changed.

I have a rule like that that shuts off an original Wyze plug (manual ON auto OFF after 30-sec). Just tried it, still works, fwiw.

Rules for me have been reliable for a couple of years. Before that, I had a problem with ‘ghost rules’ - deleted rules that would still run.

That was a back-end fix, in the end.

Does the Rule show as having executed in the Rule History?

If so, fault may be with switch. If not, fault likely with rule?

The best first question is really, ‘What have you tried so far’ :slight_smile:

1 Like

Hello I am Glad you took a screen shot of Your screen and like some of the other people here asked what have you tried so far the more information you can give us the better understanding we may have of your problem. Now this is what I have found out the most common problem alot of people make when buying the Wyze Plug. the first thing that people need to consider is what are you going to use it on like coffee maker/small fan etc… second thing is voltage specification and how many amps it draws… 3rd location now I did notice on your screenshot It said (Master Exhaust Fan) would that be for like a attic fan and if not could you please post the specification of the fan and if it has a start run capacitor mounted on it. thanks will be back here to check post to help more

Hey Robert, welcome to the Forum.

This is an interesting Topic, imo, because it may highlight whether one can profitably mix experts and non-experts to troubleshoot something.

Destro’s profile suggests he is an expert, so he has probably tried things.

But maybe not. Maybe he’s fed up with this broken stuff, refuses to do more, and is just venting.

I’m a non-expert with more than average experience with a limited set of Wyze devices (cams v2 and v3, bulbs and plugs, cam plus lite, mostly.)

I may be of some use but may be not. You? :slight_smile:

Just ran across this:

I too have encountered this, and have escalated via volunteer support channels.

1 Like

hello peepeep
yes I used to do the forum thing years ago and try to help and this is the first forum I have been on in 12 years. yea i was purchasing Wyze product along time ago my first camera was Wyze Cam v2 with Wyze Sense and still got works perfect. Yea I quit the forum thing because it didnt matter where you went there was always someone REAL RUDE and Im not saying anyone here is. I just like to help people with there electronic issues. but I better jump off this persons thread because this is probably not the place to chat I was looking around to get the feel of things. Is there a lounge here on this forum thanks

Is there a lounge here on this forum

Check out Topics in the Watercooler category:

https://forums.wyze.com/c/watercooler/54

Captured on Wyze is fun and social, too:

https://forums.wyze.com/c/captured-on-wyze/55

It’s a pretty good lot here, overall, some of the more active volunteers even prefer it to other platforms for the strong, free and civil discussions that often develop. :slight_smile:

2 Likes

I’m also having this same problem. I have a bathroom fan contolled by a Wyze switch that is programmed to shut off after it has been on for 5 minutes. History shows the last time it worked was May 9th at 7:47 AM. I have two other Wyze switches and I tried the same rule on one of them and had the same result. This seems to be a Wyze server issue.

1 Like

I have escalated this issue and the Wyze team is looking into it.

3 Likes

I’ve responded on a parallel thread: I created a workaround using a spare wyze plug (not sure if it’s v1 or later), but the short of it is that the device trigger rules involving “X has been on for Y minutes” is not working with the wyze (in-wall) switches. It is working with the wyze plug. There are two possible issues: the trigger rules for the wyze switch has been deprecated (not working since May 9th) in a firmware or app update OR it’s possible that wyze has nixed device trigger rules in which a device triggers its own action–there’s a popup warning when I edited and tried to save the old rules for “X has has been on for Y minutes; turn off X”. Hopefully the devs will find a solution.

2 Likes

Seems like device trigger for same device was turned off , is there a ticket we can all follow ? Was gonna check Reddit… But we know how that goes

While we wait for WYZE to address the issue I was able to come up with another workaround if you happen to have IFTTT.

If WYZE switch turns on, delay for x amount of time, turn WYZE switch off.

Seems to be working well for the 3 switches I have setup on timers.

Indeed. You should also be able to do this with Alexa Routines. If you have use Alexa.

It does not appear as if Google Home is quite there yet, unless I am missing something.

I’ve tried this same rule on a Wyze plug and it works perfectly so it doesn’t seem that the rule has been eliminated because it’s the same device. It just doesn’t work on the Wyze Switch.

I believe this is correct. If I create a household routine in Google Home, I can select a switch turns on as a Starter, but I can’t then select that same device in the same routine as an Action, because it’s greyed out. It appears that Google Home does not allow self-referential routines of this type…

…except that it does: I don’t have a Wyze Switch, but I used a Plug Outdoor as a stand-in for testing and set up a Google Home household routine this way:

  1. Add starter > When a device does something > [selected my plug outlet here] > Turns on or off > Turns on > Add starter
  2. Add action > Try adding your own > Turn off [my selected plug outlet] in 1 minute. > Done

When I went to save the routine, Google Home prompted me to select a device under Configuration, so I selected Don’t play media, because I don’t need to hear anything with this one. I think having a media device selected is a standard requirement when you “Try adding your own” actions.

The first time I tested the routine, it failed. Google Assistant (on my phone) gave me this message: “Sorry, because of potential risk to safety, I can’t schedule actions for devices configured as outlets.” :-1:

Then I went into the device’s settings in Google Home and selected its Device type as Switch (Outlet) and tried again. Fail: “Sorry, because of potential risk to safety, I can’t schedule actions for devices configured as switches.” :-1:

Then I went into the device’s settings in Google Home and selected its Device type as Fan (Outlet) and tried again. Success! :+1:

So it’s possible, but there are some caveats and hoops to jump through in order to get it to work. I think the simplest and most straightforward work-around I’ve seen so far is what @hanserikn suggested in another topic:

That has the added advantage of staying within the Wyze ecosystem.

1 Like

I have no official word, but my switch rules started working again this evening.

Wondering if anyone else’s are working.

2 Likes

Yes, switch rule working again.

2 Likes