Issue with a simply Wyze plug rule

I created a rule for when my wyze plug “Has been on for 2 hours” then turn the plug off. I first tried it with 5 seconds and each test worked fine. So I then set it to 2 hours, but found it had never turned off. Thus, I repeated the 5 sec test and each time it worked fine. I bumped it up to a 10 min test and each test also worked fine. When I went to an hour, it again failed to turn off.

This is such a simply definition. I’m really at a loss for why this would be happening. This is my first Wyze device in my house and I assume the rules run in the cloud; i.e. I assume it has nothing to do with my phone or the app once the rule is defined and the device is turned on.

Any advise would be appreciated.

Not sure which plug you have version 1 or 2, assuming the v2 if you recently just got it. But the V2 is model WLPP1CFH-1.

Yes the rules are ran in the cloud, and it does sound like a simple rule.

If you look in rules history do see a failed notification on the 2 hour rule? It can give a little insight to a failed rule

The history can be found under account>rules>history

Will look something like this.

Also, check to make sure the plug has the latest Firmware installed.

To check your firmware version, and update:

  1. In the Wyze app, tap on your device.
  2. Tap on the Settings gear, then Device Info> Firmware Version.

You can also check your firmware version from the Home tab by tapping Account > Firmware Update.


In addition to R.Good’s reply, try adding 1 second to your 2-hour turn off rule and see if it works. That will tell us if you’ve discovered a bug.

You may also wish to post a screenshot of your 2-hour rule. We may be able to see something you missed. Here’s an example of one of my auto-turn off rules. This one is set to turn plug off after on for 1 hour 31 mins 1 sec:

I’ll modify it to turn off after 2-hours to try to recreate your issue.

Edit: Rule updated and running for 2 hours. Will monitor. I previously had this plug rule set to 1 hour and it worked well so I’m confident that 2 hours will succeed. But this plug is a 2021 model and yours may be different. If you can determine your plug model and report, one of us can test your scenario to your model of plug.


I was just creating one myself to see if it failed as well :wink:

Here it is


I’ll create a 2-hour rule for a gen 1 / original old Wyze Plug and run that too. :+1: I may fall asleep before the test ends. :grin:


Same :sleeping: Mine is on a Gen1.


Running two 2-hour tests:

Gen 1 Plug:

Gen 2 Plug 2021:


The back of the plug says Model WLPP1CFH, Version 2022. The app reports the firmware is Up to Date. The history showed no entry for the 2 hours; (it did have entries for the 5 sec, 1 minute, & 10 minute tests.

When I set up the 2 hour rule, it was for 02:01:05; i.e. I did have some minutes and seconds on it (from my prior tests).

Thanks for the quick responses.


Argh… I don’t have a 2022 model to test. :pensive: Perhaps another @Mavens can help out with this if my other two models don’t fail their tests in a half hour. Your rule looks great and should work unless you’ve hit a bug. Also, make sure you have no other timer-based trigger rules enabled that specify the same plug.

The 2-hour rule tests that I created ran successfully for both the Plug v1 and Plug 2021:

Hoping a Maven with a 2022 Plug can chime in here.

I have a 2022 that I can test it on… But won’t be able to set it up and test until tomorrow night. Will do that if no one else posts in first.


Thank you very much! If you do run a test and it fails, please send log and post Log ID. :+1:

1 Like

Ran the rule last night… Successfully.

1 Like

Thank you! :+1: I’m going to have to think about this for a while… :thinking:

1 Like

Just to add clarity… Same firmware, but I am on Beta App.

1 Like

Dropping a thought, when you “turn on” the plug, are you doing it through the app, or removing then replugging in the plug?

1 Like

Mine failed with the V1 can test a V2 later

Log ID 1045191

Didn’t even register in the history


I’ve successfully tested 01:01:05 twice last night and twice this morning. I have now started a 02:00:05 test this morning.

When testing, I turn on the plug either from the app or from the button on the side of the plug. (I do not disconnect/reconnect it from the outlet.)

Each of the times that it has failed to turn off, it did not log an error in the Rule History. For the first failure, I had turned on the plug just before I called it a night; (around 11pm). In the morning I found it still on. Thus, I did some short 5 second & 10 minute tests with success. I then did a 1 hour test (01:00:05) which 90 minutes later I found it was still on; (around 9am). While I know this will sound strange, my recollection is that either when I picked up and unlocked my phone -or- when I reopened the Wyze app, at that moment the plug turned off. (i.e. that is why I had to confirm that Rules do indeed run in the Cloud) [I’m sorry now that I didn’t take better note of it. I’m also disappointed that Wyze does not keep a historic log of the on/off time for the plug.]

I’ll keep testing and let you know my results.

NOTE: I’ve been using Wyze for about a year at my mother’s house where I have cams and plugs. This is the first plug that I’ve installed in my own house. All devices are in the same account/app. (Not that I expect this fact to make any difference, but thought I should mention it.)

BTW, if I were hearing someone report this, I’d be questioning operator error. I know it’s hard for me to assure you otherwise, but I do have extensive experience in software engineering and have worked with apps such as SmartThings, Aqara, IFTTT, etc. I will also acknowledge that anyone can make a mistake; but I really question how I could simply change the time from 5 secs to 1 or 2 hours and see such issues - and to have this occur more than once seems odd.


After the four successful tests at 1 hour, I updated it to 2 hours and it failed; i.e. the plug is still on and the Rule History has no entry for it. (Note that after turning it on, I put my phone down and didn’t touch it until now.)

I guess I’ll try turning it off and on and see what happens this time.

1 Like

After the 2 hour test failure this morning, I tried two more 2 hour tests.

For the first test, I turned off the plug by pressing the physical button on the device; waited 2 minutes; then turned it on using the physical button. After 3 hours, the device still had not turned off - and there were no entries in the Rule History. (During this test I continued to use my phone for other things.)

For the second test, I used the app to turn off the plug; waited over 2 minutes; then used the app to turn on the plug. After 2.5 hours, the device still has not turned off - and again there are no new entries in the Rule History. (During this test I continued to use my phone.)

At this point I’m at a loss as to where to proceed next. I guess I may try a 01:30:05 test and a 01:59:05 test.

R.Good: It’s nice to see someone else reproduce the issue!

Q: What are my odds of getting Wyze tech support to take a serious look at this issue?