Turn off rules no longer working

I’ve got a number of rules to turn off switches after they’ve been on for a set amount of time. All of them seem to have stopped working without changing them at all while other rules are running fine.

Looking at rules history looks like last time any of these worked was 10th at 1:09 PT.

An example attached.

2 Likes

Is this rule firing, but not successful or is it not firing at all?

@Omgitstony I believe not firing at all as not seeing in rules history view at all after 10th at 1:09am PT.

I’m noticing the same thing. The turn off rules don’t appear to be firing at all. It’s been a few days since they stopped working.

I’m having the same issue. I’ve tried other rules with the device and they work, just not this one. I tried deleting and re-adding the switch and still the same problem

Same issue, I’ve used wyze switches for my bathroom fans (cheaper and, up to now, more flexible timers). Mine stopped working on May 10th, too. No sign of any triggers in the Account → Rules → History since running on the 9th :frowning:

1 Like

Another user reporting what appears to be the same issue: More broken Wyze stuff

Same happening to me and the last time the rule activated was also on May 9th! I use 3 switches to auto off the bathroom fans and all of their rules are suddenly being ignored since the 10th. Tried every possible troubleshooting option on a switch: deleting and recreating the rule, factory resetting the switch, turning the breaker off for a minute, restarting the router, making sure the switch and app are up to date. Nothing helped.

Timer apparently works though, gonna have to go with that for now.

So I created a workaround using a spare wyze plug (not sure if it’s v1 or later), but the short of it is that the device trigger rules involving “X has been on for Y minutes” is not working with the wyze (in-wall) switches. It is working with the wyze plug. There are two possible issues: the trigger rules for the wyze switch has been deprecated (not working since May 9th) in a firmware or app update OR it’s possible that wyze has nixed device trigger rules in which a device triggers its own action–there’s a popup warning when I edited and tried to save the old rules for “X has has been on for Y minutes; turn off X”. Hopefully the devs will find a solution.

I am having the same issue since May 9th. I tested the same-device-trigger idea by editing the Rule to turn off my switch when a different device (Wyze Outdoor Plug) met a certain criteria, and the Rule still didn’t fire.

I’m having trouble with the timer function also, however I deleted the switch and tried to reinstall and it is not detected during the final Bluetooth step.
Any suggestions on the fix?

If you’re in the app and navigate to Account → Rules → History does it list the “Hot Tub Lights have been on for…” If not, it’s likely the outdoor plug is having same issue as the wall switch. I’ll run a test on my spare outdoor plug to see if I can recreate your issue.

I wasn’t able to recreate your issue FOX99019; my test using an outdoor plug X with a device trigger “X has been on for Y” worked to turn off another device (Y - wall switch). I did find a workaround for the wall switch issue, which is to create a different self-referential device trigger rule, when “X turns on, turn on X for Y minutes” instead of “X has been on for Y; turn off X”.

I’m not sure what I did differently, but I can now have rules work with different devices (when X turns on, do Y), as Hanserikn has described.

Thank you for the great workaround ideas.

When I turn on X, I have a rule that turns on Y. I have a 2nd rule that turns off X when Y had been on for a certain amount of time. This replaces the ‘When X has been on for a certain time, turn X off’.

Still waiting for a fix…

@hanserikn nice find on the workaround. Looks to be working for me for now but hoping Wyze fixes the issue with “on for x” trigger.

Been trying to work with support on this… Today they stated:

So support doesn’t work with engineering to make sure real bugs are addressed?

Support forwards collected information, claims, reports, app log information and sends them to the engineers and developers for investigation. Unfortunately this is a one way street as the Devs/Engs don’t report back or communicate further with the user. If there is an issue found with the info sent to them, things that could be done is updating the known issues page, have Jason make a call out for more logs to help get to the root of the issue, post in fix it Friday, and work on a fix or update to the app/firmware/cloud etc.

From a related topic:

Hopefully this’ll be addressed for y’all soon. At least you didn’t say that Wyze Support told you they’re “working on developing a process so that we can track these logs”. Hopefully they’ve stopped telling customers that.

1 Like

Oh no they are still sending that message.

1 Like

:roll_eyes:

1 Like