I apologize but I cannot figure out how to ask a question so if someone could guid me it would be most appreciated.

I have been using Macrodroid for a while and it was working well for different notifications for each different camera but recently it has stopped working on some of the cameras. My Pan 2, V3 and WOC seem to work for the most part with forwarding a notification as they should. I have issues with a Floodlight Cam and my other V3. They record like they should on the Wyze app buy give no notification thru Macrodroid. They use to but have now stopped. Any help would be greatly appreciated.

Check if the notifications settings are still set right in the app for those cams, and also try toggling it off and back on.

I use MacroDroid exclusively for all my cams.

I experienced a loss in macro performance the last time I got an app update from MacroDroid but it corrected once I opened the MacroDroid app so it started monitoring for notifications and confirmed all my Macros.

Note: if you are running the Wyze Beta App, you will likely have some issues as the Beta App is a different app name operating on the same notification channels.

You can check the System Log in MacroDroid to make sure that there was a successful macro execution. Notifications received will be in Red, Macros Executed in bold green, Actions in blue, errors in purple.

If you are getting the notification to the phone from Wyze but MacroDroid isn’t executing, then there may be an issue with your MacroDroid Settings conflicting with Battery Optimization or a Sleep\DND setting on the phone.

If you aren’t getting the notification from Wyze in your Notification history, then it is something in the Wyze ecosystem.


Thanks for your input. I have got most of them working. By that I mean reporting via Macrodroid. Still Having and issue with the V3 with floodlight and a plain V3. They show up triggering on the Wyze app but don’t trip the trigger on the Macrodroid macro. My Pan 2, V2, WOC and one V3 are all reporting on both Wyze and Macrodroid. Not sure why the others will only report via the Wyze app.

I have checked and re checked and as reported below most are working while a couple of them have their own mind. Thanks for the help.

I am not really sure how you have your MacroDroid Macros built to act on Wyze Cam Events. It is highly configurable, so the build if your macro may be the issue… Or it may not be.

For my macros, based on your quote above, there is one critical component missing between the Wyze Cam Event “triggering” in the Wyze App (logging an Event Video in the Events tab) and the Macro executing in MacroDroid:

My macros depend on the notification being sent from the Wyze Server to my phone as their trigger. I have MacroDroid monitoring the WyzeMessage Notification Channel and executing actions based on matching specified text within that notification for each cam and type of AI tag. If the Event Records in the Events tab, but no notification is sent, MacroDroid can’t do anything about it because the notification never arrived.

In my case, the Events tab is only the begining of the process. I also have to check my notifications history to make sure the notification was received. I have another macro that writes every notification received to a log file so I have a historical record of all notifications.

If you are getting the notification for these events, check your trigger specifications, action expressions, or constraints in MacroDroid.

If you aren’t getting the notifications, check your Notification Settings in the Wyze App.

Not sure if this is going to work but here goes. I have built 10 marcos off of this format and they all worked fine for several months until a week or so ago and then some of them stopped. They all trigger fine in the Wyze app but some do not make it to trigger on MacroDroid. When I test them thru the Macrodroid app they do what they are suppose to do. When checking the log they show they work like the ones that are still working thru the app except it says it is a test. It is frustrating but I am not ready to give up. Thanks for putting up with me.

Macrodroid Wyze.pdf (249.1 KB)

Took a look at your macro template.

Yours are essentially the same as mine. A couple issues stood out:

  1. You are running the Wyze Beta App. If you programmed your macros on the public release app, then switched to the beta, or vice versa, the MacroDroid app will have issues because these are two different programs with two different names. I have switched back and forth and experience issues because it is pushing notifications on the same channel but from a different app. Every time I switch apps, I have to reprogram all my macros to the new program name.

  2. You have the text area of the notification dialog circled, so I am assuming that because you have “contains” selected you do actually have that filled in with text to match on your macros. Leaving it blank might return a null match.

  3. As I have indicated in all of my previous replies, if your phone isn’t getting the notification, none of your macro settings matter. When you say:

I am reading this as “The cam Records an Event Video in the Events Tab”.

That does not confirm that the Wyze Server actually sent a notification for that event or that your phone received it. Neither of these functions can be confirmed by the app. Only your phone’s Notification History can confirm if a notification was actually received.

OK, finally. I guess I just didn’t go far enough. I did a total reset on the cameras. Deleted two of them and then reset the router again. Re-installed the two and now they seem to be working again. Thanks again for all of your help. I didn’t think that since some of them were working that I would need to go that far but hey it is not the first time I was wrong. It was your statement about the phone not receiving the trigger from the Wyze server, it was being blocked by something in the camera itself. When I checked the phone notification I saw it was not getting the signal. Good call. Still not sure what caused the issue. This was the first time I have had something like this. Have a good rest of your day and thanks for hanging in there.

The same statement I mentioned in all three of my posts above? :point_up:

Also, the notifications don’t work this way:

The cams have nothing to do with notifications. The video footage is being sent to the Wyze Server when activated on motion. Depending on your App Settings on your account, the Wyze Server then sends notifications to your phone. All your cam does is shoot the video.

The problem was that the cam notification settings in the app were not correct or were not pushing thru to the server. Since you were still getting events, the notification settings were the issue. A reinstall wasn’t necessary for this. Unassign CP, cache clear, logout, reassign would have fixed it.

There are two places to check the notification. Your second one below said check the Notification in the wyze app which is what I did. I did not think about the phone notification itself. Two different places and the phone notification took some digging to find. I did clear the cache and logout. Not sure what you mean by reassign. What is CP? I have one left to do and it will require a ladder. It you think it world work this other way I will give it a shot. Please explain what CP means and what you mean by unassigned and reassign. I may have already done this but I am not real familiar with some of the terms you use.

The only place to check your notification history is in your phone. There is no notification history or notification log in the Wyze app.

CamPlus subscription. There are times when the CamPlus notifications fail to send. The unassign\reassign usually gets them going again because it updates the server and relinks the cam to the subscription. This is for AI tag notifications.

If you don’t have CamPlus subscription on the cam then it is a moot point.

Try this on the last cam that has yet to reset:

  • Toggle off Motion Detection and Smart AI in Event Recording.
  • Toggle off all Notifications settings.
  • Clear the app cache in Account → App Settings
  • Sign Out in Account
  • Close App
  • Force Close App from the OS
  • Open App and Sign in
  • Return all settings toggles back to where they were, especially the notifications.
  • Close the app, test with motion, and check if notifications are delivered to the phone.

I appreciate your advice on all of my issues. I do have Cam Plus. I followed your latest instructions and all is well.The last camera is now working fine and sending alerts to trigger MarcoDroid. I am learning and keeping notes. Thanks again.

1 Like

Glad all is working! Macrodroid has been spot on rock solid for me. I currently have 35 macros running with more added regularly. It is a good watchdog app to have because it is a good indicator of when the base app (Wyze) isn’t behaving properly. It is also great to write full activity logs on everything that happens on your phone.