Livestream Issue

Device and app info:

Camera 1 (Kitchen): WyzeCam v2, FW

Camera 2 (Basement): WyzeCam v1, FW

Camera 3 (Backyard): WyzeCam v1, FW

App: 1.3.104 beta version for iOS on iPhone 7 Plus


I received my v2 WyzeCam yesterday and set it up this morning. Setup was flawless and took only minutes. Configured all options as I like them - no issues.

Now when I view the livestream on any of the 3 WyzeCams, the playback is stuttering. It is only refreshing every 2-3 seconds, and sometimes longer. I am watching the timestamp and seeing it update sporadically. This makes the video very choppy and unwatchable.

As of yesterday, before adding the v2 and upgrading the app and all firmware to the latest betas, everything was fine.

I have not done any troubleshooting yet - I will when I get back home. Any thoughts?

I think I’m seeing similar issues with my V1 with a V2 running. When I get home I’ll try unplugging V2 and see if the streaming issue goes away.

I first set up my V2 next to one of my V1 and things seemed ok. Later I moved it to another room next to a different V1. In the second location it took a long time to connect. Now I’m noticing streaming stopping a lot from the V1. Playback from the V1 is even worse.

I have the same issue and the v2 is using the latest FW release. v1 is fine.


When I am on the wifi at my office, I have the poor video described here. Time showing every 2-3 seconds, etc. When I leave and am on LTE or my home wifi, everything is good.

I’m having the same issue even when on LTE. It seems to help the issue when switching to LTE but still skips 5 to 10 seconds.

I have 3 cameras all on the firmware.



Wyze Cam v2 – Firmware – Software 1.3.107

Image still stutters on moving object (car in motion).

Image latency is now present.

These problems do not occur with v1 – Firmware

Greetings everyone. I just received my camera yesterday and am having similar issues with my live feed. Doesn’t matter whether in HD or SD mode. Motion tagging and time stamp is off. No SD card yet. Since I’m a noob, maybe I’m doing something wrong? Thanks!

I’m experiencing the same issue. I have set my cameras on a 2.4 GHz guest network and experience it while connect to that network and my main network.

Seems to be fixed with cam FW v

Sadly, the fw update didn’t help me. :frowning:

Mostly works seamless on wifi…70-101 Kb/s and higher. Seems that it is intermittent on LTE. I notice that my kb/s jumps from 14-38 Kb/s on LTE, but sometimes it’s 70-90 Kb/s. When it is higher, I get seamless stream video and audio. When it’s at the lower 14-38 Kb/s rate, 2-3 choppy video stream and no audio. Tried turning off all motion detection, audio, select SD…etc…to no avail. Updated with latest Beta and firmware. Very frustrating as to what the cause is.

Aghhh!!! I used to love my wyzcams. V1’s worked fine. Never had the choppy, laggy video until I installed my V-2’s. Video is great while connected to same network(wifi at home). But any cellular connection produces lag. Video only updates every 2-3 seconds. I’ll do a cellular speed test right before loading up a cam and get 60 mb/s and still have choppy video. Even weirder, I’ll load up a cam, get a choppy video, push the back arrow and load it up again and it’ll be nice and smooth, SOMETIMES. Sometimes I’ll have to load it up 4 times to get a smooth connection.

On iOS iphone. Sd or Hd does not make a difference. Using V2’s with and V1’s with

I’ve deleted re-installed the app, I’ve used the Alpha test app version and deleted/re-installed all cams. Nothing fixes it.

Night vision doesn’t make a difference. I currently have 4 v2’s set up and one V1. All suffer this lag. V1 lags 3 secs and V2’s lag 2 seconds.

Please help so I can go back to LOVING THESE CAMS!

Same here!! Did unplugging the V2 help?

I thought this issue went away but it is still here. Most notably when I am on another WiFi.

v1 has no issues but V273 is choppy every 2~3 seconds.

Hi everyone! I just spoke with the Dev team about this issue. It is something we are investigating still but to offer a bit of an explanation as to what we believe is going on: we currently believe that only the primary frame is being viewed, and the rest are being discarded. We have been having trouble repoing this in the office to test fixes, but they have made some changes to how these images are processed from the buffer. V1 units should see this in the next firmware update, and V2 soon after.

I will be attempting to recreate this myself as well to try to gather more data and provide a more complete fix. I will try to keep this thread up to date as I get more information!

This is great news! Thanks for helping


Just updated to latest iOS beta and running latest FW on all cameras. Still seeing this issue on the v1 cameras. Video is very laggy/choppy and the time only updates every 3-4 seconds. Seems to only be on some WiFi connections, but good on LTE. I hope this wasn’t listed as a fixed issue for this beta version… Thanks.

Wyze Cam v2 — Firmware — Software 1.3.113; Android 6.0.1.

I have similar issue but with v2 camera. Live stream video is choppy on moving object (person walking, car in motion). Time stamp stops and then updates a few seconds later. The time stamp is approximately 5 seconds behind real time. Camera intermittently disconnects, so app must be restarted to reconnect to camera. Camera is set to Standard Def with motion tagging off.

Playback of video is smooth and choppy image is not present.

I just noticed tonight while on night mode if I zoom into an item, I get chunking. Like pixelation but in large chunks. That was in near total darkness. My other camera in an area dark enough to turn on night mode but not so dark that I can’t see if not chunking when I zoom in tight to an object. I’ve tested this on the Samsung S8+ and S9+. I also installed tiny can pro and texted it in that app as well.