Leak Sensor not working with replacement CR2450 lithium battery

My Wyze Sense Leak Sensor is not working when I insert a new CR2450 lithium battery. The new battery measures 3.13 volts, while the old battery measures 3.09 volts. I switched the batteries several times. Each time I insert the old battery, the leak sensor detects a leak when I put it in a container of about 1/4 inch of water. When I remove it and dry it, it clears the leak. Each time I insert the new CR2450 battery, the leak sensor does NOT detect a leak when I put it in the same container of water.

Any recommendations on how to get the leak sensor to work with a new CR2450 lithium battery?

Have you tried to do a Factory Reset on the sensor and reinstall it while the new battery is in place? Don’t delete it from the app, just a new Setup after the Factory Reset.

Factory Reset on the device is holding in the setup button for 10s until the device cycles.

Thank you for your response. After further research, I determined that the replacement CR2450 lithium batteries were at fault, even thought the measured voltage was over 3 volts. When I tried another set of new and fresh batteries, the Wyze Leak Sensors worked fine.