Latest thermostat firmware disconnecting wifi

Firmware 1.2.4a2 for the Wyze thermostat stinks. Do not update. WiFi keeps going offline.

My device keeps going offline over and over. It stays up for a while then boom offline. Only way to get it back is it unplug it from wall. Rebooted router no other changes or issues in the home. I saw there is a post on Reddit with people having same issues. Wyze please push old firmware back. We also need a reboot option on the device. I see a reset all option but not a reboot option.

Update: tried to do a factory reset for the device. Now the unit is bricked. Stuck on Wyze logo. Deleted my cache deleted device on app. Son of a gun. What a piece of junk.

Yes the same thing happened to me with this New Update.

I had enough with this product. For 2 years thing was never stable. Ecobee 3 lite on order.

They rolled firemware back to 1.2.1.


1 Like

Will try the update. Looks like that is only for people that upgraded to 1.2.4a2

I did the same and now it’s bricked. Can’t remove from App and can’t re-add after a reset. Totally stuck and no help from Wyze Support. They said to submit a log from the app and I asked if anyone would look at it and reach back out, The answer is no. So I contacted support and gave them the log # and they said the same thing. So, apparently no way to get it working again. Worked great for 2 years and firmware 1.2.4a broke it.

1 Like

Same results but its now 6 months since the original post. The Wyze thermostat initially connected to my WIFI and the heat came on and it said all was well. A couple minutes later it started making a clicking sound and the screen would change from saying 63, then heating to 66, then the Wyze logo in an endless loop. Using the app and navigating around it eventually said it wasn’t connected to the WIFI. I tried deleting thermostat from the app and reinstalling it several times. I rebooted the WIFI but it never again reconnected.
For all of you who think that buying some other thermostat like a Google Nest will lead to a better result, its a big MAYBE. Prior to buying this Wyze tstat I tried a Google Nest. I hit similar issues there. After much griping about a c-wire and trying a Google Power Connector with my 2-lead (R,W) tstat wire, I replaced my 2-wire system with a 3 wire (R,W,C) But it too disconnected from the WIFI and never functioned and just gave out error codes despite correct voltages and strong wifi signal. By the time I’d been through all that, I was out of the return period and stuck with the device (now being sold on ebay at a $50 loss).
My WIFI router is a TP-Link Ax 3000. It works with all other devices (phones, computers, roku) with no problems. But thermostats don’t stay connected to it. Perhaps there is configuration required within the router so thermostats don’t disconnect but I didn’t find anything on searches.

My advice to all: Carefully open the packaging without removing protective plastic covers, or ripping the cardboard. If you start hitting errors and unreliable behavior, return it and decide if you have the patience to go through this again with another brand. It’s not worth burst pipes when these things go down.