Updated thermostat, now keeps shutting a/c off and on every couple minutes

Help! While my thermostat is almost always offline, won’t connect to my wifi unless I power cycle it, I did tonight to be able to switch back from heat to a/c. When I did I found that there was a firmware update available. I did the update, and now the thermostat will not run the a/c for more than a few minutes at a time, it shuts off, before getting anywhere near the set temp, then turns the system on again, sometimes not even a minute later. This is extremely bad for the a/c compressor! It has never done this before. I guess I’m going to be replacing this piece of garbage tomorrow, finally. I’ve been spent a year without it working properly on the wifi, and now this.


Woke up this morning, checked the thermostat, it’s already offline like always. The firmware update did nothing to fix the connectivity issues, again. Mind you this thermostat was connected for a year with no problems at all, until the 2nd update. Ever since then I’ve had that problem, and now since the update last night to the latest firmware, not only the same connectivity issues, but now it’s short cycling the a/c. The app was showing it as active/running, yet the system would be off. Sometimes it would be off for several minutes, a couple times it just shut off for less than 30 seconds and then turned on again. Absolutely can’t do that to an a/c compressor, and if it does that with the heat, that’s just as bad. I’m replacing it today with a different brand wifi thermostat. I don’t understand how wyze has failed so miserably at something that’s really simple. Hundreds of people have the same issues, yet they completely ignore them.

Fixed it! Replaced the junk WYZE thermostat with a Honeywell and threw the WYZE in the trash!

Ha ha I posted same thing last week. Firmware is bad, they rolled it back to 1.2.1 from 1.2.4.a2.
Major failed, I guess they dont do regression testing.

Issues:
AC heat cycling off and on in rapid succession.
Unit goes offline between 10-20 minutes. have to pull unit out of wall to fix.

resetting to factory does nothing.

That’s wild. Seems to me that they’re just clueless about how any of their products work in the real world. No longer have to putz around with their stupid thermostat now that it’s somewhere in our local landfill where it belongs. The new Honeywell immediately works better, furnace time delay for ignition and preheat is automatically right, unlike wyze that had a limit of 60 seconds, which on my old furnace wasn’t even enough time for it to light before the fan was running. Also no more freezing, then when the heat came on, burning up before it shut off, because even though it was set to a HALF degree variation, it was always 3 degrees. Most of their settings on their devices do nothing, but the user can set them and feel like they did something.

Nice improvements. I was thinking ecobee. What model did you buy from Honeywell?

Same issues here. Did a reset and now can’t even re-setup the thermostat. Worked great for almost 2 years and then this firmware update trashed it. Won’t stay connected to WiFi for more than 24 hours. Junk and support won’t help.

1 Like

I had bad connection issues when I was still using my ISP’s gateway . Once I upgrade my network to my own personal modem and router that handled more devices , had better connectivity and range . All of my issues went away

But the thermostat is one device that is very important for a home , I think what I’ll do is buy another thermostat just for safes whenever anything crazy happens to my current device . For a just in case …

Digging my old thermostat out of the basement now. Glad I saved it.

-Luke

1 Like