Latest firmware update failed x4 Cameras + sensors

V2’s & Cam Pans
Rolled out update via app to all at once.
Update failed.

Power cycled Router & Modem & all cam’s several times.
Changed Network
Retyped password.

This has happened many times before over the years but repeated attempts resolved. This time, nope.

All I observe differently, is that the Camera is fairly quick to state “Connection has timed out, please rescan QR code” and everytime this has happened the Android app has been happily trying to Connect. It takes some before the app also realises a failure

Hi @robbie and welcome to the community!

  • Unplug all the cameras, shutdown PC and power down the internet router for 10 minutes.

  • Power up only one camera and try connect. If that doesn’t work may have to manual flash the firmware.

How to FLASH manually

1 Like

Hi thanks, every device power cycled many times.
Created new guest network just for Wyze.
Flashed new firmware manually

All fails.

Why did you mention shutting the PC down this has nothing to do with the setup process?

One device just returned after trying old firmware. phew,

1 Like

I had the same problem with my v2’s. Ending up having to manually downgraded to recover the cams. There is a problem with the latest firmware update for some users, I expect they’ll pull the update soon.

In the manual flash you’re holding the setup button until the blue light came on?

Power cycle sometimes works, longer off time helps to dump any stuck connections and clear router cache. PC introduces additional variables.

I had the issue on one of my cams, so I waited and about an hour later I tried again and it worked.

1 Like

Ok happy to say that both types of Cams recovered via flashing back prior rom.

1 Like

My time zone is NZT (new zealand). I have 4 cameras down. Have tried to restore from previous firmware but keep getting timeout error after QR code is scanned.

Hi @tmarris and welcome to the community.

You may need to open a Service Request and include the time zone and log file per instructions in @WyzeGwendolyn’s post above.

In the meantime review directions below. Holding the setup button throughout the process.


Hi I am in Australian Eastern timezone.

They just posted what the problem is and how to temporarily fix it


I’ve been searching but haven’t found anything about manual flashing WCO firmware. Is it even possible? If so, does anyone have a link to the firmware? The new update is causing my WCO to stay on all the time and kill the battery, as well as not show motion alerts due to being stuck on live streaming. I’ve tried everything and nothing has resolved it so I guess I will either need to downgrade to the previous firmware if possible, or keep the camera turned off till a new firmware is released.

Hi @stevebergmann, you are correct. There is no Setup/Reset button on the WOC.
Click here for a link to the firmware

Current Version (September 9, 2020) Base (September 9, 2020) WOC

Live support is available: +1-206-339-9646
Monday - Friday 5 am - 6 pm PT
Saturday 8 am - 4 pm PT


That’s the one! That seems to be working for me. Thanks!