Issues with v1 firmware v3.9.3.62

Let’s use this thread to track v1 f/w v3.9.3.62 issues.


Changes include:

  • Fixed a networking issue which causes camera stuck at flashing yellow/blue state


Suggested test areas:

  • Anything connection related
  • Network failure case (router power off, no internet connection, WiFi password change)


Known issues:

  • Some customers experiencing choppy video streaming when viewing from LTE (same behavior as f/w v3.9.3.56)


Update (4/26): Released to public!


A general firmware issue/request: many of us are amassing a collection of these wonderful devices on our home networks. When a new firmware release comes out, it appears that each of them downloads the big-ole file independently. It would be great if the first device on the network that downloaded it made it available to the others - or that you multicast to each device, or something to make the process faster all around.

Just a thought… Keep up the awesome!


BTW - the reCAPTCHA that makes me choose what tile(s) the toaster oven, rocket ship or bridge is in before posting is R E A L L Y annoying :wink:

Sean, the forum chief is working on making the Captcha not required for users after X successful posts or some similar method to recognize returning authenticated users.

I don’t normally get captcha that requires clicking all the tiles. Normally just a checkbox that says “I am not a robot”. I have gotten the choose the tile, and I agree that is a pain. But for me it is infrequent, maybe 3 times, and I currently have 122 posts, and edits that don’t count toward that.

Are you by any chance using a VPN proxy (like Private Internet Access)? I often get the tile captcha when I do.

I am in the same privilege as you. We are not using VPN so I don’t know if the behavior is different. I will forward to our website owner. Thanks!

Sorry, my response was meant for Sean, to see if he was using a VPN provider to “hide his IP address”. The issue with these VPN services that provide a layer of anonymity, is that spammers also use them too, so the IP’s in the provider’s pool are likely to get added to “suspicious traffic seen from this IP address” lists. Then Google (I assume that’s who’s providing the captcha checking) notices that and makes you go through several pages of click all the tiles that have a car, or store front, or steet sign, or bus, etc. It takes several minutes to get through. They do it to thwart “bots” and to waste spammer’s time. But some times there are false positives; unless our cameras are being used to send spam :slight_smile:

Soon after posting that, I got tile captcha’d twice. Now a third when posting this! And I am not using an IP hiding VPN.

General comment regarding the firmware upgrade process.

For me (and I think many people in general) upgrading “firmware” is a slightly scary process. Done right and we all breath a sigh of relief and relish in our newfound technical prowess… on the other hand if something goes wrong… horror show. Bricked devices, frustration, drama.

With that as background, here’s my suggestion, as the firmware is “updating” have the progress bar reflect the ACTUAL portion of the process completed… what I mean is without fail (over eight devices) as my cameras update, they get to 58, 59, maybe 60 or 61% and then BOOM done…

The progress bar does not ever go beyond that. (Making me wonder if it DID update properly or not?)

The cameras DO seem to be updating but the failure to hit 100% is disconcerting.

It would be much more reassuring to see the little green progress bar trudge all the way up to 100% and THEN say “Your firmware is up to date!”

Just my two cents.


iOS 11.3, iPhone 7Plus

There is some super secret algorithm that determines whether you have to do the tile captcha or just the checkbox. Probably based on the IP you’re coming from, the device, how often you’ve posted, how recently you’ve posted or some combination of these. But I think, really, it depends on what I had for breakfast. :slight_smile:

I just updated 11 cameras. On 2-3 of them, the process completed normally, but when I went back to the live stream, it told me again that it needed update for the same firmware that just appeared to install normally. Installation completed properly the 2nd try. This has happened regularly for the last several firmware updates on my V1s. I cannot correlate it to anything, except (perhaps) not waiting for a few seconds between tapping OK on the popup dialog and tapping the actual update trigger on the succeeding page.

I think everyone would like what you are suggesting. However, when doing OTA (over the air) upgrades on a device that has no ability to display anything other than what it can send to your phone, about the only thing it can give you an accurate indication of is what it has downloaded to the camera. Even flashing your home router probably involves a lot of “lying” about progress. Most of these progress bars are just timers that set the user’s expectations, so they don’t get worried.

I don’t know how the the Wyze camera firmware upgrade works, whether it downloads the update into ram (volatile memory that will be lost without power) or to an update area in the camera’s flash.

The point is, a restart is required, and a reconnect to wifi, and Wyze servers. So there is always going to be a portion of time that your app is blind to the camera. Think of it as using remote desktop to a remote computer where you are doing a feature upgrade. There is always going to be the anxious time after the remote computer reboots and does stuff even before Windows and the tcpip stack is loaded, so you just have to wait until it returns “from the far side of the moon”.

I am on a VPN - PIA, actually :wink: Not to hide my IP, but for an extra layer of security and because I just don’t trust my ISP.

I’ve heard that some of the voodoo in Captcha has to do with mouse movement, clicks, etc before hitting the “not a robot” button. Who knows…

I do know that it’s annoying. And this is the second time I’ve typed this reply. The first one didn’t post after running the tile gauntlet twice. Wheeee. LOL.


accidental dup post. edited to remove duplicate. Moderators: feel free to delete this.


I updated two cameras from .56 to .62 from 10 miles away (meaning the Android app I used to initiate the update was connected to a totally separate wifi and internet connection). Both upgraded successfully. Both cameras are connected to a dual band router with the same SSID on both bands. I did verify that if I go into device info, they are now both showing “Installed firware version:”.

I couldn’t tell any difference, but I think that is “a good thing” because I didn’t have problems before.

Yes, no news is a good news. You should not feel different between the two builds. Thanks for checking!


As requested I uploaded the last firmware yesterday.

Since, nothing works and unable to use my Wyzecam. I have deleted the IOS app, reinstalled the App, and then I don’t succeed to connect the Wyzecam.

Everything worked perfectly until last night.

Very disappointed.


Sorry to hear about your v1 firmware upgrade failure.

The two v1 cameras I upgraded successfully were shipped Jan 18, 2018 and were the v1 cameras with 4 LEDs.

I also upgraded from the previous beta v3.9.3.56

Do you know if your cameras have two or four LEDs? If you don’t know, it will be hard to find out now, since they are only visible in the dark, and since the carmera is no longer working you won’t be able to check.

Open a ticket with Wyze.

Is the light on the back of the camera solid yellow (amber)?

Since upgrading, the camera’s been glitchy and really laggy. I didn’t have any problems or issues before the upgrade, the only appeared after I did the upgrade. Anything I can do to roll it back to where it was before?

Information on factory reset and flashing firmware below for V1 and V2 respectively:


After the upgrade to v3.9.3.62 my camera is now stuck in the FLASHING YELLOW/BLUE mode. An issue this version claims it fixed. I had never seen it before, the camera has worked great for months. Now its useless, I have tried everything to reload but cannot connect to network to fix anything. The other camera I have seemed to update ok. I did tell my sister in law not to do the firmware upgrade. Also, the latest APP update leaves a “streaming camera” logo in the center of my video while monitoring, all though its not in the capture, its very annoying. Come on guys. Let’s do some QA before releasing updates.