Issue with video playback speed

Hi, I have a v2 cam at my garage and I have noticed something very weird. When I check the events and run the play back from the cloud it is about twice the speed. Like Im running fast forward. The seconds are about half seconds when they count up. When you see a person walking its like they are trotting. Things iv checked, The sd card. Its playback was the same, I formatted the card and still get the same result. This seems to have also happened after the last update. It has the newest code. Any thoughts?

Hi, from my experience, when playing back footage from an sd card on your device, it plays every other second unless you were specifically recording that time frame. I am not great at explaining this but, if you watch the time stamp as you are watching the playback, It will skip every other second

I recently posted about the same issue here:

Are your cloud events showing as longer than 12 seconds and not playing for that long?
Can you verify if yours works normally with Nightvision enabled?
Also did you recently have a camplus subscription that expired? In other words, how long ago did you set up this cam? Was it within the last 2 months?
If you had a camplus trial expire less than 2 weeks ago will you go back 2 weeks ago on cloud events and verify everything works normally for camplus uploads, just not the free cloud events?
I’d really appreciate you checking that out!

Wyze responded to this issue here:

But think they are discounting that this issue is related to the camplus trial and I would like to verify some of that for them if you could help out.

I look forward to your answers to those questions.

1 Like

Just curious whatever came of this? Im spontaneously having the exact same issue on one of my v2 cams…super frustrating.

1 Like

Honestly, there weren’t enough other people reporting this issue. I had a Wyze employee trying to help us with this issue in the Beta forum that I linked to above, but nobody responded here or in the other threads so I couldn’t get anyone else to give them enough information to pursue the issue or verify it, so after 90 days the beta thread got closed and nothing has been done about it and it has not been fixed.

I still have the exact same issue on that one cam, but it’s hard for them to verify things that appear to them to be something that is not really happening to anyone else. There was not much they could do without others admitting to them that they were having the same issue too. So due to lack of activity it just fell apart. Nothing happened.

I suggest you submit logs and reference my ticket and my original post I linked to above and send it to support and file a ticket also referencing your logs and my logs and my thread so that they can see detailed examples of what you are talking about. The more people who report the issue will allow them to compare the similarities and be able to figure it out. Otherwise they’ll just assume its a connection issue, but it is not. It doesn’t matter where my cam is, and a connection issue wouldn’t be affecting my SD card, and if it was a network strength issue then adding cam plus wouldn’t make any difference at all, but since it does, it means it’s not the network, it’s something with a certain line of Wyze V2’s.

Nothing…still have issues. I formated the card and this seemed to help for a few days but back to the same. Seems like everytime I want to look at whats making my driveway alarm go off I can’t connect either. Its like when it starts recording you can’t get the picture up.

I agree with your thoughts on it being connected to the plus trial expiring.
I have had cameras for well over a year and they worked flawlessly. I added a new camera to the system and it prompted me start a trial so I figured why not. The trail was for my whole account meaning all the cams were included. The trail ended a few days ago and now just one camera plays back at double speed.

My outddor wyze cam plays back in fast motion. This only occurs when I get a recording at night. Daytime, the wyze works as it should, Is there a fix for this???

I have the exact same problem as tremel4028. never had an issue with my year old outdoor cam until Christmas 2021. I purchased another outdoor cam, installed it, udated my Wyze app and now both are playing at double speed. Changed both to SD. still same issue, only at night. did not start any trials or changes.

See this thread:

I feel your pain and most likely am seeing the same defect. Dunno how long it’s been happening.
Just now did a side-by-side trial of my old v2 and a “replacement” v2 to see if the replacement has the same poor image quality. Both are on cam plus (the replacement with the 2-week trial). Old camera has SD card, new one, not.

Live recordings of both play back at 2x; as though every other frame was dopped. Based on other posts I suspected this was due to less-than-full WiFi strength. Phone wifi strength showed 1/2.

So…moved both cams to <5 ft from router. NOW the live recordings play back at 1x speed. OK, so cams are finicky about wifi. So be it.

BUT, then I ran playback on cam with SD card and recorded a clip. That clip also dropping frames so seems to run 2x. This makes no sense - why should frames be dropped on mp4 clips auto-recorded to SD card? Is there some nonsense where the camera hardware does not record directly to the SD?

Label me frustrated.

Again, it is only my outdoor cam, battery operated, that goes in fast motion at night. During the day, it’s fine. I contacted WYZE about it weeks ago and never got a reply. All of the other camera’s are fine.

Did you read my post above? Change the camera firmware back to the November 2021 version and that will fix your 2X speed with night vision on.

Just dropping in to say that I’ve also had this same issue with my Outdoor Cam for the past two months or so. To be a bit more specific, it happens only a night and the 12 seconds of video is compressed into about 6 seconds (i.e. everything plays fast, then movement in the video freezes, but the video itself continues running for the remaining 6 or so seconds).

I’m going to try installing an older firmware version as others have suggested, but this does seem to be a persistent problem that I’d appreciate Wyze addressing with an update.

I’ve been having this problem for around a week now, the playback speed is about double what it should be but the sound is the correct speed so they are out of sync. I have this happening on all 3 cameras (2 V2s and a Cam Pan).

I am having the issue. It only does it at night and only have 6 seconds instead of 12 of playback it has been going on for a couple months also

Update: I flashed v4.17.1.290 using these instructions (

Night recordings are again functioning as they should. Hopefully Wyze will fix this problem or at least not make this firmware version incompatible with a future update.

I have had my v2 cams for several years and the last week or so 3 of the 5 are doing this. Either looks sped up or like 1-2 seconds are missing and jumps to that next frame. I have sent in a couple logs regarding the issue but not fixed so far. Mine were not just night time but anytime of day.

I am having the same issue. The playback is going at double speed on cam pan v2 and cam v3 as well. I tried formatting the SD card to no avail.
This is clearly a bug that is affecting many users. Some of the cameras are a few feet from the router with a 630mbps/300mbps connection.

1 Like

What actual app version are you using? What is the actual firmware version on the cameras themselves? What type and mode device are you using the app on? I am guessing this has nothing to do with your internet connection speed, but more of a app, firmware or hardware issue.