CamPlus not recording longer than 12 sec - when there is motion

Got two v3 delivered the other day to add to my stable of v2s. Also ordered a one year subscription for CamPlus (code came in an e-mail). All good so far. Cameras looks really good and image is stellar.

Cameras came with a 14 day trial each to CamPlus, so holding off activating my subscription as cameras not yet officially and properly mounted, and I do not yet know which one will be graced with CamPlus. For now, only testing.
Issue: event recordings are still limited to 12 seconds - even with CamPlus activated (trial) on both cameras. That’s it, even when motion is longer. What is going on? Camera can clearly “see” motion, as I have motion tracking on.
As cameras working fine apart from that, firmware not yet updated and they are still on delivered version (

Common issue? Did search but couldn’t find a post addressing the problem.

I got my V3 9 days ago and the firmware version is Did you go to your account, look under services and see if the trial version of Cam Plus is listed and activated? I would send a screen shot but I have since changed mine from trial to paid version.

Oh yes, CamPlus has the trial licenses activated on both v3 until February 21, 2021.

Odd thing when clicking “edit” on the “CamPlus”, it leads to - correctly - a page that indicates “0 available free trial licenses” (which would be correct, as there are none left to activate), but it also lists both v3 to “update”. Same as all other devices.

On the two v3 cameras, I have a total of 24 “Events” from today. All of them are 12 seconds. Even though motion is longer clearly is longer on a number of them, and with CamPlus, longer recordings should have been captured. Not enough events today to tell if there is still the same 5 min cool down period, but based on events over the past couple of days, I say it is clearly there.

So still, even with trial of CamPlus; limited to 12 sec and a forced 5 min cool down between event recordings.
@WyzeGwendolyn , any chance to provide a comment to one of your Kirkland neighbors?

Why don’t you update the firmware? Since it states update, I don’t think it applied the camplus correctly. Have you restarted the cameras at all recently?

Edit/ info from support pages:

Have updated FW, rebooted. FW fixed it - on both devices. Thanks!

Otherwise, why not update FW? In past cases with Wyze, I have stayed on FW that has been 6 months old or more. just because it has been working stellar (and reading about issues with newly released FW). Little bit like “why mess with it if not broken, even if a bit old”.
Adding, looking at the other cameras, all 5 were behind (on and and three out of five failed the firmware update while doing each one individually and in sequence (waiting until one was done before proceeding to the next). Failed several times. Will have to power cycle those three cameras.
This is one reason many of us are staying on older FW. It just works, cause it is annoying to get into a FW update process that can be hit or miss.