Initial feedback for Home Monitoring

Getting the exact error with my home monitor setup process in Alberta as well. Let’s me know once the fix is available.

1 Like

I’m having the same issue… does anyone else think it’s funny how they launched this with all the hype and it doesn’t even work lol. Can we at least have the option to bypass it and just use the hub locally to monitor the sensors?

Just received the home monitoring device yesterday and I’m facing the same issue where postal code is not accepted while setting up. Following this thread for further updates. Location - Ontario.

1 Like

I think monitoring the sensors locally does work by skipping the Home monitor setup

Same problem, also in Ontario. If I put in 5 numbers (like the hack that used to work at gas pumps in usa asking for your zip code for a credit card where supposedly you could use the 3 numbers in your postal code then add 00 ) the red box for that field vanishes and you can go to the next step. But it then says something to the effect address does not seem correct etc. I think Wyze just forgot to change that field from expecting all numeric zip code to the alphanumeric postal codes used in rest of world!

1 Like

Postal code seems to work for me when using an android. Had the error and couldn’t move ahead when using iphone or ipad. Seems to be a bug on Wyze for iOS?

Also there doesn’t seem to be an ability to order additional hardware for home monitoring in Canada after initial purchase. Any attempts to purchase hardware redirects to US site, otherwise isnt there. When speaking with support, they confirmed this and advised currently the only way to purchase additional hardware was to order the service again with the hardware, and then cancel the duplicate service once receiving the hardware.

We are investigating an issue with addresses in Canada not being verified properly and hope to have a fix out soon. I am sorry for the trouble.

1 Like

We have released a hotfix that should address this issue.


Hello Jason,

It’s good to hear that Wyze is working on a fix for this. However, although Wyze pricing is extremely competitive, it would appear that people are paying for a service they are not receiving and it’s no fault of their own. In addition to this issue, some may have cancelled their current alarm monitoring because they had received the Wyze home monitoring. Lastly, from a legal perspective, considering how litigious things are in the USA, you would think that Wyze would/could be held liable, to some degree, for not being prepared to have their product roll out and not coming up with a fix forthwith.

Food for thought.

1 Like


I do agree and am sorry it happened. We do have the fix rolling out now. It should be available for download in the coming hours if it is not already. I linked to the post about it just above your post.

1 Like

If you mean for it to be downloaded in the Apple App Store, there is no update as of yet.

The app and firmware just came in and seems to work

I updated the app and my Canadian address accepted!

Now to figure out why the Wyze Hub didn’t update and is offline.

A ticket had been submitted and hopeful for an answer soon.

Yes, my hub did the same thing. It’s too bad WE need to try and figure these things out. I connected it via an Ethernet connection and that worked for me, but in my case I need it connected to wifi. I will figure that part out tomorrow. It should be as simple as unplugging from the Ethernet connection, as the app suggests, but based on how things have gone thus far, it won’t be.

Now that the app is working in Canada any idea on when we can start purchasing additional sensors?

1 Like

I have tried the support desk 3 different times and they have no idea, very frustrating for such a simple question

The Hotdix worked to a point. I was able to get my account set up. However, whenever I hit the monitoring button on app in IOS, it would flash up the setup screen at section 3 before loading the dashboard. It awaits continue w setup before it went to full screen. Not being sure that things were correctly set, I hit button and went in. Got to the page with my address. The country was blank. Click on it and it only gives USA as choice. So I am stuck. I can’t set it up again. This is so frustrating. I reset all my gear and started from scratch. Paired all sensors. Still no difference. So I’m sitting inside my home with the system armed in HOME settings. I have no way to disable it. I’m on the phone awaiting tech support but I know I will get an offshore support centre who are powerless to make any changes. Could I please have some support with solutions?
[Mod Edit]

This launch hasn’t been smooth at all for longtime Canadian customers!

[Mod Note]: Personal information has been manually removed for privacy and security reasons.

I also have that problem. Extremely frustrated. This is yet another whole day I’ll never get back. Spent a big part of the day trying to resolve my issue with several reps. Try everything they suggest to no avail. Get the feeling they don’t quite know how to deal with us Canadians. Not set up properly yet? Didn’t seem to have any problem taking my money …
All I want to is change my US Address to my CDN address so that I can set up myCanadian add for monitoring. The app refuses my address (Has to be US only) Everyone I talk to can’t seem to come to grips with my issue. Just lame canned responses.
I’m done.
Writing off my expense on this stuff. Burned but lesson learned.

1 Like

Good news. WYZE home monitoring now accepts Canadian addresses. You just need to update the app to the latest version.

1 Like