Infuriating RTSP on V2

I have to start this by saying I am a technical idiot. I have been trying to get my cam V2 hooked up to my NAS DVR and it’s infuriating. I read up on RTSP here and no matter what I do, it doesn’t work. Doing everything it says. Download, unzip, rename, root of the micro, install micro. Every single time I hold the setup button and plug it in, it just says “ready to connect.” Never a blue light. I tried setting it up again and getting it back to what it was multiple times. I tried it on a USB. I tried re-downloading and unzipping. EVERY TIME… READY TO CONNECT. It says wait for blue light. How long do I wait, because my hand is going numb after 2 minutes.

Updated firmware on camera. Checked for new version of the app (not that it should matter).

How do I get the dang thing to accept the firmware???

Welcome to the forums!

Download the RTSP firmware, extract it and place the file in the sd card (make sure the ad card is 32 gig or less). Rename the file to “demo.bin” (if you use windows sometimes it hides extensions so I tried unsuccessfully to install demo.bin.bin unknowingly and yes it did not work like that). Unplug camera, place sd card in cam, press and hold the setup button (I’ve found that placing the camera upside down on a table and pushing into the table helps the akwardness), keep holding the setup button and plug in the cam. When you see the led light in back shine yellow and blue at once then let go of the setup button. Let it sit while it does it thing and it should install.

This is EXACTLY WHAT I’M DOING. Zero blue light. Straight to yellow, then flashing yellow and “ready to connect.” Card is a 32gb SanDisk Ultra. Formatted about 10 times now.

(and thank you… don’t mean to sound jerk-ish. It’s not you I’m frustrated with its ME :slight_smile:

Only things I can reference now is maybe try a different sd card if possible, quadruple check that the file is named demo.bin (on my computer it only shows as “demo” because the .bin is hidden). Do you have a second v2 to try this process on? Something isn’t jiveing because it shouldn’t say ready to connect if everything is right.

Are you trying to use the #.49 version of the v2 RTSP firmware? some reminders I’m seeing in other threads is to make sure the card is formatted fat32.

If the file is valid, it will go to light blue (flashing mode) in about 5 seconds. Make sure you are pressing and holding the setup button BEFORE you apply power.
Having done a couple dozen V2 flashes in the past few days, it worked every time EXCEPT when the uSD card got corrupted. Formatted the card in my PC, and copied the flash files onto the card again, and did another dozen flashes. BTW, I use a small screwdriver to hold the button on the camera, and I normally use a USB battery bank for power. Start with the battery bank turned OFF, and plug in the cable. Press the setup button and with my other hand, press the power button on the battery (much easier than trying to plug in a cable).

Thank you all… I figured it out. I was verifying that the card was good by putting some photos on it, trying it in other devices, and it all checked out good. But something about that card didn’t play well with the wyze cam. I bought a new card today and I currently have a blue light.

I have never experienced that where a card worked in all of my devices except one.

Now the fun part will be the learning curve of actually configuring my router and NAS so they can see each other :flushed:

I’ve tried 5 different cards of varying sizes and ages, including a brand new one, and cannot get the demo.bin RTSP firmware to load on my v2 currently running

Are all of these memory cards no good for flashing or do I keep trying?
Is the only option to buy more memory cards hoping one will work?

I’ve had the RTSP firmware on this same camera in the past and flashed it with the card I have now. Why would it stop working?

I would hope some that you have would work. Make sure it’s 32 gig or less, and that the file is demo.bin not demo.bin.bin. Windows tends to hide file extensions, so be aware of that

Also make sure it is formatted FAT32…

I’m also seeing this issue. I’m using a SanDisk Ultra 32GB Class 10 card and formatted it using the camera (Wyze V2). I then downloaded the Wyze V2 RTSP firmware, copied it to the root of the microSD using the command line on a Linux computer (no hidden file extensions) as demo.bin, inserted it into the camera with the power off and turned it on with the setup button held down. I get the orange light and then “ready to connect.”

From the digging I’ve done it sounds like a number of folks have run into this. Some have seen it with some of their cameras and not others. This page theorizes a correlation with the second part of the string contained in the QR code:

My camera doesn’t have either of the codes listed there, it has Y00A0030. I just updated it to firmware