RTSP flash troubles

Ever since getting a Synology diskstation I’ve been trying to flash both my Wyze V2 cams without much luck. II first downloaded the firmware. Put the card in the camera. Held down the, “Miniscule,” button until the light turned solid blue. Went to the software>setting>advanced and no mention of RTSP.

A few Questions. Under Settings. Device info> Firmware Should it list the RTSP version, “” or just the regular, “” TIA

BTW: if any of the Designers of the wyze cams read this. Please, either make the dang button easier to hold or allow us to connect it to a pc for flashing!!!

Did you extract the file from the zip? Name the extracted file demo.bin? Put it on a 32gb or smaller SD card formatted FAT32?

1 Like

A small screwdriver or the tip of a pen makes the button very easy to hold for five seconds or so after powerup (I slowly count to eight because I usually can’t see the status light while holding the light). Then wait several minutes for it to load and reboot.
The firmware will show the RTSP version. RTSP is on the Advanced settings all the way at the bottom.
I’ve done something on the order of 50 RTSP flashes and it works EVERY time if you do it right.
One followup to what WildBill said, make sure that windows is not hiding filename extensions (horrible idea Microsoft to default that to on) - else you end up with the filename demo.bin.bin *which won’t work).

1 Like

It’ll show the RTSP specific firmware version, like so.

And when you saw blue light, is a just blue, or a blue led and yellow led combo that’s solid?

Ok, guys, getting closer. I started fresh by erasing the card, dl the zip and unzipping, renamed the bin to demo.bin.

Put the card in, held the reset button, “used a dime.” waited for it to go solid blue then released. It rebooted only now it’s flashing green and won’t connect!

Never mind guys. Just needed to unplug it. once plugged back it, it worked. Thanks to all!!

Just need to figure ot how to get it into Synology Surveillance Station

Ok, got both Wyze cams recording to my Synology disk station, Thanks guys!

I am having the same difficulties flashing the RTSP firmware onto two brand new Wyze Cam v2. I have followed the instructions above:

SanDisk 8GB MicroSD card, FAT32 formatted with Windows
downloaded the zip file Wyze Cam v2 RTSP file

unzipped the file into a file folder called:
and within that folder is a BIN file called:
I copied this BIN file onto the SD card and renamed it as ‘demo.bin’

Hold down ‘setup’ button and plug in USB cable…
the LED is solid orange, after 5 seconds there is an audible ‘click’ after another 2-3 seconds there is a ‘crackle’ as the speaker is activated, then the LED starts blinking orange and prompts ‘ready to connect’

  • I haven’t released the button at any point.
  • At no point during this sequence does the light turn blue.

I have the same result on both devices.

I have paired the cameras to the android app and updated firmware to

I must be doing something wrong, any tips?

It shouldn’t say ready to connect at any point if you are flashing the firmware. The que to release the setup button is the status led light showing the solid blue and yellow led on at the same time.

Are you making sure the demo file is demo.bin and not demo.bin.bin? Windows sometimes hides the second extension and that will cause the flash not to work.

1 Like

Rename the file demo.bin and nothing else. Once it turns blue-ish let it sit for a few minutes and it will restart. then it is ready.

SD contents

after watching a youtube video, it really is that simple. I had to find a ‘new’ SD card, the previous 2 I was using wouldn’t work for flashing but do work for recording :roll_eyes:

So you got it working then?

1 Like

yes all working now, I needed to try a third SD card to get the firmware flash to work