Reinstall firmware on Wyze cam V2

I had installed the RTSP firmware on a number of my wyze V2 cams. I’m now trying to go back to the standard firmware, but my cameras are not going into “install” mode. According to the instructions, after inserting the card with the demo.bin file, I should be holding down the setup button while plugging in the camera and holding it down until the status light turns blue. But the status light never turns blue, it just stays orange and eventually goes into setup mode “ready to connect”.
Any suggestions? Is there a different process when the camera has the RTSP firmware installed?

It’s the same process that you flash the RTSP firmware onto the camera with just using the production firmware branch. What size is your card? Did you triple check that the file is only named demo.bin? Windows tends to hide the file extension so you may have demo.bin.bin If it wasn’t renamed correctly. Those are the two most common ways I think manual firmware flashes don’t take.


It’s a 64GB card. It’s the same card I used to install the RTSP firmware (infact, it had me overwrite the existing file that was on there). File is just named demo.bin. But I don’t ever see the status light turn blue when I’m holding down the setup button, so I don’t know that it ever tries to load the firmware.

You must be lucky because I’ve only heard up to 32 GB works for the firmware flashes. Do you have a 32 GB card you can use for this?

The status light will turn a combination of blue and yellow. Both the blue and the yellow LEDs will light up together when the firmware flash takes, then you can release the setup button.

That’s interesting because the card I used is the one I installed the RTSP firmware with. I tried a 16gb card and still no luck. I never actually get a blue light. I see a quick flash of blue, but then it changes back to orange.

What computer are you using to copy the demo file over to the card? For troubleshooting you could try to flash the RTSP firmware back to the camera to test if the process works for you again. But I’d check if you are using demo.bin, or demo.bin.bin (my windows machine hides the last extension so I rename the file “demo”, then it appends the .bin part secretly.)

I’m a software developer, so the first thing I do when I get a computer is turn off the option that hides file extensions. I could try re-flashing the RTSP firmware.

Never had issues reflashing firmwares with 128GB cards on my side. (V2-V3-Pans v1)

I am having the exact same problem with my v3 camera. Tried with two cameras, using the sdcards that were already installed and brand new 32 gb cards, and getting same exact results! Did you ever find the solution?

I have not yet found a solution. I wish this had a “factory reset” like other devices have. At least that way it could go back to the original software that could be updated online.

I was having this exact issue. Every time I tried flashing the NEWEST firmware, I couldn’t get the cam led light to stay on steady blue, it would flash and never update the firmware. Then I tried the “demo_4.9.7.798” and it worked the first time. Then I was able to update to the newest firmware through the app.
Hope this helps any of you trying to manually update the firmware after using the webcam firmware.

Do you have a link to where to get that firmware version? I don’t see it on their firmware list.

If you want newer firmwares:

1 Like

Got it. That firmware appears to work. THANKS!