IFTTT Integration with motion as a trigger not working

Anyone else having issues with Wyze cameras not triggering IFTTT applets? I have a camera at my front door and I want it to trigger a virtual switch in Smartthings. I followed all of the troubleshooting tips but it still says “never run”. I have two tickets into Wyze and they have not responded other than to say allow 2-5 business days for a response. It’s been at least 5 days. Anyone able to fix this issue?

1 Like

Yes, I have been having the same problem. I set up a few IFTTT scripts a couple of weeks ago using Wyze motion detection. They worked great for a few days, then all of a sudden stopped working. No activity in the activity logs for IFTTT, although wyze is definitely registering the motion. Something seems to be wrong with the connection. When I go to the IFTTT setup, where you would choose which camera it is using, it says ‘options unavailable’. Then if I relink my wyze account to the services page, the cameras show up in that field, but it doesn’t solve the issue. If I check the same area a few minutes later, it says options unavailable again.

@WyzeGwendolyn why is this? Something that yall are working on hopefully? Thanks!!!@!

I just wish they had ST integration then this would be a non issue. I saw somewhere they said they are considering it.

1 Like

Same problem here. Also wish they had ST support.


IFTTT/Wyze-motion integration has been broken since about the 9th November 2018. There are no logs either on IFTTT (both the web portal and the phone app) or on the Wyze app that indicates what went wrong.

I have an IFTTT app that is set up to send email notifications when a Wyze cam detects motion. This was working quite well until some time between the 9th November evening and 10th November morning (which is when I knew something was seriously wrong because I was not seeing email for motion events that I knew for certain were occurring).

As of now, motion events are being generated by the camera, are being reported “locally” via push notifications on the Wyze app, but IFTTT does not seem to get any of this information—and obviously does not generate any notification emails.

Strangely enough, activity initiated at IFTTT, for example, the hourly video-clip upload, has been running fine. So the data/control communication path from the IFTTT servers (where the hourly app runs) to the Wyze servers (where authentication tokens are validated) to the Wyze camera in my home (where video is captured and uploaded) are all working fine, at least for this particular activity.

Activity initiated at the Wyze camera (like motion detection) is also getting to the Wyze servers and to the cloud storage, but the Wyze servers are simply not sending the relevant event notifications to IFTTT.

BTW, I have other IFTTT applets that are based on “locally initiated activity” (for example, Smartthings door-sensors being opened and closed) that have been working fine during the same period of time when Wyze motion detection has not worked with IFTTT.

Clearly, some services (like Smartthings) are working just fine with IFTTT for device-initiated events. IFTTT initiated activity (like DateTime) also seem to be working with Wyze. But WyzeCam initiated events are not getting to IFTTT.

I have tried “refreshing” the Wyze service on IFTTT, tried deleting and recreating the IFTTT apps, restarting my camera, etc. multiple times. None of this helps.

Wyze folks. Please fix this ASAP. At the very least, tell us what is going on so that we are not left speculating or running useless experiments on our end.

1 Like

Same issue since 11/02 on my V2 cameras (all of them) and since 11/07 with the Pan.
My IFTTT applets were working fine until then and suddenly stopped working.
I tried to unlink/relink the wyze account but it didn’t fix anything.
I have contacted the support and the only answer was to “allow 2-5 business days for a response”.
As it has been more than a week now, I doubt I will get an answer… which is disappointing.

We’re sorry to hear about this! I’ll send this thread over to the dev side, too. I’ve been collecting reports and sending them over but I don’t have answers yet. Sorry I’m not more help at this point. :frowning:

Same problem here since at least 09NOV… hope it gets fixed soon! I enjoy using the motion triggers.

Finally heard back from Wyze and this is what they tell me. You got to be kidding me. You don’t think I would think to enable my motion in the settings? Needless to say have not heard back from this guy.

Thank you for contacting us! :slight_smile: I’m sorry to hear that you are having an issue with your camera and your alerts. I’m sorry we haven’t responded to you yet. I have a couple of questions for you to see if we can figure out what might be going on and help fix your Camera. Can you go into the Live Stream for your camera so we can confirm the alert settings are turned on? You can do that by clicking on the Gear in the upper right hand corner then going to alert settings to make sure at least Motion is turned on. If it is already turned on, try cycling it off/on again by clicking it and going back to the Live stream. Do any errors pop up when you do that?

Hopefully that helps but if you have anymore questions or anything else comes up, please feel free to let me know or just reply here and I’ll be able to help you out. :slight_smile:

Mine just magically started working again. anybody else?

1 Like

Aw, jeez. I just sent this to one of the team leads so that they can look into it. This team member definitely missed the mark with your issue and we’re sorry about that.

We’re looking into the IFTTT issues now. If you could send me a direct message with this information, it would help! :slight_smile:

  1. What time and date did IFTTT most recently fail and what time zone are you in?
  2. If this is a continuing issue, when was the last time IFTTT was having trouble and when was the last time this applet worked? How consistent is it?
  3. What is the MAC address of any camera(s) affected by this applet?
  4. Please give a description or pictures of your applet so that we can try to reproduce it. Please include any services you are using in this applet.
1 Like

Hey, folks!

We’re trying to chase down these issues. If any of you have sent in support tickets about this, please add this information to them:

  1. What time and date did IFTTT last fail and what time zone are you in?
  2. If this is a continuing issue, when was the last time IFTTT was having trouble and when was the last time this applet worked? How consistent is it?
  3. What is the MAC address of any camera(s) affected by this applet?
  4. Please give a description or pictures of your applet so that we can try to reproduce it. Please include any services you are using in this applet.

If you haven’t contacted customer support yet, please use this link to fill out the form.


Yes It’s working again for me…

1 Like

Working good now Gwendolyn thanks for all your help

1 Like

My pleasure! Sorry we dropped the ball on this. Please let me know if you run into anything similar in the future. :slight_smile:

I had this problem beginning around Nov. 7 but it magically fixed itself sometime during the night of Nov. 12/13. I had reported the problem to support on Nov. 10 after pulling out all my hair trying to debug it with no success. I haven’t heard anything back from support at this point. I would appreciate an explanation from Wyze as to what happened to cause the problem and how it was resolved. Maybe this would help to find a speedier solution if it happens again.

1 Like

I know that we looked into it but I don’t have any further details. I’ll see if I can get a tech side person in. :slight_smile:

Would you like to give me your support ticket number so that I can close your ticket for you? We apologize for the delay in response but we’re happy to hear that IFTTT is working for you again.

My ticket number is 134801. I would really appreciate an explanation of what caused the problem and what was done to correct it. Thanks in advance for your cooperation.

Hi Richard, I looked at your ticket and it seems like working now. That would be great. We looked at IFTTT service in the past few days. The overall service health is the same as before. We only saw a small number of failures. We are chasing an issue that IFTTT brings you empty option when creating trigger. We added logs for it.

If the issue showed up and disappeared itself, it may show up again another time. I would like to work with you to fix the issue. For your past incident of no trigger, can you check if your IFTTT applet ran on IFTTT side when there was a motion trigger?

1 Like