IFTTT Integration with motion as a trigger not working

Just a note that I have had intermittent problems with IFTTT integration for the last week or so as well. Most recently this morning.

The problem gets resolved every single time if I go into the Wyze service on IFTTT and “Reauthenticate” by logging in using my Wyze username/password. But I have essentially done that 3-4 times in the past week.

Whenever this happens, IFTTT does not report an error. It reports the applet as successfully triggerred. However, if you go into the “Configure” screen for the Applet, you notice that the Wyze device list (labeled “Which Device”) is blank, and does not include your linked cameras. That was my clue for a broken authentication.

Going into the Wyze service, clicking “Edit Connection” and reauthentication restores the list of cameras, and the functionality of the applets.

I had not contact Customer Support yet on this issue (I was first googling to see if it was common), but will certainly do so next time.

[Mod note: IFTT => IFTTT for better search ability]

When the problem first started happening I would sometimes get an IFTTT error: “Applet Failed, there was a problem with the Wyze Service.” Then later on as the problem persisted there would not be an error message. My phone would receive the motion notification from the Wyze app but nothing would happen with IFTTT and there would be no IFTTT error. This was only happening with two of my five cameras that use IFTTT. The other three cameras never had any problem with IFTTT. The two failing cameras would always send all Wyze motion notifications to my phone, but very few of the motion notifications would get to IFTTT.

Same issue here. Mine has not fixed itself yet. The only way I know it has failed is if I’m sitting at home and IFTTT tells me it ran the applet (me leaving home). Sure would love a fix for this.

I just got smart lights for Christmas and wanted to set up an applet to turn on the living room lamp when motion is detected on the living room WyzeCam Pan. It doesn’t give me an error message nor does it work. I tried what was suggested in this thread but nothing has worked yet. Put in a support ticket too as this would be a perfect function for my needs and it stinks that it doesn’t work.

@WyzeTao and other Wyze experts:

Does this not work in 2019? I can’t get IFTT applet to work detecting motion with my brand new wyze device… just bought less than 24 hours ago…

Hello @simpsons007 sorry to hear about your issue but IFTTT should be sending you notifications if you have the applet turn on and the camera connected to IFTTT but in some cases you may need to re-establish the Connection between the both so I’ll link you to an article on how to go about doing that.

Here’s the link to the article.


1 Like

@simpsons007 this issue with automation and IFTTT is still an issue. I’ve reported the issue and emailed log file. Would love to hear something on this issue soon. You can also see the automation failure at work if you create shortcuts in the Wyze app.

At one point automation was failing only on my PanCams. Some sort of restart that was automatically instigated fixed this issue for a few days.

A few days later both my V1 and V2 cameras began to misbehave. Based on another community members experience I removed both the V! and V2 camera and then re added them. Automations resumed for these cameras for less than 24 hours and then they once again were missing both Wyze shortcut commands and instructions coming through IFTTT.


I’m having the same issue. When wyze pan came detects motion I want to turn on a smarthings virtual switch. Wyze records a video when it detects motion but nothing else. I tried other methods in IFTTT and the wyze app too. Using IFTTT I’ve tried to to turn on a wyze smart plug when motion is detected and I set a rule in the wyze app to do the same thing. Also no luck there either.

Can confirm. Motion sensor linked with ST virtual switch refuses to trigger it. Did multiple tests and Wyze appears to be the service at fault here since other applets involving ST and Ifttt work just fine.

Come on, guys. This is elementary stuff. If you can’t keep it running then at least consider releasing a direct ST integration and save the rest of us the trouble.

Hi - not sure if anyone will be looking at this thread but i just opened a ticket with wyze 3+ years later and same symptoms appeared for me and my v3 integrated with ifttt. Was working fine but motion detecting stopped triggering ifttt a couple of days ago. Iftttt can still turn camera on and off so there is some communication happening. Support seemed stumped. Gwendolyn, if you’re still out there … help please

Same thing with me, June 2nd was last time they ran. You find a fix yet? I reconnected and that didn’t work

started working again yesterday 6/6. i did have a ticket open with wyze and was communicating with someone on the issue was, so perhaps that led them to the fix

Yeah same for me just started working again yesterday