I can't get Wyze to save my wifi password

I have tried deleting the base station, deleting the base station and all cameras, resetting the base station, and even got a new base station…UGH. And support seems to have no idea as they just keep offering a replacement but this one is brand new and the issue remains. At first I couldn’t even get it to accept my wifi name at all but now it has done that but will not accept a password so I can’t use wifi. Anyone have any ideas? I am losing my mind at this point.

1 Like

Do your trying to switch the base from Ethernet to WiFi, or are you trying to set up the base on WiFi. Did it previously work, but stopped working?

I am trying to witch from ethernet to wifi. Far as I understand to do so I would need the base station to save my wifi password and it won’t. If I just unplug it it won’t connect as the password is not accessible to it since it won’t save it. It worked before I changed my wifi password and the whole thing crapped out when I did that. I have been trying for weeks to get it all to work again. Super frustrating.

1 Like

Any special characters in your wifi ssid or password now? Anything other than letters and numbers? Any error messages? What happens when you try to save the info?

1 Like

Hint, you made a change to your password and now it does not work. Think maybe there is something about your new WiFi password? As Tony said, any special characters in the new password?

1 Like

There is a special character and my wifi requires that so I can’t change. Given that it worked before w a special character (same one) my guess is that’s not the issue.

So it was working over WIFI at one point? When you had to change the PW, did you have to change wifi hardware also? Is there any error messages that show when you try to save the info? What does the app do when you try to save?

As a test, change the WiFi password back to what it was and confirm that the Wyze stuff works or does not. That will pretty much confirm that it is or is not something about the password.
Did the password change length? I don’t know what the limit is, but my primary WiFi has a password that is over 50 characters long and I have found some devices that can’t accept that length. And no, my IoT devices are not using that SSID, and the IoT SSID has a shorter password.

Yes, it worked before. No, I did not change hardware and no error message. It just tries to save it and then when the spinning wheel is done and I check it’s not there. It’s still blank.

And sorry but I am not going to change the password again and have to change/reload all my devices. This has already taken days of my time and I am beyond frustrated. I can’t believe their techs have no suggestions other than the simplest things that I had already tried.

What actual app version are you using? what actual firmware version is on the base station?

The app is v2.34.0(75). I have no idea what you mean by app version on the base station, sorry. Where would I find that info?
I did delete and reinstall the app as well. And I have updated all firmware etc. so everything is apparently current.

Meant firmware…

ah, firmware says up to date. v4.16.3.117

My suggestion was a test one just the ONE device that has the problem. Presumably after learning the results of the test, change it back to the “new” password that works on everything except the WCO base station.


Did you happen to change the name of the wifi router?

No, it’s the same name it has always been.

You don’t need to change all your devices for the test. Just change the password, and see if it helps. If it doesn’t, change it back and we can move on. The other devices are offline a few minutes.

1 Like

Try setting up your base station from a different phone/tablet.

1 Like