How to turn on Cam Plus Lite

I just updated to the latest Beta and now it no longer shows on mine either. I go into Services, scroll to Cam Plus Lite (as you indicated), and then I see the Camera’s. I can add a camera to the mix but Manage does nothing.

I believe, if you see the Camera in the list, then it is using Cam Plus Lite. however, if you don’t you can click on Add Camera and then add the additional Camera’s. Once your Camera’s are added, then you do the rest within the Camera Settings page.

Seeing the same, my options disappeared. Mine are signed up, but sometimes a camera stops tagging for me. Turning off and back in helps sometimes.

I have a camera that was on Cam Plus, now that I canceled Cam Plus on the Camera, there doesn’t seem to be a way to use CamPlus Lite on the camera I have a few cameras that use Cam Plus and a few with Cam Plus lite and they all seem to work as advertised, but I can’t add the new camera to Cam Plus Lite. the app does give me the option to resubscribe to Cam Plus or image storage.

I’m starting to think even if you have already subscribed to Cam Plus Lite, any new camera going forward will not be automatically added to CamPlus Lite. I guess I should have read the fine print because my camera was activated and being used with Cam Plus months before the cut-off date. Can someone confirm my suspicion?

I just removed one of my CP CamV3s from my CP subscriptions thru Accounts>Services>CamPlus and changing that cam from Green Checkmarked to unassigned. then went over to the CPL list on the far right and added that cam to the CPL.

However PD DID NOT work on that cam. Verified settings and tested it with an extended walk-around up to and away from the cam.

Went back to the app and added the V3 back to an open CP subscription which immediately removed it from the CPL list.

Verified PD with Notifications sill on… Still no PD.

Reviewed the SD footage, Green tracking box the whole time.

Going to try @Megamind’s storage and cache dump and see if that fixes it.

In my case, I can see my CPL list but there’s no way for me to change (add or delete) my CPL list. I can still change my CP list but if I unassign a CP camera there’s no way to add it to my CPL list. Thank you for testing and reporting your findings. BTW, my app version is 2.28.1 (109) for Android.


Yes, I see your dilemma. I was having exactly the same issue in testing and I have the most up to date app on Android 2.28.2.111

I am pretty sure the update from your current version, 2.28.2.109 was to handle the introduction of CPL. It might make a difference to adding to CPL.

I was getting the same results as you testing it several times with cams open for assignment but no way to add to CPL:

Then I went to the webpage under my account and clicked on the add a subscription button on the manage my services page. I tried to do it several times using the EDIT link by the CPL but all failed.

I was able to get a positive confirmation that I added a CPL subscription. I entered $0. It did give me the are you sure you don’t want to give us more $$ popup, But answering NO works. You should see the confirmation at the top of the page.

With that new CPL subscription on the books, it took a minute for it to migrate servers and to show up in CPL in the app, but eventually the plus sign showed up in CPL for me to add the second cam.

I’m still waiting for the app rollout of the newest app. I even tried to manually download from the Play store but the newest version is not available to me yet. I assume I’ll eventually get it and try again. I did try to re-add the service from the website last night but I still don’t see the camera available on the CPL list. Thank you for taking the time to help me.

It might be quicker to get the updated app from a mirror site instead of waiting on the app store. Check out this post from @carverofchoice. I have grown to trust his advice.

1 Like

Seems I can’t add a cam to CLP from my Android phone or the website. I need to re-read the suggestions here but it seems to be a viscous cycle of dead ends. All of my cams are CLP except for one. I can’t find a way to manage this one cam and make it CLP. Frustrating.

1 Like

There have posts here and elsewhere about this trouble. It appears that the best success I have found is to use Android chrome to hit the website, logging into the website under your account, and adding a CPL license for $0 or more. Then going to the app and assigning that cam to the CPL.

If the license isn’t there or the cam is assigned to a license elsewhere, it won’t work.

See this:

Appreciate the help. I tried adding a CPL for $0 but couldn’t since it said I already have a license which I do. I was in the Beta program but have left it now and am uninstalling the app and will reinstall and see what happens. The cam isn’t assigned to a license.

Update… I thought I left the Beta program but when I reinstalled the app from the Google Play Store, it looks like the app is still the Beta version. It appears my devices are no longer installed in the Beta program however.

I tried several ways to get my one camera onto CLP with the other devices but again, no luck. Finally I figured I would just take a chance and unsubscribe to CLP and re subscribe. Fortunately this worked and I was able to add devices to CLP from a list of available devices. The only one I couldn’t add was my pan/zoom. Not sure why but if I feel daring I will try the unsubscribe - re subscribe method another time.

Ooof! What a process! I know you aren’t the only one having issues assigning a cam to CPL or dealing with the CPL license acquisition snags…and I have no additional suggestions. It wasn’t easy when I did it either, but I have CP on all mine, so pulling them off CP and moving them over to CPL may have unique characteristics that ppl without CP don’t experience.

As for the beta app. If you are interested I posted above the APK site where you can get the rollback app version (.111)

Same here, I was holding out hope that the newest app v2.28.2 (111) would fix the issue, but after downloading it last night I still have the same problem. No “Add Camera” button. I even removed 2 of my cameras from CP, but still no Add Camera button available under the list of CPL cameras. BTW, all of the cameras I added in February are still in my CPL list and work as expected, I just can’t add an additional camera to the CPL.

Did you go to the web site and add more licenses? That is where I found the biggest headaches. It is very difficult to actually get more licenses. The plus won’t show up unless the app is told by your account that there have been licenses added and the website is having trouble adding them to your account. It’s like the right hand and the left hand are attached to two different bodies.

I’m not having trouble with CP, my issue is with CPL. I have a few cameras with CP, five to be exact and the rest of my cameras have CPL. There’s no way to “add more” CPL licenses. I did unsubscribe and resubscribe and the app gave me a notification to assign my cameras to CPL, but my original list of assigned cameras was there, and still no “Add Camera” button. I also restarted my phone still no “Add Camera” button

I am in the same boat. I have 12 CP cams on Unlimited CP licenses. I removed a cam from CP to test CPL but couldn’t get the plus sign in the CPL to appear to put that open cam on CPL.

It took me SEVERAL attempts to ‘buy’ a license to CPL on the website. The app will NOT work to ‘buy’ a $0 license. Here is how I made it work from my post above

Keys… When you enter your $0, click somewhere off the entry line to get the popup and save button.
If you don’t see the “YOU HAVE SUCCESSFULLY EDITED YOUR PLAN” banner…you have not got the CPL license.

Yes, I did that. I saw the confirmation on the website, I got a notification on the app to add cameras to CPL and an email subject “Let’s get you set up for Cam Plus Lite” the email body gave details on how to set up CPL. I think there is a bug with the app, I was able to help my neighbor set up CPL earlier today and everything worked great on his phone. I do have a backup phone and I plan to try on it this weekend.

You have a beta badge. Is your app beta? And your neighbor not? Mine is not.

No, I currently have the standard app. I did do some beta testing on the Legacy Person detect a while back.