How can I remove codes from my Wyze Lock Keypad?

I have a Wyze Lock with a Keypad. It’s been working great, but I wanted to reset the main code (not a guest code). I went through the normal process and it added the new code, but I tested to see if the old code was removed and it wasn’t. It just added a second code.

I tried to reset the keypad by removing it, removing the batteries and then adding it back and no change. It seems the codes are stored in the lock. So, I did the same for the lock. This didn’t work either. I contacted support and they gave me the same guidance. They asked me to submit a log, but then closed the ticket because they had no answer.

Has anyone else seen this? Is there a way to do a factory reset on the lock and remove all codes?


Welcome to the forum @kevinliebl !

Sorry to hear of this issue. It has been awhile since I have changed my code so I decided to test based on your post.

I changed my code for my lock and keypad 3 different times (on 2.4 GHZ Wifi, on Mobile Data, No Bluetooth) and it worked within seconds of each change.
The old codes gave me the red fail light at the keypad and the new codes allowed me access.

I’d be happy to bounce around some ideas with you if you. Assuming you probably checked some of the below since you removed and re-added the devices and contacted support but a couple of quick thoughts…
What Mobile Device and OS are you on?
Are your Firmware versions up to date for the lock and keypad?
Wyze App Version up to date?

1 Like

Thanks for the offer. I’m using an Apple iPhone XS Max, IOS 14.8. Firmware is up-to-date. Wyze app v2.26.21.

Are you getting the confirmation page after changing the code?

Do you have guest codes setup?

Yes, it confirms the reset and shows the new code. The new code works, but it doesn’t delete the old code. No, I am not using Guest Codes.

I see that this was an issue around a year ago in another thread… @kevinliebl do you have your support ticket number? I would send a log as well from the app and get that log number. One of the forum Mavens may be able to assist.

@Brlepage or @dr.know was there a resolution to this issue not posted (Not sure if this was Android related only)? Thank you for any assistance.

Are you suggesting I post the ticket number here? I already sent the logs to Wyze. They closed the ticket because they said there was nothing more they could do and support doesn’t look at logs - only the engineers do.

I am please. We may be able to get your issue escalated with some assistance.

1 Like

The Wyze Ticket is 1604771.

Are you still having this issue?

The topic got locked (because it went 90 days without a reply and in the Beta category) so there has not been further discussion on if it has been solved.

1 Like

Yes, I am still having the issue. Bottom line - when I “reset” the code for my Wyze Lock keypad, it simply adds another code, rather than deleting the original one. I now have multiple codes that work. I can’t seem to reset it so that the old codes go away. I would love some support on this issue.

Do you have a support ticket number?

The Wyze Ticket is 1604771.

1 Like

I will try to get this looked into. Do you have the loge number too? If not, could you submit another and post the number here?