HMS 1st. gen keypad not updating (1 of 2)

It’s been 5 or more updates since late spring of 2021.

My HMS 1st.Gen “Pre Ordered 2020?” keypad, won’t take any of those updates.
The one I ordered a month or two later, updates just fine.

When I spoke to support in the fall of 2021. I answered all the questions, did all the techs, processes n then got one “Sad” email.

It was an offer to replace it, “But” ! Only if it was still under warranty !
Well my “Pre Ordered” , HMS reached me in April. It was then over a yr late in, the fall is more than 1yr.

Longevity, should be measured in Yrs “Plural” n not “Singular” .

Whatever the case, fortunately, it still works n have no idea what all the HMS keypad Updates are for ?

Has anyone else, been able to update a stubborn HMS keypad.
I’ve tried all the “Support”, Resets (Hub, Modem, App, Keypad), All the Proximity to Hub moves, including zero inches apart. All the Wyze app resets n uninstalls.

Thankfully, it still works ! Just drives me crazy, that out of all my products (10 types / 30 devices). This one, just defies updating.

Does anyone have a breakthrough tip ? That gets me to, “The Keypad” of happiness ?

Hi @BigBurly13.

What Firmware is your Wyze Sense Keypad on now? This is the device you are referring to, correct?


HMS keypad #1 Firmware -
HMS keypad #2 Firmware -

1 Like

This is purely just a shot in the dark thought… given you have talked with support and have tried all of the other troubleshooting steps.

Have you tried removing the “Happy Keypad” then attempt to update the “Un-Happy” keypad,

I don’t have multiple keypads connected to my hub (and again just a thought), but I wonder if something might be getting confused in the connection since they are associated to the Hub.

1 Like

Now that sounds like a plan worth trying !

Thx !

Hey @BigBurly13,
Curious if that approach had any resolution to your issue?

Sadly no,

I tried it last week. (Jus 4got to post the results,)

I even tried to today, but got distract by the leather strap for orig. Wyze band.
(App shopping a no go. Had to use website in desktop mode).

But great plan.

My other deleted keypad, booted n updated to the current version.

This stubborn one keypad, jus refuses to budge.

Brilliant plan, I wish it had worked !

Thx !

Thanks, another community member was running into a similar firmware update issue, not sure if they have 2 or not but it reminded me of your thread and thought I would follow up.

Well now I feel invested, if you go into the unhappy keypad device info, does the connected to match the MAC address of the Hub?

Did support have you reboot the hub in your troubleshooting?
Again thinking out loud…I wonder if a reboot of the hub would help since the keypad connects via the hub, but Rebooting the hub is somewhat a sensitive process. A false move and you hard reset the hub losing sensor connections. Which could be a cumbersome process depending on how many devices you have connected.

Don’t wanna go reconnecting all those sensors n devices with a hub reset.

But here’s the Mac Addy’s for the “Good” n “Some what Good” keypads - TMI ?


Yea, you can remove the PIC (no need to share the MAC addresses)

Under Device Info of the Keypad, their is a Field that says Connected To

The Connected to field should match the MAC address of the Wyze Sense Hub.

I was curious if both Keypads show that Wyze Hub MAC address in the Connected to Field ( I would assume so since they are connected and operating) but the one just won’t update.

If you do consider the REBOOT as a try…
@WildBill was my coach and can correct me if I am wrong here.
But the process is to

  1. Remove the Power Cable From the hub - This is the key difference in a Reboot vs. a Reset
  2. Press and Hold the Reset button for 10 Seconds
  3. Release the Reset Button When the lights go out
  4. Return Power to the Device

As I recall that’s the correct process. Luckily, haven’t had to do it for quite some time.


1 Like

Thank you, I referenced the posts multiple times before retyping :wink:

Thx Guys, I appreciate the help !

I tried it 2x,

  1. Unplug Hub, 2) hit & hold reset.
  2. Result: Only center light went out in 10 sec.
    Then hub blinked & started a zig-zag of flashing lights.
  3. I reconnected power, hub lights returned to normal.

Then I tried to update my, " stubborn keypad ", twice after each hub reset.
No dice !

What’s in all these updates, that it’s missing out on ?

Am I missing out on any of these new features ?

You may want to ask them to replace the keypad that’s at ver. .48. I checked the update webpage and .63 is listed as the initial firmware. Both of mine shipped with .63 and have never updated. Maybe you somehow got a pre-release keypad?

1 Like

Ur saying there weren’t any updates after the initial release ?

I will have to hunt down that return email.


Nice call out…


1 Like

“Nice call out” - is a good thing ?
Like a “Great catch” ?

I’m vernaculary challenged :wink:

Yes, and this may assist in a replacement. If .63 is the “initial” FW then the inference would be that possibly the patch mechanism is incomplete because that FW version was never intended to be rolled out, which is why you cannot update. Possibly, maybe :wink:

1 Like

Not that I have any “pull”, but, I have reached out to a Wyze Engineer that assisted me in troubleshooting an item in the past asking for consideration to look into this.

For good measure and if we get Wyze eyes (lol Wyze Eyes) on this. @BigBurly13 could you submit a log for the .48 (unhappy) keypad and post the Log ID number here?


Submitted today with logs
Ticket # 466910

Originally reported late 2021

Thx !

1 Like