Unable to update firmware HMS Keypad

So not sure if I’m doing this wrong, or it’s a bug, HMS being a new product.

Got the new HMS system yesterday,
It got stuck on step 2 of setup, so called tech support and they had me manually add the devices through the Home section of the app, instead of using the HMS setup.

When I select the keypad on my Android App, it says there is a firmware update.
It says to press and hold the X button on the keypad while near the base station.
I will hear a beep when it is ready.

So I’ve tried holding the X button on the keypad right next to the base station.
Held it down for a minute or two.
But nothing, no beep.
I try to click continue anyway, but it says it could not find my keypad to update it.
(Since the base station never gave the ready beep)
Even tried punching in my code on the keypad first to make sure, then hold down the X, but nothing.


Am having the same problem in updating Sense Keyboard. 40 minute setup becomes many hours and no success.

1 Like

Same here. Been trying different combinations too, like holding checkmark, or both X and checkmark. Nothing. No beep, so no firmware update.

1 Like

Still cannot update Wyze Sense Keyboard and hoping someone on this forum has a solution since Wyse support has not responded to Ticket #1165223. Also called support number and after 22 minutes they just disconnected call. Horrible call waiting music is designed to make one give up in the first few minutes.
Could this be a defective Keyboard or Software related?

1 Like

Hey folks, had the exact same issue with little help to go on and a lot of anger building inside of me.
However, I stumbled on a solution. Simply go to the main page of your Wyze app, then click/tap the + in the upper left of the screen, select add devices, select sensors and everything is listed there. Choose the Sense Hub to reconnect to it if you reset the connect on the hub. From there add all the devices you intend to add (keypad, entry and motion sensors). can even add existing sensors to the hub here.
After this is all done, go back to the main app screen and the select Home Monitoring on thhe center bottom to finish setting it all up.
Hope this helps anyone in need of support.

1 Like

I have no problem connecting Hub or Wyse Sense Keyboard. Pairing indicated as successful but cannot do final step of updating firmware from ver. to ver.
No response when I press X on Sense Keyboard as instructed.
Everything else on Sense Keyboard works as expected.

1 Like

I’m assuming its a bug on the hub, and that it can be fixed with an update. So then we can update the keypad. But no way to find out until the developers chime in.

I personally always update my devices through the app. Easiest way to make sure they are updated. So long as the device is in your list in the app, simply tap it, then select device info, then tap Firmware Version. That will show the current and update firmware(s). Just tap update on the bottom of the screen and you’re set. Hope this helps you out.

Agee that updating thru app is the normal way and most always trouble free. This update for some reason most be done with Sense Keyboard by pressing X button

Mine automatically updated after the hub updated. Make sure your Sense Hub is updated, If so, try resetting the keypad and then updating it after.

My Wize Sense Keyboard says on the app Firmware update page “Individual upgrade only” requiring holding X button and wait for beep. No hub beep heard.
My Wize Sense Hub indicates “up to date with latest version”

Have you tried resetting the keypad yet?

Yes I have reset Hub, reset Keypad, deleted and reinstalled all in HMS multiple times plus deleting Wyae appon iPhone to do a fresh HSM install always ending up with same result of not being able to upgrade Sense Keypad firmware.

Sorry I couldn’t help. Just thought I’d try helping since Wyze doesn’t even have a section for HMS in it’s support FAQ’s or anywhere. Hope you get this worked out. Hopefully they have some on hand incase something like this happened. Wish I could have been more help.

Appreciate your help and thanks.
There is a FAQ and Troubleshooting for HMS at:
No help for my current problem

Thanks to all who tried to help.
Problem solved.
Installed this latest Wyze App update, 2.19.24 and tried again to update Wyze Sense Hub by deleting and reinstalling, plus quick press of reset button along with the confirming beep, the upgrade began. Now have installed on my Wyze Sense Keyboard.

This fix worked for me also. Thanks!

Hi! I’m having the same update problem with the keypad. I tried with the latest version of Android and iOS app without results.
The current firmware version is 0.0.48. I heard the hub beep after a short press in the keypad reset button and seconds later I received a time-out notification.
I tried to reset and start again from zero with all the devices 3 times without any luck. Any ideas??

When I had the same problem Tech Support was no help when it was a true software problem. Even when the app was finally updated I had to discover it myself.
Appreciate your frustration. In addition to starting fresh try removing the batteries from the keypad, reinserting and press reset quickly. I am currently using IOS app v2.20.142 and Keypad v0.0.0.63 and Keypad functions as it should. My second Keypad purchased more recently installed without any problems.