Headphones won't connect to Echo Dot

Headphones have latest firmware (both pairs, I have 2).
Echo Dot, tried 3, 2 Gen1, One Gen2, Also up to date.
Headphones work great with everything else, phone, TV, they connect immediately.

I was so happy with them for TV listening I bought a second pair. Never thought the Echo would be a problem. I have one in my wood shop, The noise canceling on these 'phones are awesome and it all worked well with my phone. But I really like being able to control the media or ask questions (convert metric to fractions, etc) by just yelling at Alexa. So I tried pairing them with the Dot as I have with other, more inferior headphones, and it they won’t pair,

Please don’t confuse this with enabling the Alexa assistent on the 'phones, that is NOT what I want. I don’t want to have to double tap them in order to give a command. First, that has never been that reliable, and second, when my hands are busy in a project I don’t want to have to manually initiate it. I just want to yell at the device in the corner and hear the answer on my headphones. I have had numerous, cheap headphones and earbuds that this works on. But not these.

I have enabled Alexa on the 'phones, and disabled to no avail.
I have tried connecting via voice and in the Alexa app.
Again, I have tried with each pair of headphones and 3 different Dot’s, no dice.

Has anybody been successful with this and what is the trick?

Hello @Jtpryan

I had never thought about connecting headphones to an Echo dot, just larger Bluetooth speakers.
Your post made me curious to try and to see what the outcome was with my Wyze Headphones.

I was able to complete the paring in my test.

My test was with the Wyze Noise Canceling Headphones (firmware version 2.1.143), 3rd Gen Echo Dot, Alexa iOS App version 2.2.469863

First I made sure the Wyze Headphones were not connected to any other devices
Next I went into the Dot settings in the Alexa App and Bluetooth Settings in preparation to pair the Headphones
I then put the Wyze Headphones in paring mode by pressing the power On/Off / Bluetooth Pairing Button until the Headphones announced “Pairing”

The Wyze Headphones showed up as a selectable device on the Alexa Menu and I selected them, less than 5 seconds later the device paired and I was listening to music.

I am sure you did the similar steps above, so not sure if there is any difference in how you attempted to connect them vs. how I did, but I was able to get them to pair with the above. Hope this helps, if not happy to help you bounce around some other ideas.


Yes, I did the same things. But my Dots were Gen 1 and Gen2. Maybe I need a Gen 3 to do it. Funny thing is that I have connected probably 4 or 5 other different earbuds/headphones this way with no issue. Yes, I removed all of them before trying the Wyze.

**I stand corrected, I have 3 third gen dots, not 2nd gen.

Also, same problem with a Google Mini. Keep in mind, they connect fine to my phone and Sony TV.

By the way, how did you confirm they were not connected to any other devices? I don’t see that in the Wyze app.

Thanks for trying.

I removed or disconnected them from the other devices.

They were connected to a PC, I turned the Bluetooth off on that PC prior to my test.

I had also paired them to an iPhone. I disconnected and “forgot” them from that device.

Yeah, the only thing in the room they could connect to was my phone so I turned off it’s bluetooth. I could only test that by not getting a “connected” message when I powered them up. It just seems they will not connect to my Amazon or Google smart speakers. Everything else works as should.

Sorry to hear you are having troubles still.

I was pleasantly surprised about how smoothly my test went. I’ve always felt like connecting extended devices to Alexa devices had way more steps than needed, like associating a Firestick with a Echo Dot for hands free voice commands with the Firestick.

Did you check your firmware on the Wyze headphones and build numbers on the Echo Dots for any updates by chance? Not sure about the Google mini as I have amassed quite a collection of Alexa devices :grin:

I had issues connecting to my work computer. Not sure if this might work for you, but I ended up factory resetting the buds, then connecting via Bluetooth the the work computer BEFORE connecting them to my phone or in the wyze app. Then after they paired, I set them up in the app.

I have an older echo and a couple dots. I’ll try tomorrow to see what my results are.

1 Like

Yes, they all appear to be up to date. I even tried a 4th gen echo I have in the kitchen. It really is strange, the 'phones connect to everything else.

I bought the second pair of headphones just for the wood shop, so they had never been connected to anything else before I tried the shop dot. But I did do a long press on the headphones which wipes out Bluetooth memory, no luck. Is there a further factory reset I can do?

Unfortunately there is no factory reset with the Wyze Noise Canceling Headphones


Just out of curiosity, and since this is your second pair, have you tried the other pair to see if you get the same results? Just as a test,

If they do connect without issue, I would suggest reaching out to Wyze support for the pair that won’t.

Actually yes, I did try with both pairs, same thing with each. I tried both pairs with Gen1 dot, Gen3 dot, Gen4 Echo, Gen1 Spot, Google Mini. Nothing, Yet all of these devices have no problem with various BT speakers and earbuds.

I seem to remember connecting my first Wyze 'phones to the Dot in the woodshop a while back when I first got them, but I can’t swear to it. So my thought is, because both pair are on the latest firmware, is there anyway to roll back to an earlier version of the FW?

Yeah, I realize I misread what product we were discussing. I was thinking of the buds. I do have the headphones, too. I’ll see if I can get those to connect when my husband gets home with them.

There is no way that I am aware of to roll back the firmware on the Headphones at this time.

Are you on firmware version 2.1.143 currently?

Yes, I am.

Sorry I missed a few of you earlier details from above and asked a question you had already provided info on.

Suggested a Bluetooth device clear but looks like you did that too.

Maybe a factory reset on the Dot, then a Bluetooth device clearing on the Wyze headphones?

I have reached out to some additional forum members to take a look at this thread to see if they have any additional ideas.

1 Like

Did anybody get a fix for this? Used to be able to listen to my echo dot using my wyze noise cancelling headphones. After the last update, I cannot.