Buds & Alexa Devices

I have a pair of Buds and Buds Pro. Trying to use them as bluetooth device with an Echo and Echo Studio. Very frustrating. I’m able to pair with the Studio with the Pro, but when I try to pair the Buds, they are not even recognized. Conversely, I am able to pair the Buds with Echo, but not get recognized by the Studio when I try to pair. I’ve tried on numerous occasions and also restarting the echo devices. And yes, I always make sure when I try to pair that they are not connected on any other device.

I am definitely not new to pairing devices. They both pair just fine with my PC, my phone, and with my iPad. I’m open to any suggestions.

Welcome to the forum @tgkrueger

Sorry to hear of this issue. I have only done this one time in the past with the Wyze Headphones connecting to an Echo device assisting another member with almost the same scenario as you and it worked without issue.

I tested connecting an Echo Dot Gen 3 to the Wyze Buds today and I was able to connect them right up and listen to music.

Here are my resources
Wyze Buds (Black not Limited Edition) - Firmware Version 0.03.18
Echo Dot Gen 3 - Software Version 7416571268
Alexa App (on iOS 15.5) 2.2.485084 (Client Version 1.24.208447.0)

As far as process goes
I opened the Alexa App, Browsed to the Echo Dot Device and Clicked on the Add button under Bluetooth devices

With the Wyze Buds in the case and the lid opened, I pressed and held the pair button on the Wyze Buds Case for about 5 seconds until I saw the devices available in the list and selected them

The Wyze Buds showed as connected and I listened to music and gave a number of commands. All worked as expected.

Not sure if how you attempted to connect is any different than the way I explained. But check all devices and make sure they are up to date.
I don’t have an Echo studio to test on.

1 Like

I appreciate your lengthy reply. I did misspeak in my original message. It was a Dot I was able to pair my Buds with, but no other Echo device, but not able to pair my Buds Pro with the same Dot. That is the strange part. AND, I’ve only been able to connect my Buds Pro with an Echo Studio and not the Dot or other Echo devices. When I try to pair the Buds or Buds Pro using Alexa app to the devices not paired, the app does not recognize the Buds or Buds Pro. It is so frustrating.

I am happy to test more to see what my results are and if they are any different. You are half motivating me to get an Echo Studio (Prime days are coming up so I am sure it will be on sale) and the Echo Show 10 is 70 dollars off right now :smiley: Can’t tell if the Show 10 is a Echo studio with a screen or the Echo Sub Woofer with a screen

I will test the Wyze Buds Pro with (Pick one or more of what I have)
Echo Show
Echo Show Gen 2 10.1 HD
Echo Show 5
Echo Show 15
I also have a Fire HD 8 (Gen 8) with the Show Mode Dock (Basically turns the Fire Tablet into a Show Device)

A multitude Firesticks and Fire TVs. As well as the Gen1 and Gen2 Fire Cube.

1 Like

Don’t bother with the Show. I have not tried the Fire because I’ve found while listening to books with it, the audio goes for a short time and just stops - doing research I’ve found this is a known issue with the Fire.

I tested this device since it was sitting on my desk { Fire HD 8 (Gen 8) with the Show Mode Dock (Basically turns the Fire Tablet into a Show Device) } and was able to use the Wyze Buds Pro as a speaker source.