Wyze buds will not pair with app on android nor ios

I am not able to connect these wyze buds to my note 20 ultra even is i put my phone on a 2.4gz network or even try over the 4g 5g connection. My home mesh nomrallly is 5gz and even that doesnt work it says make sure you are connected to the internet. They dont even show up on my iphone when i look for bluetooth devices. Now whats crazy is on my android the bluetooth can see them but the app cant and if i connect to them directly via bluetooth it says you need an app to make them.work so even when you click connect they wont connect. This is my second pair both are doing the exact same thing
I have done the clear cache force close the app reset the headsets nothing works. So even if there is a fw update i cant eveb get them.connected to downmoad it.


Since i can o ly post one photo at a time

Here is another one

So as you ca. See the bluetooth of the phone sees the buds but the app will not connect to them


Any suggestions

The iphone is running ios 17.5.2

The android is samsung note 20 ultra on android 14

They dont show up on bluetooth on the iphone at all and on the note the show up but the app cant see them. And con ecting to them directly through the phone it says you need an app to use them

Sorry to see you are having issues connecting your Wyze Buds.

Out of curiosity, have your tried disconnecting any other Bluetooth devices connected to the phones while connecting the buds?

I remember in the past there were some connection issues especially with a Smartwatch connected to a phone.

I just started having this problem last night. It started with my phone not registering that the Wyze Buds Pro had been put back into the case and would still keep the Bluetooth connection active, while also only registering that the Left bud was out of the case and would not connect to the right bud. I deleted the device from my phone and the Wyze app and I now get the same error when trying to perform the setup through the Wyze App. I can connect them to bluetooth, but it still does not register the right ear bud and the Wyze app still won’t see them there.

I’m using a Pixel 8 Pro on Android 14, along with the current Beta build v2.50.2 (442)

A few days ago, my Buds would connect to my Android (Go edition) tablet and momentarily show the battery capacity notification on screen, but then I wasn’t getting audio through them when I would begin playing a YouTube video.

After several rounds of putting them back in the charging case and trying again, I put them in the case and pressed the Bluetooth pairing button and tried to re-pair them to the tablet. During that process, I saw “LE-Wyze Buds” show up on the available device list (as illustrated in one of @icanthearyou2k8’s screenshots), and I didn’t recall seeing that label before. When I let the tablet chew on it a little more, it presented me with a dialog about Google Fast Pair, which I also don’t recall seeing previously. Whatever I did with that (I think I accepted or approved something) seemed to do the trick, and I was able to use my Buds after that.

I apologize for not providing better detail. I hadn’t experienced that issue before, so it seemed unusual to me, and then I saw this topic in the Forum, so I’m chiming in at this point basically to track the issue (yes, I know I can track a topic without commenting). If I see a recurrence and have to go through a re-pairing process again, I’ll try to grab some screenshots.