Wyze headphones won't finish pairing with the ios app

My headphones stopped responding to touch commands and the noise-cancelling seems to be less effective. I figured updating the firmware would fix this.

So, I opened the app which I haven’t used in almost a year and could not get the app to connect to my headphones. So I removed the device. This then brought a new problem. The app would find my headset and would pair, but would never get to the point where it would ask you to cover the right panel. Instead it will ask to select an accessory which I do, and then will say headphones found, only to take me back to the select an accessory page.

I have tried uninstalling the app, forgetting the headphones, and restarting my phone but nothing seems to fix the problem.

Hello @HamSam and welcome to the community!

Are you using an Android device, if you are and the Android version is 12+ can you go into the permissions for the Wyze app and make sure ‘Nearby devices’ is set to allow?

1 Like

I’m using Apple IOS 15.5

Can you try to connect on another device? Also try turning Bluetooth off and back on for about 10 seconds on your phone.

Happened to me today - just received them.

-Hold the power button long enough to clear the devices list.
-Shutdown the headphone with a single power button click.
-In the iOS settings app, in the Bluetooth section, select the Wyze headphone and “forget the device”.
-Return to the Wyze app and add a new device. Select the headphones.
-When asked for pairing, press the power button once.

Don’t press and hold to activate pairing until requested.

Should be good to go.

1 Like

That has been how I’ve been doing it, but then I get stuck on the “Select your headphones” screen.

It does the same thing on my Ipad, even after I cleared the bluetooth list (on the headphones) and forgotten everything (on the device).

It pairs but does not progress to the hand over right side page, it just gets stuck on the select device. If I hit the pair button again I get stuck in the loop, if I don’t then nothing pops up in the list (I did leave it open for half an hour and nothing happened.)

You sure the headphones aren’t connected to a different device or aren’t turned off? See if they show up in your normal Bluetooth settings on your iPad.

Pretty strange. I never saw this screen.

Did you try this exact sequence?

  • Close Wyze app.
  • Reset the BT list in headphones (long power button press until voice prompt).
  • Forget the BT device in iOS.
  • Shutdown headphones (short button press and voice prompt confirmation).
  • Start Wyze app.
  • Power headphone (one short button press and voice prompt confirmation).
  • Add device in Wyze app then, select “Headphone”. Do not press-hold headphones button to pair.
  • Wait for app to fail adding.
  • Press “Retry”.
  • Press-hold headphones power button to enable pairing and make sure you hear “pairing” audio cue.
    At this point, the whole thing worked for me.

They have been performing excellently since.

Actually, I see a headphones icon in the corner of your screen. I think they are already connected, or something else is which may cause it to not let you connect these.

Yeah, that’s the problem. I can connect to the phone just fine, but it is connecting to the app which is the problem. I think it might have something to do with the fact that I can not use the touch controls or something.