Google Home + Wyze Plug issues since AWS outage

I have two Wyze plugs that I automate with Google Home routines. Simple on-time, off-time rules, nothing fancy. I prefer to use Google Home rather than the Wyze app since I have other devices to control, too.

Before the 12/15 AWS outage, my Google Home integration worked flawlessly.

After the outage, my routines run OK perhaps 50-75%, and the rest of the time I get a Google Home notification saying “1 action may need your attention”, and Google Home reports “Sorry, I couldn’t reach Wyze Home”. If I open Google Home on my android device, I can usually control the plugs manually, suggesting a brief outage or problem with the automation rather than direct control.

I’ve unlinked and relinked Wyze within Google Home and I’ve signed out/in to the Wyze app. This problem seems to be server-side.

Anyone else experiencing similar? Wyze, if you’re listening, any idea what’s going on? Plugs that I can’t turn on and off reliably are basically useless.

[Attached photos show 1 rule that failed and one that worked, 15 min apart]